bfgDeveron
Dogfish
Dogfish
1,934 Posts

Post Your Lost Civilization Tech Issues Here Only!

[Post New]by bfgDeveron on Nov 6, 13 8:42 AM
Thanks for getting this started deejae101. I'm going to go ahead and sticky this thread so others can find it.

If you are having problems getting the game to work correctly, we highly recommend going to our Help pages. Using our Help pages is always the quickest way to get technical problems resolved. Here are a few suggested articles that have helped many people correct these types of problems in the past:

Game Crashing, Freezing, or Blank Screen
Game Compatibility

While we can offer a known solution for technical issues in the Forums, or other tech savvy pond residents can swim by with good tips and suggestions, we cannot provide the same excellent level of support provided by our Customer Support team.

The Forums are not very well suited for the kinds of information gathering and troubleshooting that get these types of issues corrected quickly.

If there is a problem with the game, our Support Team can also gather necessary information on what types of computers are being affected by the problem and deliver this information to the developer for a fix.

If you are not able to get a game working properly using our Help pages, please get in touch with our Customer Support team, you can find a link to contact our Support team on the front page of our Help pages.

When posting in this thread and also when contacting our Support Team, it would be helpful if you could state what system you are playing the game on (i.e. PC, MAC or Mobile), so we can provide you with the appropriate support as quickly as possible.

*Finally, please reserve this thread for tech issues only. If you are seeking game play assistance (i.e. hints and tips), the best thing to do is to start a new thread in the game's Forum by clicking on 'Create New Discussion.'

 
belamba
Angelfish
Angelfish
1,058 Posts

Re:Post Your Lost Civilization Tech Issues Here Only!

[Post New]by belamba on Nov 6, 13 10:49 AM
Playing on 2013 MacBook Pro OS X Mavericks (all latest operating system). Got to a HOS with a skip. Peace sign on top of skip that is needed, but cursor turns to a hand constantly. The hand opens and closes the lid, so not sure how anyone is supposed to get the sign. Even tried turning off custom cursor but still won't work.

Given up now. Every game I've bought this week has glitched and I'm losing the will to live (

 

Re:Post Your Lost Civilization Tech Issues Here Only!

[Post New]by LuvDemGames on Nov 6, 13 10:58 AM
Got stuck in a scene and couldn't get out; I had to close the game down and when I went back it was still stuck in that spot.

 
JulieJay
Catfish
Catfish
1,555 Posts

Re:Post Your Lost Civilization Tech Issues Here Only!

[Post New]by JulieJay on Nov 6, 13 1:59 PM
I noticed from the very start that some of the words were blurred (menu/play/options and place names on map) although the dialogue was totally legible. However, I got to my first HOP and had to quit - I couldn't even read the list of items I was supposed to find.

 
pandab10
Jellyfish
Jellyfish
12 Posts

Re:Post Your Lost Civilization Tech Issues Here Only!

[Post New]by pandab10 on Nov 7, 13 6:04 AM
The game was in such slow motion I couldn't play it

 
wwhitley56
Seahorse
Seahorse
27 Posts

Re:Post Your Lost Civilization Tech Issues Here Only!

[Post New]by wwhitley56 on Nov 7, 13 6:13 AM
I can't install the game,its says a newer version of Microsoft Visual ++2010 redistritutable has been detected on my machine. please help!!

 
Darkaddict25
Squid
Squid
61 Posts

Re:Post Your Lost Civilization Tech Issues Here Only!

[Post New]by Darkaddict25 on Nov 7, 13 10:23 AM
I do like this game but it has terrible lag. I know my computer exceeds the requirement.So what gives. I did disabled Aero went to windows basic mode. It still laggy. I am playing the game regardless. The HOGS seem to load up fast.

 
bfgDeveron
Dogfish
Dogfish
1,934 Posts

Re:Post Your Lost Civilization Tech Issues Here Only!

[Post New]by bfgDeveron on Nov 7, 13 1:23 PM
If you have a lag in your game, or if it's running slowly, I'd recommend turning off the custom cursor. That can be done from the Options menu in the Main Menu. If you're in the game, click on 'Menu' on the left-hand side and then 'Options' and make sure the custom cursor box is unchecked.

LuvDemGames. I'd recommend uninstalling and reinstalling the game to make sure everything has downloaded correctly to your computer.

JulieJay, I'd suggest checking for updates on your computer, to make sure everything is as up-to-date as possible. You can find help for that HERE

wwhitley56 and belamba (and if my suggestions above don't work), our dedicated Tech Support Team is here to help and can offer more specific suggestions to help out with issues like this.

I hope this helps!

bfgDeveron

 
roaming
Clownfish
Clownfish
644 Posts

Re:Post Your Lost Civilization Tech Issues Here Only!

[Post New]by roaming on Nov 8, 13 12:41 AM
The demo kept freezing up forcing me to do a C-A-D and restart. Each time it froze up in a different place. The last time it was in the HOS at the artist's stand. After that I gave up.

 

Re:Post Your Lost Civilization Tech Issues Here Only!

[Post New]by tiredoftrouble on Nov 9, 13 4:46 AM
I reinstalled and it still will not even start. I have had no trouble with any other games that was downloaded. I will not download for 2nd time or purchase a defective game. It freezes on the 1st scene, it did this same thing the first time I downloaded it.

 

Re:Post Your Lost Civilization Tech Issues Here Only!

[Post New]by texasokie on Nov 20, 13 1:54 PM
I had the same problem with C++???

 
 
 
 
Go to: