bfgFlounder
Moderator
Moderator
12,864 Posts

Post any Build-a-Lot: The Elizabethan Era technical issues here only

[Post New]by bfgFlounder on Jul 14, 10 12:38 AM
If you are having problems getting the game to work correctly, we highly recommend going to our Help pages. Using our Help pages is always the quickest way to get technical problems resolved. Here are a few suggested articles that have helped many people correct these types of problems in the past:

Frequent Crashing of Game
Game Compatibility

While we can offer a known solution for technical issues in the forums, or other tech savy pond residents can swim by with good tips and suggestions, we cannot provide the same excellent level of support provided by our Customer Support team. The forums are not very well suited for the kinds of information gathering and troubleshooting that get these types of issues corrected quickly. If there is a problem with the game, our Support Team can also gather necessary information on what types of computers are being affected by the problem and deliver this information to the developer for a fix.

If you are not able to get a game working properly using our Help pages, please get in touch with our Customer Support team, you can find a link to contact our Support team on the front page of our Help pages.

 

Re:Post any Build-a-Lot: The Elizabethan Era technical issues here only

[Post New]by foreverblue127 on Jul 19, 10 6:22 PM
Hello,

On level 9 it tells you that you need to employee 5 workers. And yet when I do train 5 workers it does not check off. It constantly says one more needed. I have even trained ten workers and still nothing even though I have completed the other tasks.So I have not been able to move on to the next level.
Thank you!

 

Re:Post any Build-a-Lot: The Elizabethan Era technical issues here only

[Post New]by pythongirl on Jul 20, 10 9:50 PM
Is one sick?

 

Re:Post any Build-a-Lot: The Elizabethan Era technical issues here only

[Post New]by NaomiJameston on Mar 21, 11 11:16 PM
Every time I try to load the game (after the first time I downloaded it), it refuses to load past the first screen and kicks me back to my desktop. The only solution I've found so far has been to reinstall the game, which is annoying. Am I just doing something wrong when I'm trying to open the game? I mean, it'll open just fine and it will show the "loading" page, but once that finishes, it won't go to the actual game and forces me to close it out. What am I doing wrong?!

 
MNHawk
Seahorse
Seahorse
28 Posts

Re:Post any Build-a-Lot: The Elizabethan Era technical issues here only

[Post New]by MNHawk on Mar 27, 11 10:48 AM
Running win7 64 bit ultima
ATI 5640 PCIex
LED HDMI 32" TV

I normally don't have any problems with graphics on big fish games
But this one seems to do nothing but CRASH

Def a no buy KILLER for me

And if this is how BF games are going to go, then I will also drop BF all together cause the support sucks and the games are getting CRAPPY

 
Vickibenj
Jellyfish
Jellyfish
11 Posts

Re:Post any Build-a-Lot: The Elizabethan Era technical issues here only

[Post New]by Vickibenj on Aug 6, 11 8:23 AM
I had it crash just a couple of times while playing the campaigns, but now I'm playing casual mode, the second one crashes every time when I'm about halfway through. It isn't my video card, not my computer because it's only happening on level 2 of the casual play. I don't suppose support has a patch or some kind of fix available?

 
cel_1
Seahorse
Seahorse
33 Posts

Re:Post any Build-a-Lot: The Elizabethan Era technical issues here only

[Post New]by cel_1 on Jun 26, 12 1:42 AM
i am having trouble starting this game whenever i try to start game i have to get my task manager up and it says the game is not responding. i have had this game a long time and had no problems playing until recently. i have no problems with other big fish games, i have loads, this seems to have just happened the last few times i have tried to play it. please can you help me

 

Re:Post any Build-a-Lot: The Elizabethan Era technical issues here only

[Post New]by michel1957 on Sep 17, 13 4:50 AM
I cant delete the high scores for the casual game.
(It stops at 20 high scores per town and i cant put any more in the list.)
I already uninstall and reinstalled the game.

 
 
 
 
Go to: