Mac Version Not Working?

[Post New]by dyermaker on Nov 24, 10 2:02 PM
I have been having tons of trouble with this game. At first, I created a female character and then when I hit 'Start' I got a message saying something about the file not being found. So I ran it again and did not do anything to the character except give it a name and clicked 'Start' and ran through the beginning. As soon as I got to the first screen, it told me to click my character and drag him to talk to someone. However, I could not see my character and I could not move around the island at all. I tried going through it a couple more times but I had the same problem each time.

Anyone else having this issue?

 
bfgArnoStyx
Stingray
Stingray
5,877 Posts

Re:Mac Version Not Working?

[Post New]by bfgArnoStyx on Nov 24, 10 2:33 PM
Hey dyermaker,

Welcome to the pond! I do have a couple suggestions that might help with the game:

First, please make sure that all the latest updates are installed on your Mac. For that, you can simply click on the Apple button in the upper left-hand corner and manually launch a Software Update.

It might also help to run the following update as well:

Software Update

If you're still running into issues, please get in touch with Mac Support. To do this, you can click on the green envelope to the right of the screen, and then click "Contact Us" (bottom left) of the next page to reach the online web form. To submit the web form, first click "Check for Answers" to visit the Help pages, and if you still can't find an answer, you will then be able to click the "Submit" button to send your ticket to our reps.

If you're a Big Fish Game Club member, you can connect to Live Chat for real-time support through your "My Game Club" page. Chat hours are Monday through Friday 9:30 AM to 4:30 PM PST.

Hope this helps!

-bfgArnoStyx

Edited on 11/24/2010 at 2:36:05 PM PST


 

Re:Mac Version Not Working?

[Post New]by GrannyGorgeous on Mar 8, 13 12:30 PM
Hi there,

First, let me thank you for good games and support!

But...
I purchased this game mid october 2012. Since I knew and loved the game already, having played it on my former computer (PC), I just bought it without downloading the 60 mins free trial version first. My bad. Too excited.
I was (still am) unable to play it on my mac (OS X Lion), and I was told there would be an update or a patch or something available within weeks, and I should keep an eye on the forum for it.
It's been almost 5 months now, and still no updated version, patch or anything... or did I miss it? I did do a search before posting this (ofcourse ) but can't find anything other than this thread.
Is the Lion-friendly version/patch in the pipeline, was it dropped, did I miss it, or something else?

Best Regards,
Maria

Edited on 03/08/2013 at 12:32:39 PM PST


 
bfgIzara
Flounder
Flounder
2,151 Posts

Re:Mac Version Not Working?

[Post New]by bfgIzara on Mar 21, 13 12:20 PM
Hey there GrannyGorgeous and a warm welcome to the Pond!

I'm so sorry to hear that there's still an issue getting your game to work. You're totally right and there has yet to be an update.

I've checked in with our Mac experts here, and it seems that some games that were previously released, like Escape From Paradise 2, are having some conflict with the way that OS X Lion plays games. It's nothing wrong with your system but just the way the game was originally designed.

One of our Mac Support specialists will be happy to go over some options for the game with you, as well as help with any other questions you may have.

Just click here to submit a support ticket via email. If you're a Big Fish Game Club member you can also connect to Live Chat Support Monday-Friday 7:30am-4:30pm PST.

I hope this helps to explain things a little better and happy swimming!

bfgIzara


 

Re:Mac Version Not Working?

[Post New]by Joli123 on Aug 10, 13 1:11 PM
Every time i try to play it it quits unexpectedly. I try to reopen it and it loads but then does it again. Its really frustrating and upsetting because i bought the game but cant play it.

 

Re:Mac Version Not Working?

[Post New]by steffy91 on Sep 20, 14 11:15 AM
I'm getting really frustrated with this game. I bought it because i liked the online version but it is not even working. What is the point?

It literally just loads... well it's says "loading" but it never those.

My system is fully updated by the way at 10.9.5 yet it refuses to load.

I have deleted and re-downloaded the game various times.

But yet it refuses to work

I just want it to work

Help!!!

 
 
 
 
Go to: