634 Posts

Post any World Mosaics technical issues here only

[Post New]by Mamalita on Jul 21, 11 10:10 AM
I can't play World Mosaics on my computer. I had to play it on my husband's computer. Supposedly, according to other discussions elsewhere, this may be because I have the Wacom pen tablet installed on my computer. The other three World Mosaics and Gemsweeper all work on my computer. World Riddles works on my computer also.

Edit: typos

Edited on 07/21/2011 at 4:43:34 PM PST

Sea Anemone
Sea Anemone
5 Posts

Re:Technical Issues

[Post New]by MsAva on Jul 21, 11 4:14 PM
I too have a WACOM tablet and could not use this game.

3,712 Posts

Re:Post any World Mosaics technical issues here only

[Post New]by bfgHondo on Jul 21, 11 4:44 PM
Hey fishies, thanks for getting this tech thread started! I'll go ahead and sticky it to the top of this forum page.


If you are having problems getting the game to work correctly, we highly recommend going to our Help pages. Using our Help pages is always the quickest way to get technical problems resolved. Here are a few suggested articles that have helped many people correct these types of problems in the past:

Game Crashing, Freezing, or Blank Screen
Game Compatibility

While we can offer a known solution for technical issues in the forums, or other tech savvy pond residents can swim by with good tips and suggestions, we cannot provide the same excellent level of support provided by our Customer Support team. The forums are not very well suited for the kinds of information gathering and troubleshooting that get these types of issues corrected quickly. If there is a problem with the game, our Support Team can also gather necessary information on what types of computers are being affected by the problem and deliver this information to the developer for a fix.

If you are not able to get a game working properly using our Help pages, please get in touch with our Customer Support team, you can find a link to contact our Support team on the front page of our Help pages.

*Please reserve this thread for tech issues only. If you are seeking game play assistance (i.e. hints and tips), the best thing to do is to start a new thread in the game's Forum by clicking on 'Create New Discussion.'

31 Posts

Re:Post any World Mosaics technical issues here only

[Post New]by comcruiser on Oct 19, 11 10:19 PM
How do you use the hints e.g. the eyes on the right when plaing this game?


Re:Post any World Mosaics technical issues here only

[Post New]by makesmiles on Feb 24, 14 7:58 PM
I downloaded the trial game but the cursor does not show up in the game. I am running windows 8. I uninstalled the game and reinstalled it but that did not work either. Please help.


Re:Post any World Mosaics technical issues here only

[Post New]by Twinkles63 on Mar 31, 14 7:59 PM
I've had problems with the cursor not showing up when playing on my laptop. So I bought a new (cheap) computer and all the games I couldn't play before now work correctly. I think that the video card in my laptop wasn't built for gaming but a PC has much more room and even a cheap computer can have a bigger video card. So that solved the mouse problem for me.

But now I have another problem. When I played World Mosaics on my new (Windows 8) computer, I left the game to play a different one, then went back to World Mosaics the next day, but had to start over! It is not saving my game progress! I thought I did something wrong, but it happened again! I have not dared to exit the game to play a different one in case my game progress is reset again and I've gotten pretty far! I would like to leave the game to lay something else without having to start over every time! Anybody know how to fix this?!

19 Posts

Re:Post any World Mosaics technical issues here only

[Post New]by Bebalovo on Aug 14, 14 2:04 PM
World mosaic for iPad has stopped loading, used to work but no longer does. After the Big Fish logo and the Faguso logo, the World Mosiacs page loads with the loading progress box sitting there blank. Nothing messages, just sits there.
I have tried deleting the game and reinstalling. Nothing I have tried has worked.

Go to: