bfgImbrium
Moderator
Moderator
4,236 Posts

Post any 1912: Titanic Mystery technical issues here only

[Post New]by bfgImbrium on Aug 10, 11 12:52 AM
If you are having problems getting the game to work correctly, we highly recommend going to our Help pages. Using our Help pages is always the quickest way to get technical problems resolved. Here are a few suggested articles that have helped many people correct these types of problems in the past:

Frequent Crashing of Game
Game Compatibility

While we can offer a known solution for technical issues in the forums, or other tech savvy pond residents can swim by with good tips and suggestions, we cannot provide the same excellent level of support provided by our Customer Support team. The forums are not very well suited for the kinds of information gathering and troubleshooting that get these types of issues corrected quickly. If there is a problem with the game, our Support Team can also gather necessary information on what types of computers are being affected by the problem and deliver this information to the developer for a fix.

If you are not able to get a game working properly using our Help pages, please get in touch with our Customer Support team, you can find a link to contact our Support team on the front page of our Help pages.

*Please reserve this thread for tech issues only. If you are seeking game play assistance (i.e. hints and tips), the best thing to do is to start a new thread in the game's Forum by clicking on 'Create New Discussion.'

 

Re:Post any 1912: Titanic Mystery technical issues here only

[Post New]by papillion727 on Aug 13, 11 11:15 AM
Just downloaded the Mac version for trial. In the lifeboat area HOG scene I could see the doll on the left and tried to click her face, body, legs, etc. The "hint" indicated that was indeed the doll but I couldn't click on it.

Dumped it in the trash. I didn't think the game was up to BFG standards anyway.

 
cirig
Jellyfish
Jellyfish
15 Posts

Re:Post any 1912: Titanic Mystery technical issues here only

[Post New]by cirig on Aug 14, 11 1:21 AM
I also just downloaded the Mac demo. In the HOG scene in the dining room, I'm unable to click on the game pieces. The hint shows I'm clicking the correct item, but it doesn't work. Looks like this kind of thing is a problem in other locations, too. Any suggestions?

Edited on 08/14/2011 at 2:07:01 AM PST


 

Re:Post any 1912: Titanic Mystery technical issues here only

[Post New]by Old_Man_River on Aug 26, 11 10:31 AM
I'm having a problem trying to buy some games. Since the new game Manager has been installed, several games have given me problems after the trial. I try to purchase the game by clicking on the buy button, but nothing happens. The screen is not frozen, and I can do anything with in the computer except buy these games.A hard restart does nothing, even shutting down for 15 minutes does not help.

 
bfgArnoStyx
Moderator
Moderator
5,877 Posts

Re:Post any 1912: Titanic Mystery technical issues here only

[Post New]by bfgArnoStyx on Aug 26, 11 10:54 AM
papillion727 and cirig,

Please take a look at the following help article for some troubleshooting steps that might help:

Mac Game Errors

Old_Man_River, you may want to see if uninstalling and reinstalling the Game Manager might be helpful. Here's a help article with those steps:

Uninstall / Reinstall Game Manager

If you're still having troubles, please get in touch with Tech Support and our reps can definitely assist you further. Thank you!

-bfgArnoStyx

 
MsAva
Sea Anemone
Sea Anemone
5 Posts

Re:Post any 1912: Titanic Mystery technical issues here only

[Post New]by MsAva on Aug 26, 11 2:01 PM
I can not see the cursor in this game. I have had problems with other games not recognizing the Wacom tablet mouse and/or pen. I tried a reinstall and using a regular mouse to no avail.

Any suggestions?

Thanks!

 
care___916
Clownfish
Clownfish
951 Posts

Re:Post any 1912: Titanic Mystery technical issues here only

[Post New]by care___916 on Aug 26, 11 10:28 PM
In one of the beginning scenes I am in a restuarant, have found all items except one handbag after clicking on it several times I used a hint and it did cirlce the handbag I cannot click on it to pic it up even after using a hint.

Cannot purchase even at a DD price if stuck.

I have win 7 and a new computer.

Happy gaming to other fishies

 
Heartisan
Jellyfish
Jellyfish
17 Posts

Re:Post any 1912: Titanic Mystery technical issues here only

[Post New]by Heartisan on Aug 27, 11 1:39 AM
Ok, I have two problems in this game I haven't seen yet. One is probably a setting on my part, and one is the game.

First one is on my big monitor, the game goes off screen to the right a bit. I can see enough of the menu buttons to click them. And the game, well some of the hidden objects I can't reach. I've never had this problem with another game or anything for that matter. All the settings as far as I know are right since again, nothing else does this. I did try playing with display settings a bit, but no change. But I put it on my notebook and it was fine.... as far as that issue goes.

I played on the notebook through the trial. I had just started the second set of rooms, in fact I had clicked on a room and it was loading when my time was up. I liked the game. Sometimes I like the easier to find ones for a change for my eyes, and this one has an interesting story to follow, so I went ahead and bought it (by the time I did I had to use one of my codes because it had just changed while I was playing and wasn't DD anymore).

When I got it installed, I went to play again, and it is stuck on the first set of rooms that I had already finished. They all have the completed check mark in them, so I can't go into any of them to see if I could get it to keep going. Did the reinstall nothing changed, so now I used a code, and I can't play it on either machine.

I would like to be able to play it on my bigger monitor, because of my eyes, some games the HOs are harder to see than others, and this one was in some spots so the big screen would be better if I can figure out how to get it centered.

Please help... send e-mail if you like. This problem doesn't fit with anything I've been able to find in help so it needs the human touch

Thanks in advance
Jewel

 

Re:Post any 1912: Titanic Mystery technical issues here only

[Post New]by Wiley04Little on Jun 29, 12 9:45 PM

Edited on 07/02/2012 at 2:17:13 AM PST


 

NO cursor and have tried everything...HELP!!

[Post New]by godfreygirl on Jul 13, 12 8:08 AM
I have a big problem with Titanic....no cursor!! The PC version.
I've been wanting to play this game because it looks like it has great graphics and I love HO games. I'd probably buy it IF I could play it first. I contacted customer service AND did the "Chat Online".....they were GREAT and gave many suggestions via email, but no one has been able to help as yet. I did everything they told me to do and the cursor is still not there. I even uninstalled it and then reinstalled it AND now the game won't even start at all when I click on "play". VERY disappointing!!! I think maybe it's a glitch in the game that they need to fix. It looked like a fun game and I'd love to play it.....too bad. I haven't uninstalled it yet though.....just in case I get another email from tech support with the fix to the problem. Maybe you may have some solutions.....you think?

Edited on 07/13/2012 at 8:09:53 AM PST


 

Re:Post any 1912: Titanic Mystery technical issues here only

[Post New]by antiquejewel on Oct 28, 12 4:39 PM
Like some of the others, I have no cursor. I have a touch screen monitor that I can use, but on a desktop computer this is awkward and slow. I am very disappointed that I bought a game that cannot be played. How can this problem be corrected?

Please help.

 
 
 
 
Go to: