Windows 7 fix for access violations

[Post New]by Athealis on Oct 14, 11 11:47 PM
For those of you running windows 7, and having an access violation error or a game freeze upon starting a new game:

Go into your game folder, which should be wherever you have it set to save your bigfish games. For me it's /bigfish/avalon. Basically, it is where the REAL exe file for the game exists, not the shortcut. there will be a folder called assets. Open in, and remove the folder called cutscenes. You can back it up if you want, whatever, but move it OUT of the assets folder. This should fix the problem. You will not see the game's cutscenes, but who cares? At least you will be able to play it now, hopefully.

-Athealis

P.S. this is NOT an official fix, i discovered this on my own after much frustration about not be able to play the game, with no real viable fixes. One user suggests installing directx 7, which is actually impossible to do on windows 7.

 

Re:Windows 7 fix for access violations

[Post New]by Puzzling on Oct 15, 11 2:48 PM
I get the error code 803400 when I try to install the game. I have a new computer and can't get my purchased Avalon to install. It gets to the point where I have to activate the game and then I get the code. I tried the fix below, but it still won't activate. Any ideas?

 

Re:Windows 7 fix for access violations

[Post New]by Athealis on Oct 15, 11 11:38 PM
yes, i think I might know what's wrong. The avalon installer tries to install a very old flash directx version, which is incompatible with windows 7. I'd imagine that it's what's causing your crash. I didn't have that problem because i had a newer version of directx installed, and it just skipped that part of the installation.

So here is my suggestion: download and install latest version of adobe flash, then download and install latest direct x (which should be 11)

THEN install the game, THEN apply my fix by deleting the cutscenes folder. Let me know if this works.
-Ath

 
Katems
Seahorse
Seahorse
22 Posts

Re:Windows 7 fix for access violations

[Post New]by Katems on Dec 2, 11 2:19 AM
I'm on Vista and after doing all the other suggested fixes (updating drivers, changing compatibility, etc) Avalon STILL wasn't working.

I am happy to say that deleting the cutscene folder worked! That is so silly. I don't know how you figured that one out but I am so greatful!!!

 

Re:Windows 7 fix for access violations

[Post New]by LkGrgGrrl on Feb 17, 12 11:57 AM
Removing the cutscenes folder worked for me until I got the Water Artifact and then the error came back again.

 
 
 
 
Go to: