Re:Welcome to Treasure Seekers: The Time Has Come forum

[Post New]by mebowman on Mar 11, 12 5:08 PM
I want my money back. I can get to 3 screens and it keeps telling me to jump to another time and I'm stuck.

 

Re:Welcome to Treasure Seekers: The Time Has Come forum

[Post New]by Classicaljazz on Apr 9, 12 12:56 PM
I am stuck on the "rotating wheels" door puzzle in the Yucatan, Mexico, chapter of this game. I tried every possible position for the wheels and cannot get the puzzle to match the stones in the frames on both sides at once.

I finally downloaded the walkthrough. It was no help, for the screenshot shown there is impossible to achieve in my game. SPOILER WARNING. When I match up my stones with the red design in the frame on the left, there is no stone with a green design directly across from it on the right side of the larger rotating ring to match up with the green one in the frame on the right. END OF SPOILER.

I'm wondering if my game has a glitch.

Anyone else having this problem?

Classicaljazz

I'm editing this to insert spoiler warning... and also to add that I finally had to skip the puzzle mentioned above. When I did, it confirmed my suspicion that this puzzle in my game has a glitch. SPOILER WARNING: I say this because when I hit "skip", it showed the solution (which was exactly the same as the one shown in the walkthrough with the stone with a distinctive red design directly across from the stone with the green design). Since my larger rotating wheel did not have a stone with a green design across from the correct red stone, it was, indeed, impossible to solve the puzzle myself to move on in my game.


Edited on 04/11/2012 at 7:45:37 AM PST


 

Re:Welcome to Treasure Seekers: The Time Has Come forum

[Post New]by playmonkey on Apr 19, 12 5:39 AM
I am on Chapter 3 - Scotland and still looking for the 6th lily or fleur de lys....I am being told to use the magnifying glass to find it but the only place I can use it is the graveyard and nothing is showing up....is there a glitch in the game or can someone please tell me how to get the last lily? I've already gone through the walkthrough and that was not helpful. Thanks.

 
Meandy40
Guppy
Guppy
142 Posts

Re:Welcome to Treasure Seekers: The Time Has Come forum

[Post New]by Meandy40 on Jul 18, 12 8:16 AM
So far I haven't seen anyone with this problem so here goes. I am in Chapter 4 Yucatan, Mexico. In the yard in the HOS. The last item for me to find is a sledgehammer and I cannot find it anywhere. Every time I click on the hint I am told I have to go to another time. For a HOS??? I did go ahead and try it and still nothing because every time I click hint I am told to try another time. I can't paint the idol or do anything else. had a similiar problem in the temple and had to restart the location but then it worked fine.

 
 
 
 
Go to: