bfgBaikal
Marlin
Marlin
8,624 Posts

Post any Echoes of the Past: The Kingdom of Despair technical issues here only

[Post New]by bfgBaikal on Sep 11, 13 1:35 AM
If you are having problems getting the game to work correctly, we highly recommend going to our Help pages. Using our Help pages is always the quickest way to get technical problems resolved. Here are a few suggested articles that have helped many people correct these types of problems in the past:

Game Crashing, Freezing, or Blank Screen
Game Compatibility

While we can offer a known solution for technical issues in the Forums, or other tech savvy pond residents can swim by with good tips and suggestions, we cannot provide the same excellent level of support provided by our Customer Support team.

The Forums are not very well suited for the kinds of information gathering and troubleshooting that get these types of issues corrected quickly.

If there is a problem with the game, our Support Team can also gather necessary information on what types of computers are being affected by the problem and deliver this information to the developer for a fix.

If you are not able to get a game working properly using our Help pages, please get in touch with our Customer Support team, you can find a link to contact our Support team on the front page of our Help pages.

When posting in this thread and also when contacting our Support Team, it would be helpful if you could state what system you are playing the game on (i.e. PC, MAC or Mobile), so we can provide you with the appropriate support as quickly as possible.

*Finally, please reserve this thread for tech issues only. If you are seeking game play assistance (i.e. hints and tips), the best thing to do is to start a new thread in the game's Forum by clicking on 'Create New Discussion.'

 
bajacalla
Guppy
Guppy
135 Posts

Re:Post any Echoes of the Past: The Kingdom of Despair technical issues here only

[Post New]by bajacalla on Sep 11, 13 10:29 AM
unplayable for me. just like the CE, the game doesn't fill the screen, is cut off at the bottom, and has a pretend menu bar at the top. no tech support has helped. I've written directly to Orneon telling them of the problem; maybe they'll write me back.

 
arthurC
Parrotfish
Parrotfish
424 Posts

Re:Post any Echoes of the Past: The Kingdom of Despair technical issues here only

[Post New]by arthurC on Sep 11, 13 12:17 PM
I'm having a similar problem. Except I can only play it when I unclick 'full screen' .. which isn't the best of gaming experiences. On top of that, the game cursor is clunky and prone to freezing for seconds at a time.

It's a huge pity because it looks like a great game .. first decent one in over a week.

I'm not going to go through the tedious process of checking everything, all my other games play ok.
I just won't buy it.
Jo

 
moonwitch1
Seahorse
Seahorse
31 Posts

Re:Post any Echoes of the Past: The Kingdom of Despair technical issues here only

[Post New]by moonwitch1 on Sep 11, 13 3:50 PM
I bought this, only to get immediately frustrated as the same old "requires security key" message popped up on both games I got today. I don't know why all of a sudden every game I'm buying is doing this, and sometimes I'm having to wait two and three days to get a key to play.

 
emery419
Guppy
Guppy
114 Posts

Re:Post any Echoes of the Past: The Kingdom of Despair technical issues here only

[Post New]by emery419 on Sep 11, 13 8:24 PM
I cannot play the game because it won't even open! This happened with the CE version, too. I thought maybe it would be fixed for the SE. I have really liked the series, but there's no way I can purchase something that won't even play. I'm using Mac OS 10.6.8. Uninstalling and reinstalling does not help; I tried 3 or 4 times with the CE. There must be other Mac gamers who don't even bother to report that a game doesn't work; I can't be the only one having this problem. Other games work fine on the same computer. Maybe if it ever comes out for iPad, I'll try that one.

 
bfgBaikal
Marlin
Marlin
8,624 Posts

Re:Post any Echoes of the Past: The Kingdom of Despair technical issues here only

[Post New]by bfgBaikal on Sep 12, 13 2:20 AM
Hi folks!

For those of you with display and/or performance issues, have you checked your screen resolution and updated your drivers already?

If not, I would suggest trying to make those adjustments as the first port of call.

If that fails, I would encourage you to work with Tech Support Team so they can offer some more dedicated support.

emery419 - as opposed to the links I have offered above, you might want to have a look at our Mac specific help page here?

Finally, moonwitch1 - The request for a security key is often associated with some major change to your computer. Some modifications can prompt the Game Manager to request a security key for one or several of your games as well.

To obtain the necessary key to gain access to your games, please get in touch with Customer Support and one of our Reps will be happy to help!

There is some information that you can include in your email that will help us to generate the code(s) right away and the process for collecting that can be found in the following help article:

Security Key Error

Hoping this helps!

bfgBaikal

Edited on 09/12/2013 at 2:21:23 AM PST


 
whoanelly
Jellyfish
Jellyfish
16 Posts

Re:Post any Echoes of the Past: The Kingdom of Despair technical issues here only

[Post New]by whoanelly on Sep 12, 13 4:56 AM
Items went into inventory very, very slowly. Even with system cursor everything was far slower moving than it should be. My driver is current and I have done everything I know to do to get this to play. Also had even more trouble with the CE trial version. It would hardly run at all. This game is just not working right for me and after all the other issues I have had and back and forth with tech support I thought all my issues were finally fixed. I think this one is the game itself. It is one I will not be buying. I am really sorry about this for I have all the others in the series and was hoping this one would be just as great.

 
bfgDeveron
Dogfish
Dogfish
1,934 Posts

Re:Post any Echoes of the Past: The Kingdom of Despair technical issues here only

[Post New]by bfgDeveron on Sep 12, 13 10:12 AM
Hey whoanelly,

It does sound like this would be disappointing, especially as you enjoy the series.

If you'd be open to it, I'm sure one of our Reps could take a closer look at your system and see if we can find a way to help this game run a bit more smoothly. To contact our Tech Support Team, just click on the blue Help link on the top right-hand side of your screen and then 'Contact Us' on the bottom left.

I hope this is resolved for you quickly!

bfgDeveron

 
phisherman
Guppy
Guppy
164 Posts

Re:Post any Echoes of the Past: The Kingdom of Despair technical issues here only

[Post New]by phisherman on Sep 16, 13 11:40 AM
I thought the days of developers putting out slow sluggish games with slow jerky cursors were over. I guess not. I have a brand new computer with Windows 8 and am also having this problem. It has been a problem since the CE version. Too annoying to bother with buying this game.

 
grammakk
Seahorse
Seahorse
25 Posts

Re:Post any Echoes of the Past: The Kingdom of Despair technical issues here only

[Post New]by grammakk on Sep 17, 13 1:28 PM
was really looking forward to this game have all the others. says not supported on my computer have to shut down to get out..am reinstalling again to try again did all the updates as recommended was okay not a problem with any other game though in the past had 2 games did the same thing drivers updated etc. run as admis. not working. see how it goes when done downloading again really want this but may have to end up with a credit. Sigh ...

 
bev4ron
Jellyfish
Jellyfish
15 Posts

Re:Post any Echoes of the Past: The Kingdom of Despair technical issues here only

[Post New]by bev4ron on Sep 17, 13 2:58 PM
Playing on a PC. Reached the point where I was to put the toy table set on the table in the children's room. Focusing on the table the magnifying glass swings instead of remaining still and will not hold the close up. Blinks back and forth between close and far so I can't place the toy set on it. At this point the hint button doesn't work either.
Any suggestions?

 
letsdoit
Shark
Shark
10,483 Posts

Re:Post any Echoes of the Past: The Kingdom of Despair technical issues here only

[Post New]by letsdoit on Sep 18, 13 12:58 AM
Basically having same tech issues as others posted here. Game did d/l fine, after hit play that was the problem started, it was a black border on top, right side, bottom. So decided to mess with it instead of just deleted it, so changed up the screen, ratio aspect, etc. but to no change at all. Went to barely find the edge of the 'exit' and clicked on it. O.K. will not exit. Did go to task manager but game was 'not running', very odd?
So did a hard shut down. Restarted and immediately deleted from C drive and searched for all pending 'hang ons' to delete from anywhere the game landed in other places. Its a 'no buy' on the SE!
What strange I did demo of CE, played fine. I have all the series of this game so was a wee bit excited to play. At this time a CE is not in my budget. Do have a few PCC to use and thought this was a possibility to finally use one!
That's it on this subject and will 'maybe later' check if there may be a 'fix'.
Lets...

 

Re:Post any Echoes of the Past: The Kingdom of Despair technical issues here only

[Post New]by dramat27 on Sep 22, 13 7:39 PM
Playing on a Mac - using the lastest OS update.

Having the exact same issue as Emery419 -

With both the SE and the CE, the game downloads, I click on it, game manager opens and the game itself won't (error message is that it "quit unexpectedly")

The Mac-specific help page does not address this issue.

 
Mac_too
Starfish
Starfish
46 Posts

Re:Post any Echoes of the Past: The Kingdom of Despair technical issues here only

[Post New]by Mac_too on Sep 23, 13 1:26 PM
Playing on a Mac with no problems until I lost my player profile twice. First time, had just started the game so I played over again from the beginning. Second time, I was more than half way through and my player profile disappeared. Not willing to start again or play the whole game in one sitting. Uninstalled and reinstalled twice - no effect.

 
bfgSeine
Stingray
Stingray
5,158 Posts

Re:Post any Echoes of the Past: The Kingdom of Despair technical issues here only

[Post New]by bfgSeine on Sep 23, 13 3:54 PM
Hi everyone,

If you're seeing problems with the game display or if the game is crashing or coming up black or not loading properly, please check out our help article here that has some recommendations on it:

Game Crashing, Freezing, or Blank Screen

If certain items in the game are not working, it can sometimes help to uninstall and reinstall the game itself. You can find information on doing that here on our help article:

Uninstall / Reinstall a Game

If those recommendations aren't helping, or if you'r seeing a different type of problem, please let our Tech Support Team know so they can look into your issue. They'll be happy to help out!

bfgSeine

 
cbellcrm
Clownfish
Clownfish
818 Posts

Re:Post any Echoes of the Past: The Kingdom of Despair technical issues here only

[Post New]by cbellcrm on Oct 2, 13 1:25 AM
When I started to play I had a big black bar on the right-hand side of the screen but the left-hand side of the picture was missing - including the journal and the menu button. I tried again and clicked on Aspect Ratio under settings. I have no idea what Aspect Ratio is, but it solved my problem.

 
GrammyZ
Jellyfish
Jellyfish
15 Posts

Re:Post any Echoes of the Past: The Kingdom of Despair technical issues here only

[Post New]by GrammyZ on Jan 11, 14 11:57 AM
I'm in the Knight's Virtue and am stuck. I have put the shield on the knight, but the screen keeps telling me that the shield won't be found by me just standing there. I have a feeling this is a technical issue, not that I didn't find something. I'm playing on a PC Windows8. Drivers are all up-to-date. I usually keep on top of that. Any help would be appreciated.

 
 
 
 
Go to: