in Wickfields den

[Post New]by co2reb51 on Feb 9, 15 12:11 AM
In Wickfields den I have done everything and I click the hint and it will show a ring around a box setting by the chair. When I put my cursor anywhere around the chair and click nothing happens. I have tried going into other areas and when I hit hint and follow the hints it will take me right back to the den and that box. I have nothing in my inventory that has worked so I'm completely stumped. Right now it looks like the game is bad in that area. If anybody knows what I need to get past that area your help will be completely grateful.

 
JoFin
Guppy
Guppy
106 Posts

Re:in Wickfields den

[Post New]by JoFin on Feb 20, 15 6:55 PM
If this is the area where the box has criss crossed belts, you need to add the three key parts to the center to remove the belts and then sort the animals. Nothing happens until you add the three key parts, that look move triangular and wooden to me.

 

Re:in Wickfields den

[Post New]by MygramaCarol on Mar 2, 15 7:05 PM
I am having the same problem, but, I have opened the box & retrieved the nozzle but the hint keeps taking me back to the box, The problem is when I click on the box nothing happens.

 
 
 
 
Go to: