Welcome to Westward forum

 
bfgDonau
Flounder
Flounder
2,464 Posts

Re:Welcome to Westward forum

[Post New]by bfgDonau on Apr 20, 11 10:31 AM
Hi jellybeanyz!

I just wanted to swim by to say that I've added a response to your post here. Since this issue is specific to Westward II: Heroes of the Frontier, I'd recommend continuing the discussion in that thread in the Westward II: Heroes of the Frontier Forum.

Hope this helps!

-bfgDonau

 

Re:Welcome to Westward forum

[Post New]by victoria2102 on Jul 14, 11 9:08 AM
Brilliant game, ive loved playing everyone in the series, well worth buying

 
GeorgeTSLC
Manatee
Manatee
3,919 Posts

Re: Welcome to Westward forum

[Post New]by GeorgeTSLC on Sep 9, 11 8:42 PM
Actually, bfgDonau, the answer is generic, no matter what the game is: Check out the general Help posts, and if they don't work, contact Customer Support.

 
AliKat611
Starfish
Starfish
44 Posts

Re:Welcome to Westward forum

[Post New]by AliKat611 on Oct 30, 11 11:33 AM
I played the online version of this for a while and I thought it was cute so I downloaded the demo. First I couldn't move anyone around--online (and as it says in the tutorial) left-clicking on the person and dragging them was the way to do it. It wouldn't work. Finally tried right-clicking and that worked. Annoying, but no big deal. I'm now trying to build the first gold mine and it won't let me. I click on the mine in the building tab and the placement I choose is fine but it won't work. I built it fine in the online version so I don't understand the problem now. I'm following the instructions, but it just won't work. Two issues in less than the first 10 minutes of the tutorial? Guess I'll be deleting this one.

Edited on 10/30/2011 at 11:34:49 AM PST


 

Re:Welcome to Westward forum

[Post New]by my_turn on Jun 14, 14 3:55 PM
Does anyone know of any other games that are like the westward series?

 

Re:Welcome to Westward forum

[Post New]by cynthiap15 on Dec 5, 14 7:25 PM
I'm sure no one comes to this forum anymore, but I'm still playing my games and I need help. The hidden treasure in Hope River is my last task and I cannot find the treasure. I have rescured Maureen, paid the ransom and took all the gold from the bandits. The treasure task is still up there. I've tried to follow the clues and have even tried to follow the directions given in the forum and nothing works. If anyone is still around, any suggestions?

Thanks

 
 
 
 
Go to: