wind generator and battery

[Post New]by periwinkle_sky on Apr 7, 15 5:24 PM
I'm in Chapter 5: Brandon. I've gotten to the point where I place the wind generator in the yard to blow away the fog, but it needs the charged battery to do that, which I have in inventory.

I've tried clicking around the generator, but the cursor won't change to a hand to allow me to do that. I've clicked all around the generator, in the grass around it, I've tried just dropping the battery around and on the generator, and nothing works. All I get is the message, "I can't use that here" or something similar. The generator is so low on the screen that often I click the Inventory drawer or change to the bridge by accident.

Is this a bug? Am I just not clicking the right spot?

ETA: I just went back to the game and the generator has sparkles and a little light on it (yeah, I'm playing Easy Mode), and I've tried and tried clicking all around it, moving the cursor all around it, but nothing! I'm about to lose my mind on this one. I can't go ahead in the game until I get this done. (First world problems, lol )

Edited on 04/07/2015 at 5:35:10 PM PST


 

Re:wind generator and battery

[Post New]by periwinkle_sky on Apr 7, 15 7:21 PM
Okay...I uninstalled and reinstalled the game, as per the instructions in the Technical Issues thread above. (I didn't look there first because I didn't think it was a technical issue, I just thought I was doing something wrong or overlooking something obvious.)

I never did get the magnifying glass or anything else to come up, but I did pick up the battery and "dropped" it on the generator, which brought up the close-up window. I was then able to hook up the battery.

I'll just leave all this here in case someone else has the same problem.

 
 
 
 
Go to: