voodoo doll

[Post New]by rosflickan on Jun 16, 15 6:27 AM
I am playing the very first hidden object scene and I can´t find the doll to put the needles in to make the voodoo doll. In the walkthrough the doll is shown in the right bottom corner of the crate. There are no doll there only a rope and no matter how many hints or clicks on the area nothing happens. I have also tried to restart the game but still no doll. Please help.

Edited on 06/16/2015 at 6:27:48 AM PST

9,130 Posts

Re:voodoo doll

[Post New]by bfgBellerophon on Jun 17, 15 8:13 AM
Hi rosflickan,

I'm so sorry to hear that when playing the first hidden object scene in this game, the doll seems to not be where the walkthrough states. Definitely doesn't make things fun.

It may be helpful to look at the following help article to check that your video graphics card is up to date.

Game Crashing, Freezing, or Blank Screen

If you are still having issues after trying the troubleshooting steps in the above help article, please reach out to our Technical Support Team with a Dr. Felix Report. They can help investigate this further for you.

Since this is more of a technical issue, moving forward we ask that they be placed in the following thread:

Please post any TECH ISSUES for Mystery of the Ancients: Curse of the Black Water here

Thanks for your understanding. Since this has been addressed, I'm going to go ahead and lock this thread. Feel free to PM any of the moderators if you have any questions.


Go to: