bfgBellerophon
Marlin
Marlin
9,130 Posts

Please post any TECH ISSUES for Royal Envoy 2 Collector's Edition here

[Post New]by bfgBellerophon on Jul 13, 15 8:21 AM
Hey there Everyone,

If you are having problems getting the game to work correctly, we highly recommend going to our Help pages. Using our Help pages is always the quickest way to get technical problems resolved. Here are a few suggested articles that have helped many people correct these types of problems in the past:

Game Crashing, Freezing, or Blank Screen

Game Compatibility

While we can offer a known solution for technical issues in the Forums, or other tech savvy pond residents can swim by with good tips and suggestions, we cannot provide the same excellent level of support provided by our Customer Support team.

The Forums are not very well suited for the kinds of information gathering and troubleshooting that get these types of issues corrected quickly.

If there is a problem with the game, our Support Team can also gather necessary information on what types of computers are being affected by the problem and deliver this information to the developer for a fix.

If you are not able to get a game working properly using our Help pages, please get in touch with our Customer Support team, you can find a link to contact our Support team on the front page of our Help pages.

When posting in this thread and also when contacting our Support Team, it would be helpful if you could state what system you are playing the game on (i.e. PC, MAC or Mobile), so we can provide you with the appropriate support as quickly as possible.

*Finally, please reserve this thread for tech issues only. If you are seeking game play assistance (i.e. hints and tips), the best thing to do is to start a new thread in the game's Forum by clicking on 'Create New Discussion.'

bfgBellerophon

 

Re:Please post any TECH ISSUES for Royal Envoy 2 Collector's Edition here

[Post New]by CanonicalKoi on Aug 9, 15 1:52 PM
Running the game on a MacBook Pro, OS X 10.10.4, all drivers up to date.

The whirlpool for entry into the Expert level is missing. I've uninstalled and reinstalled it while nothing else is running on my computer (no foreground and only essential background processes) and still no luck.

I normally have the Game Manager set to automatically check for updates, but went ahead and tried manually as well--nothing.

Other than a complete and total lack of an Expert level, the game (Adventure) and all Challenges play just fine, just no Expert level to be found.

ETA: I maxed out on gold stars on all the Normal mode Adventure levels and Challenges and still didn't get the whirlpool.

Edited on 08/09/2015 at 1:56:28 PM PST


 
 
 
 
Go to: