Cannot complete the steps

[Post New]by Nels1cin on Dec 1, 15 7:27 PM
Not sure what I did wrong in the Apothecary there was a trunk that I opened and was supposed to put together the three steps. The top one went on then the bottom one and it will not allow me to pick up the 3rd board! I've tried exiting and going back in, I've tried uninstall and reinstall. Nothing has worked. Any suggestions?

 

Re:Cannot complete the steps

[Post New]by maria3e09 on Dec 2, 15 11:36 AM
help me to continue with the steps of this game

 

Re:Cannot complete the steps

[Post New]by EMERALDLILYCUTIE on Jan 12, 16 5:55 PM
HELP!

I'm in the SAME situation where I cannot complete the steps of the game until I finish collecting ALL the items that is in the Top House of the Street Fair location.

I've collected ALL items except the 'poisonous mushrooms' and the 'Ax'. It seems I need to put the stick which looks like the handle for the broken ax head BUT every time I pick up the handle to attach it to the broken ax head --- it doesn't come through --- WHY?! And I'm having the same situation with the poisonous mushroom.

There is a metal tweezer and the poisonous mushroom which I believe the tweezer is use to pick up the poisonous mushroom BUT every time I use the tweezer to pick up the mushroom ---- it doesn't go through WHY?!

Is it something I'm missing or doing wrong; please respond because I really want to FINISH this game.

Thank you

 
 
 
 
Go to: