JB4510
Guppy
Guppy
199 Posts

Anyone able to run this on Win 764bit?

[Post New]by JB4510 on Jan 6, 16 4:07 AM
I posted in Tech thread but am just curious as to if anyone else is having trouble running the game on Windows 7 64bit. I've done everything and it simply will not launch.

 
angelfish106
Pufferfish
Pufferfish
1,378 Posts

Re:Anyone able to run this on Win 764bit?

[Post New]by angelfish106 on Jan 6, 16 5:07 AM
I'm running Win7 Professional 64-bit on a desktop PC and the game plays perfectly.

 
dueler
Guppy
Guppy
190 Posts

Re:Anyone able to run this on Win 764bit?

[Post New]by dueler on Jan 6, 16 5:27 AM
Running windows 7 home 64bit, no trouble what's so ever here, maybe your graphs card ?, maybe need to clear your cache out ?, but don't ask me, I only read what people have said in the past, hope this helps.
happy gaming.

Edited on 01/06/2016 at 5:28:33 AM PST


 
bfgPanthalassa
Flounder
Flounder
2,450 Posts

Re:Anyone able to run this on Win 764bit?

[Post New]by bfgPanthalassa on Jan 6, 16 4:13 PM
Hi JB4510,

I'm sorry to hear that you've been having trouble running the game.When a technical issue comes up, we encourage taking a look at our help articles. The following help article has steps that are useful in a wide range of situations, including this one:

Game Crashing, Freezing, or Blank Screen

If the game still isn't running, we recommend contacting our Technical Support Team HERE with a Dr. Felix Report. Any of our Reps are happy to help, and have the tools to gather data on and report this kind of problem.

Since this is a technical problem, I'm going to go ahead and lock this thread. I understand you also posted in the Please post any TECH ISSUES for Roads of Rome: New Generation here. thread, which is exactly what we recommend. Keeping technical issues in this thread helps the Forum Moderation Team keep track of trends and make sure they're reported to the right team.

Thank you for your understanding.

bfgPanthalassa

Edited on 01/06/2016 at 4:13:57 PM PST


 
 
 
 
Go to: