Problems with Rasputin's Curse

[Post New]by hotbowler178 on Jan 28, 10 9:51 AM
My specs: Dell Dimension 9100, 4GB Ram, Windows 7 Home Premium 64 bit, video card, NVidia 9500 GT.

Problem: Open Game Manager to play game (1 hour trial) and game will not start. Icon goes to task bar at bottom of screen, click on it, sometimes screen comes up, stays on for about a second and returns to task bar. Screen resolution changes to something like 600X800 (large).

Possible solution: Close program with task manager. What I have noticed is that if I close my browser (Firefox Ver 3.6) the game will load and play with no problems. This was not noted with previous versions of Firefox so it may just be a problem with this version. Tried this with IE8 and game loads and plays with this browser on (minimized).

This same problem occurred with a game I tried last week (The Sultan Labyrinth) and someone noted in that forum that by restarting their computer they were able to load and play the game. In effect, turning off the browser.

Info has been passed to tech support. Hope this helps.

 

Re:Problems with Rasputin's Curse

[Post New]by nancybbh on Jun 11, 10 9:24 AM
My problem with this game is at the luggage office. I can't get the last key. The walkthrough says to click on the door to open, The key is behind this door. I know I'm in the right place. The door will not open when I click on it. I've done everything Big Fish said to do: installed newest Adobe Flash and Shockwave. I also uninstalled and installed the game. Any ideas? I have a Mac. I've not had any problems with games for the year I've owned the Mac.


 
 
 
 
Go to: