13 Posts

Manor Memoirs Collection

[Post New]by snow24 on Sep 24, 16 3:20 PM
Why can't I get any help? I have tried and tried and no one helps me. I had Manor Memoirs Collector's but when I sign on, it closes big fish. It won't play at all. I have uninstalled it and then installed it. What is the problem?

3,807 Posts

Re:Manor Memoirs Collection

[Post New]by bfgIlinalta on Sep 27, 16 1:40 PM
Hello snow24,

I first want to apologize that it has taken a while for one of us to swim by and assist. It sounds like there's some trouble signing in to the Big Fish Games app as well as playing your purchased games. I am sorry to hear that this is happening and want to say that it is not our intention to seem like we're not helping out. We definitely don't want you to be stuck with games you are unable to play and I wanted to drop by with how to receive more help.

The forums, unfortunately, do not have the tools to help with this particular issue you are experiencing and I would like to recommend reaching out to our Technical Support Team HERE with a Dr. Felix Report. The Dr. Felix Report should allow our representatives to look into why there has been trouble playing your games. Our Reps can gather data on and report issues to the right team, can provide support beyond the forums, and they're always happy to help.

If you receive a response that doesn't seem to assist with your specific request or your issue was not resolved, please be sure to reply directly to that message to signal our representatives that you still require personalized assistance. This will ensure you do not lose your place in queue and that we can get you the help you need by working with you closely to make sure that you can play your purchased games again.

Since this is a technical issue, I am going to go ahead and lock this thread and request that future technical issues be reported to the recreated technical issues thread here: Please Post your TECH ISSUES for Manor Memoirs Collector's Edition here.

Thanks for your patience snow24, and I hope this was able to help out,


Go to: