How are artifacts used

[Post New]by tractorfeed on Oct 13, 16 6:34 AM
In the other Weather Lord games you're given a chance at the beginning of each level to choose which artifacts you want to use. I've "found" a number of artifacts but never get to choose to use them. The rain cloud in particular regenerates so slowly and I'd like to use the artifact to speed it up.

 
nwl43
Stingray
Stingray
4,931 Posts

Re:How are artifacts used

[Post New]by nwl43 on Oct 13, 16 12:26 PM
After the discussion by Olivia and Victor you will get a pop up showing your artifacts. Click the circle next to the ones you want to use. You can use 3 at a time.

 
Eileen266
Jellyfish
Jellyfish
10 Posts

Re:How are artifacts used

[Post New]by Eileen266 on Oct 14, 16 7:34 AM
there are no circles that allow me to choose the artifacts.

 

Re:How are artifacts used

[Post New]by tractorfeed on Oct 14, 16 9:59 AM
Yes I never see the popup to choose the artifacts after the initial dialog. This is different than other weather lord games. It seems like that step is just missing.

 
nwl43
Stingray
Stingray
4,931 Posts

Re:How are artifacts used

[Post New]by nwl43 on Oct 14, 16 12:55 PM
My artifacts are shown at the beginning of every level right after the dialogue between the characters. Click the artifact to choose and a green arrow appears in the small circle next to the artifact. If you want to remove in order to choose a different one, click the arrow. Very odd that you don't get this. Major glitch I guess.

I don't remember first level where I gained an artifact and don't remember if the pop up was there before finding the first one.

 
nwl43
Stingray
Stingray
4,931 Posts

Re:How are artifacts used

[Post New]by nwl43 on Oct 14, 16 1:08 PM
I just started with a new profile and the artifact pop up does not show until you have gained your first artifact. After you gain the first one it pops up and the play button for the level is at the bottom.

 

Re:How are artifacts used

[Post New]by wendyeth on Oct 15, 16 5:51 AM
I'm having the same problem. From the map menu, I can click on a bar and see my artifacts and learn what each one does, but in the level there's no circle or green arrow or anything after the dialogue. The level just begins.

I'm on a Mac. For the people that it works...are you on a PC? Maybe it's a glitch in the Mac version.

 
nwl43
Stingray
Stingray
4,931 Posts

Re:How are artifacts used

[Post New]by nwl43 on Oct 15, 16 5:55 AM
I'm using a PC and it's working fine.

 

Re:How are artifacts used

[Post New]by tractorfeed on Oct 15, 16 6:16 AM
I'm on a mac and it doesn't work for me.

 
Phoebe06
Seahorse
Seahorse
22 Posts

Re:How are artifacts used

[Post New]by Phoebe06 on Oct 15, 16 12:59 PM
I'm also on a Mac running OS 10.12 Sierra. I can look at the artifacts from the Map and choose only one. But when I press play and after Olivia, or Victor speak the level begins. I think this is why I can't get into L39. I must need more than one artifact to go forward.

 
stratacatQ
Lobster
Lobster
90 Posts

Re:How are artifacts used

[Post New]by stratacatQ on Oct 15, 16 9:47 PM
While I found it a bit confusing at first on how to select the artifacts within the level pop ups, I do indeed have them. I didn't understand at first how to select or how many but once I figured it out, & replayed levels, it helped a ton!

 

Re:How are artifacts used

[Post New]by tractorfeed on Oct 18, 16 8:59 AM
stratacatQ wrote:While I found it a bit confusing at first on how to select the artifacts within the level pop ups, I do indeed have them.


I'm guessing you're on a PC. Those of us on Macs don't even see the level popups. This is a big problem for the Mac version of the game.

 
meemawsue
Jellyfish
Jellyfish
12 Posts

Re:How are artifacts used

[Post New]by meemawsue on Oct 20, 16 5:46 PM
Another Mac user here. I can/t find a way to choose artifacts either.

Edited on 10/21/2016 at 7:23:56 AM PST


 

Re:How are artifacts used

[Post New]by brianax3 on Oct 25, 16 2:53 PM
I am having the same problem (also on a Mac). It makes it impossible to beat level 39. Has there been any fix to this?

 
 
 
 
Go to: