bfgIlinalta
Moderator
Moderator
3,807 Posts

Please Post your REVIEWS for Return to Mysterious Island 2: Mina's Fate here.

[Post New]by bfgIlinalta on Nov 13, 16 2:00 PM
Howdy Everyone,

Welcome to the reviews thread! Please feel free to post your thoughts and feedback on Return to Mysterious Island 2: Mina's Fate here. We appreciate the time you take to put your reviews together, and I know other gamers and the developers do as well. We just have a few guidelines to keep in mind when posting. Our goal with these is to keep the thread tidy, easy to navigate and helpful.

Review Guidelines

1) Be sure to keep your reviews on-topic. Reviews in this thread should only be commenting on Return to Mysterious Island 2: Mina's Fate.

2) Be respectful of the reviewers. Please keep in mind our Forum Rules and be respectful of our reviewers. They take the time to post here to be helpful. Please do not review the reviews of others.

3) Do not respond to someone else’s reviews with questions or comments If you have any feedback about a review, or you feel that a review contains incorrect details about the game, please contact the poster directly via PM.

4) Do not review developers. While we do appreciate your feedback, we’d ask that you keep your posts in this thread dedicated to the specific game at hand.

When posting reviews please be courteous and refrain from posting spoilers. If in the event that a spoiler is needed, please remember to post with white text and a warning. .

*Moderators will be removing any content in this thread that is not a review.

If you have any questions or concerns, please feel free to PM one of our Moderators.

bfgIlinalta

 

Re:Please Post your REVIEWS for Return to Mysterious Island 2: Mina's Fate here.

[Post New]by Aussiechick23 on Mar 10, 17 2:45 AM
Hi,
I have tried to play this game but it won't load. It successfully installed, ready to play but when it starts, the big fish logo starts to fade and then FREEZES. Nada, nothing, and it is TERRIBLY FRUSTRATING when you have paid for a game and it DOES NOT WORK. I have uninstalled and reinstalled, the result is still the same at the same spot. Please reply as I have sent an email about this before and am still awaiting a reply.

 
 
 
 
Go to: