game stopped working

[Post New]by mostlynoob on Sep 17, 17 9:29 PM
Hi All,

Not sure why the technical issues thread has been locked so I'm going to post my issue anyway and see what comes.

Installed Windows 10 about 8 months ago, about the same time I bought and installed The Sapphire Dragon on PC-CDROM. All had been working fine until a month ago when this game stopped loading, all that appears is a black screen and the JQ cursor.
Followed the HELP links 'Game Crashing, Freezing, or Blank Screen" but have had no luck following the steps, the link to the support team is broken too.

I have a DELL Inspiron One 19A running Windows 10 Home (64-bit).
Updated OS recently and pretty damn sure all systems are up to date.
Have an Intel R G41 Express Chipset (Driver/Date/Size: 3/11/2013 10:00:00am).

I have tried to update the Graphics Driver to Intel G41 Express Chipset Windows 7 (64-bit) 8.15.10.2869 but the system doesn't meet the minimum requirements. Tried the Graphics Driver for Intel G41 Express Chipset Windows 7 (32-bit) 8.15.10.2869 and got the same error message. I ran the Dell System Detect and it said my driver was up to date and the best one for my system.

I am running older versions of this game fine and I have installed Jewel Quest 7 and it is running without issue either.

If anyone has any ideas on how to solve this issue or had the same issue and found a fix then I'd appreciate hearing about it.

Many thanks in advance.

 
 
 
 
Go to: