Posts created by OrionsRose

 
 
 posted in Slingo Quest Amazon on Feb 5, 13 5:23 PM
There didn't really seem to be an ending to this game. Wasn't I supposed to get Joker back once I defeated the devil? I'm puzzled.
 
 
 posted in Awakening: The Skyward Castle Collector's Edition on Feb 2, 13 12:35 AM
I just have to say thanks to the devs for the hilarious nod to Mythbusters (specifically Adam Savage). That made me laugh out loud! I was having a bad week and now I can't stop smiling so thank you so much!
 
 
 posted in Slingo Quest Amazon on Dec 31, 12 3:16 PM
I have an issue that no one else seems to have had. I have the newest build so maybe it happened in that and wasn't present in the earlier builds.

The glitch is that in the Jaguar duel level the bonus frogs randomly give the points to the wrong player. Doesn't happen ever single time but it's fairly often. Sometimes the Jaguar gets my points, sometimes I get his. Frustrating when you're trying to get a star for 50,000 points. I'm not far enough into the game to know if this issue will repeat itself in future duel levels.
 
 
 posted in Christmas Stories: Nutcracker Collector's Edition on Dec 28, 12 11:04 AM
Ok I see I'm not alone in this glitch. I did not get the gold statue for not using skips or hints either. I am 100% sure I didn't even accidentally use them and since several of us are reporting it there must be a glitch there. Bummer, the achievements are fun to work on and often the reason (or at least in part) why some of us like CEs.
 
 
 posted in Running Sheep: Tiny Worlds on Nov 10, 12 2:36 PM
Once you get the hang of it this is actually a wonderful, addictive little game.
That said, getting the hang of it had me cursing a lot for a while because turning the arrows was difficult until, almost magically, it suddenly worked for me nearly every time (there's a bit of a trick to them) and I was off and running...pun intended! Then I couldn't get enough. I stretched it out as long as I possibly could and was sad when I realized I was all done.

Some levels are insane (50! but there's actually an easy trick to that one) but most are just a nice challenge. Yes, the timer is a pain but you can still get the purple ribbon even if you're down to the last second so don't give up. The main thing is getting all the wolves in the black hole, collecting the coins, and getting the sheep to the barn. Time left on the timer only matters for your score (and progression), not the ribbons.

Tips:
- Arrows are reusable. Just grab them and put them where you need them next after they've been used the first time.
- If you're struggling with a particular level, take the time to look at the picture of the level (on the screen where you can choose which level to play) and strategize.
- Coin positions change if you replay a level so keep in mind your strategy may have to change. If you think you've got ones that are just too time-consuming to get, hit replay until you find a configuration you like.
- If you're struggling just to pass a certain level, just do your best to get the sheep to the barn - you can always go back later and replay for the wolves and coins once you have a better feel for the level (and sometimes have taken a break with some easier levels).
- Sheep (and wolves too I think) seem to always turn right when they hit a wall or tree so you won't need extra arrows if you plan carefully.
- Each new set of 50 levels gets progressively harder, meaning you get a bit of a breather for a few levels each time you reach a new location (though there are sometimes new things to learn).

Most importantly, have fun! It really is an awesome game if you give it a chance!
 
 
 posted in The Game of Life ® on Oct 26, 12 11:28 PM
I was so looking forward to this game but as most everyone has said the issues with viewing it make it a no buy before I've even gotten a chance to try it. Heck I got stuck in the settings page and couldn't get out! I'm completely shocked that BFG is letting these games on their website...what happened to some quality control?! It's basically unplayable for many of us in it's current state and frankly in this day and age of technology it's ludicrous that this should be considered an acceptable way to present a game. New builds are required of some games with major issues and this should be one of them.
 
 
 posted in Monopoly ® on Oct 8, 12 3:42 PM
It absolutely does cheat. It's completely improbable for the AI to get doubles and land on GO as often as it does and yet...
Also, gets adventageous Chance or Community Chest cards nearly every time but I get all the awful ones plus it virtually never lands on tax spots but I do constantly.
 
 
 posted in Monopoly ® on Oct 8, 12 3:39 PM
Same problem as a few folks with the dice being black. Of course during the demo everything worked perfectly but now that I've bought it I'm having that issue.

Thankfully nothing else seems to be wrong yet, other than the fact that the computer clearly "cheats" to make every possible advantage come the way of the AI (it's statistically improbable to throw doubles and land on GO as often as the AI does!).
 
 
 posted in Where Angels Cry on Oct 7, 12 2:58 PM
Thank you for replying. I'm sure it must look amazing on a 27" iMac!!! That would certainly be impressive!

I have my res set to the highest it will go at 1366x768 so I'm gathering that must be too low to see a difference. And I've got a 15.6" screen.
I can't figure out the processor bit though...mine says it's Intel Pentium P6100 @ 2.00GHz but I'm not sure if that's equivalent to the core2duo you mentioned. Oh and it's 4GB of memory.

Basically though, I'm assuming if the option was greyed out I must not be able to use it so that's that I guess. I had hoped there was something I could do to turn it on but the computer must have deduced that it wasn't available to me.

Thanks again for the info.
 
 
 posted in Where Angels Cry on Oct 6, 12 6:30 PM
I have a fairly new computer that's up-to-date but yet I can't seem to get the HD option working. It's greyed out and unclicking other options doesn't seem to be making that one available. What am I missing here?
The game is feeling a bit flat to me so I was hoping the HD option would make the experience better.
 
 
 posted in Fairway ™ Collector's Edition on Sep 13, 12 3:15 PM
I'm confused...
Is there a daily game play for the PC version of this game (which is what I assumed this forum was for)? Because I can't find anything like that in my game.
 
 
 posted in Eternal Journey: New Atlantis Collector's Edition on Sep 8, 12 12:57 PM
Not sure if this is a tech issue or not but it was unusual and a bit annoying so it might be. On a regular basis, the hint button would suddenly be empty and start filling again...even though it had never been used. This happened throughout both the main and bonus games.
 
 
 posted in Malice: Two Sisters on Aug 25, 12 11:14 PM
Ho-hum, blah game but unfortunately I didn't figure that out until after I'd already bought it.
There are hundreds, probably thousands, of better games here at BF and I really regret spending money on it. But that said, a dud happens sometimes and I could have lived with my poor selection if it hadn't ended so badly! I was surprised enough that it was finished so soon (I was bored though so that was fine) but after the last scene I just sat here scratching my head in confusion and annoyance at the abruptness of the ending. No resolution, no logic even. Just weirdness.
2 big
 
 
 posted in Super Granny 6 on Aug 12, 12 7:22 PM
I am beyond furious right now. I waited for a long time to get this game and then it was even longer before I could play it on a good keyboard and now when I've spent over a month of hair-pulling, and cursing to get through some insanely tough levels I was in the home stretch, so I thought. I had 3 levels left...only 3 to the whole game.
I have had the same issue a few people have mentioned where when you use the space bar (for me it only happened with the switch to change screens) and the game shuts down. It's happened 6-10 times at least and as annoying as that was I was thankful it rarely happened on levels I'd fought hard for and I was even more thankful that when I turned the game back on everything seemed fine and I could just continue on with my progress. So now it happens again...ok fine...I load it back up and poof...all my progress is gone and it has me starting over again at the very beginning. I'm shaking I'm so angry. I know it's just a game but I've worked so hard to get through these horribly tough levels and now it's for nothing, I cannot do it all over again. I have the latest version that BF offers and while it runs it runs fine and every other time this shut down happened I didn't lose progress so why now? Why when I was so close to being done? Is there any way to get my progress back?
I've never asked BFG for my money back in over 3 years of being a customer but now I'll be demanding it...this is not ok that this is happening.
 
 
 posted in Super Granny 6 on Aug 12, 12 4:34 PM
I think I'm ready for the nuthouse!
I think I want to have *words* with whoever created some of these insane levels - they have a sick sense of humor! I'm almost glad the devs won't be making more SuperGranny games even though some of them are my all-time favorite games ever because they went way too far with this one. As someone else mentioned games are supposed to be FUN!

I have scoured the internet (incl. Y-tube) for some tips on this level and have not found anything remotely useful for this nearly impossible death trap. I have nearly worn out my space bar from mashing it so much and so hard only to die over and over and over again because the blasted whip doesn't work half the time and those 5 measly lives get used up PDQ.

If there are any tips, tricks, advice or valium anyone can provide I'd be really grateful.

Thanks!
 
 
 posted in Super Granny 6 on Jul 7, 12 8:19 PM
sewrightcat wrote:I, too, was thoroughly frustrated with this level. I searched the forum for any help I could find. I finally got a method that worked for me so I thought I would offer some tips.

The first thing you need to do is get that stupid blue pterodactyl down to the middle screen. Just stand next to the switch to go to the next screen, wait for the idiot bird to be level with you and switch screens. Then go down a couple ladders, wait for him to catch up with you, then go back up to the top screen.

When you get to the blow torch platform wait until the bats are in a position that they won't kill you on your way back to the switch.

Use the ladders to descend--DON'T FALL--the ladders are actually faster and when you reach the ladder above the switch you can hit the space-bar while still descending.

As soon as the screens start to move hit your right arrow key so that Granny is facing the right way.

On the middle screen the fall is the faster way to go. Also, while falling hit the left arrow key. Walk to the switch.

Again, hit the space-bar and then the right arrow key as the screens switch.

Use the ladder to get down from the platform and run to the drill. You should get there with 2 seconds left on the torch.

If you don't have 2 seconds you will probably have to start again. But this method works for me every time I do it.


Thank you - this totally worked! The key seems to be getting that darn pterodactyl out of the way and into the second level - brilliant! Also not worrying about getting the cats (or scarabs) while getting the blowtorch. Get them later (and separately if necessary). Using the climbing bar (not sure what else to call it) to get across and back to the switch gave me the time I needed. Also, avoiding the pterodactyl you've stashed on the second level - because he really slows you down.
 
 
 posted in Big Kahuna Reef 3 on Jul 3, 12 2:40 PM
I've actually really enjoyed the game despite the annoying issues. Perhaps though, mine haven't been as noticable as others or I've found ways to compensate for them. Who knows, still a fun game!

That said, the sluggishness we've all noticed seems much worse on the Tiki Challenge levels, at least for me. Definitely getting more annoying to play. I'm almost done though and I probably won't play again for a long, long time unless there's a fix.
 
 
Yes, I realize this is rather late since the game came out quite some time ago but I didn't have internet and am only just getting around to playing it. Anyway, not the point...

I'm sitting here rather in shock at such a blatant slap-in-the-face to those gamers of faith.
I've only just started the game and was enjoying the various historical (and possibly mythical) ideas and articles and locations associated with some religions when after dusting off a plaque the main character (and not the bad guy even) says this:
"Some bla-bla-bla about miracles...The only thing useful is the date."
Are you kidding me? They couldn't have just said something like "oh this date might prove useful" they had to make a snide-type comment about miracles? Why choose this setting and these articles to make a game out of if you can't even be respectful about them or about your players who have meaningful connections to these places, things or ideas?
 
 
 posted in Big Kahuna Reef 3 on Jun 28, 12 11:45 PM
Found another issue...on level 142 (not sure if the issue is level-specific) it sort of froze...sort of. Everything was still moving and I could move pieces but it wouldn't acknowledge anything as matches so I'm looking at a screen with a dozen or so matches made but they don't disappear and drop away. At first I thought it was a delay from a charm to help you get bigger matches (like the frozen thing in Chainz) but after a minute I realized they weren't ever going to go anywhere. Finally had to do a restart of the level. Then on the second try on that level it played fine but one square wouldn't allow a piece into it even though absolutely nothing (and I analyzed the board!) was blocking it from dropping a piece in. Near the end of the level it just suddenly dropped a piece in and I was able to finish.
 
 
 posted in Curse at Twilight: Thief of Souls Collector's Edition on Jun 28, 12 11:36 PM
Purchased this game in April, after the new build, and I'm having a couple of the previously mentioned issues. The chalk game not working correctly (finally had to skip as someone else mentioned since there's NO RESET! and with a minigame that requires this level of presicion it's insane not to have a reset) and the main issue is the flickering/shuttering/interferrence mess at the bottom of the screen. It's been intermittent thankfully but it's making it hard to play at times. Plus, I suffer from migraines and this issue is actually painful for me.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator