Posts created by gemini888

 
 
 posted in Westward Kingdoms on Feb 2, 11 3:28 PM
I cant get the key from the berry bush until I have the first scroll which I think is the one in the outpost,There is blight on bush at the moment.Have I m,issed something?-Thanks
 
 
 posted in Westward Kingdoms on Feb 2, 11 12:44 PM
How do you get the scroll in the ruined ancient tower?I planted a bean trying to knock it down but that didnt work.
Also-I still cannot find the key in the same area-cant mine rocks or gold-Anyone?Please?
 
 
 posted in Westward Kingdoms on Jan 18, 11 6:29 PM
How can I return to this area, there were still some big trees that I hadnt cut down, Im thinking I may need to do this in case it is required to do so further into the game. I did get the kings crown though.
 
 
 posted in Westward Kingdoms on Jan 18, 11 6:24 PM
Oooops, scholar hadnt turned the wheel at all, I tried a level 4 soldier and he did it when the pickaxe icon showed up, but hero still wont cross, Duhhh!!!
Clues any-one?
 
 
 posted in Westward Kingdoms on Jan 18, 11 5:35 PM
My scholar turned the wheel, but my hero wont cross either, the wheel is still complete--strange, it doesnt look like the drawbridge even went down--Completely stumped!!!
 
 
 posted in Westward Kingdoms on Jan 18, 11 1:17 AM
Where do you go to purchase the plans? I have all the requirement to do so, but cant find where to do it.
Any help would be most appreciated-Thanks
 
 
 posted in Westward Kingdoms on Jan 18, 11 12:29 AM
Thank you very much, I shall try what you suggested
 
 
 posted in Westward Kingdoms on Jan 17, 11 1:00 AM
I have killed the plants, got the three stones, had a scholar read everything, but I still cant find the scroll to go any further.Please help--Thanks
 
 
 posted in Westward Kingdoms on Jan 15, 11 2:38 PM
How do you open the gate where the giant is so the stone quarry can be built?(k2)
 
 
 posted in Westward Kingdoms on Jan 13, 11 7:11 PM
Hi--What do you mean by the "second" button on the build menu? as I am sooo confused, I also cant find the blacksmith build either .I am unlocked etc and meet all other criteria, this is a neat game but Im tearing my hair out here.
Your help would be appreciated. Thanks.
 
 
 posted in Westward Kingdoms on Jan 13, 11 3:17 PM
I run out of gold before I can complete the castle repair so cant get to build the blacksmith needed to build the bridge ,which will lead me to more gold.
Also, In my lumber camp, I have two workers, one has 152/200 ex. and the other has 53/200. Why cant I update the camp?,the requirements to do this states I only need 15 ex.
I am sooooo confused

PLEASE HELP SOMEONE
 
 
 posted in Westward Kingdoms on Jan 13, 11 12:14 PM
Thank you soo much,just aiting for the tutorial.
 
 
 posted in Westward Kingdoms on Jan 12, 11 7:27 PM
How do I get to the boars? and also I am having difficulty constructing a bridge,
Can anyone help me please?
 
 
 posted in Westward Kingdoms on Jan 11, 11 4:16 PM
how do i get 25 food for the king? I get as far as 20 and it wont go any higher.
 
 
 posted in Fisher's Family Farm on Dec 21, 10 6:39 PM
On level 42, the factory that boxes up the fish fillets doesnt activate. I tried upgrading it but still no joy,-- cry cry, sniff sniff--
Cannot finish this level because of this glitch.
Has anyone else had this problem?
I purchased the game from Bigfish, so its not the Beta version.
I would welcome any help with this problem--Thanks in advance.
 
 
 posted in Fisher's Family Farm on Dec 21, 10 6:26 PM
I cannot activate the machine to box up the fish fillets, has always worked fine on previous levels, I cannot complete this level because of this glitch,
Has anyone else struck this problem?
 
 
 posted in Garden Panic on Dec 11, 10 7:26 PM
Hi Katherine, excuse my ignorance, but I dont know how to "PM" you, as I too would like help with these levels--25 + 26--Thanks
 
 
 posted in Youda Farmer 2: Save the Village on Dec 2, 10 1:39 PM
I too uninstalled and reinstalled the game because of probs on level 61--the magnet would not drop onto the truck--PLEASE GET THIS DARN GAME FIXED ASAP-so I can continue to the end.Thanks
 
 
 posted in Dairy Dash on Nov 15, 10 3:34 PM
I cant get the hay machine to produce hay, have figured out the grain water etc, but when I clik on the machine at the middle top. with the two levers on it, nothing happens, can anyone help? please?
 
 
 posted in Build-a-Lot: The Elizabethan Era on Aug 30, 10 5:17 PM
Thank you soooo much for your help
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator