Posts created by georgiarealist

 
 
 posted in Legendary Mahjong on Jan 19, 16 9:46 AM
I have a few mahjong games, but they're not usually my favorites. This one is different, though. The slider temple is a real puzzler - very hard to get the pieces lined up just right. So far I haven't done enough of the levels to get the next key to unlock another temple, so I don't really know what the other formats are. But I'm looking forward to finding out! I did finish the first level of the first temple and have started on the second level there (just to get a break from the slider one). It's nice to be able to go from one temple to another without having to finish the whole level of one first. I suppose it might be nice to be able to switch the formats if you really get frustrated by one (I can see that the sliders might get to that point if they get any harder with the other levels). I've just about decided it's not possible to get 3 stars on all the slider levels, since I don't seem to be able to make all the tiles match without having one get stuck somewhere.

If you play mahjong games for relaxation, I don't know that this is the game for you. If you like a challenge, though, this will keep you interested. Lots of levels and multiple formats mean it's going to keep me busy for quite a while.
 
 
 posted in Roads of Rome: New Generation on Jan 4, 16 4:59 PM
I like the game and agree that it requires planning out your strategy to get gold. I also agree that it's annoying to not be able to queue tasks and to have to put up with the tutorial and dialogue, even on replaying a level. On the whole, though, this is a good time management game.
 
 
I was playing along in the demo and got to a point where I need to get the coat by using the rope pieces tied to the one on the branch, but I tied both pieces on and still get told it's too short. I've looked in the guide, but it only shows picking up 2 pieces and says tying the 3 pieces together will let me get to the coat - looking at the picture, it appears the guide is counting the piece already on the branch as one of the 3 pieces, so it ought to work. What am I missing? Or is there a glitch in the game? I'm afraid to buy it at this point, since I originally had the Windows 10 problem already mentioned here when I first downloaded it. The update seems to have fixed it so it runs, but now there's this issue.

OK, never mind, I found the other rope. Guess it was too late at night to be playing anyway. Still haven't quite decided whether I like this game well enough to buy it.
 
 
 posted in Moai 3: Trade Mission Collector's Edition on Dec 28, 15 10:31 AM
Having looked at the Bonus content listed in the game, it appears to be entirely stuff like music that can be saved to your computer, screen savers and artwork, along with the strategy guide. Since I have no interest in any of those things (and find a strategy guide to be unnecessary for time management games), I'll wait for the SE to come out. I've bought some recent CEs that had extra levels to play, but that's the critical difference for me. More levels are generally worth paying a bit extra for (although I admit to waiting for a sale for most such purchases), but things like this are the equivalent to paying extra for a designer label on something. If that's your thing, fine. I'm just glad they list the bonus content so I can decide.
 
 
 posted in Rainbow Mosaics: Christmas Lights on Dec 24, 15 9:23 AM
It's a little clunkier feeling than the Fantasy Mosaics games, but this has a lot of levels, auto-completion and colors. And the pictures actually look like things, as well as being left on screen long enough to see them and having titles. It's a huge improvement over the Griddlers games.

If I could change anything, I'd have the tree to decorate as a separate screen - it's hard to tell much about how it looks when you add ornaments. But that's a relatively minor quibble.
 
 
 posted in Sweetest Thing 2: Patissérie on Nov 20, 15 11:27 AM
On level 7, I've found the hidden treat, but the question mark remains on the map. I have tried starting over with a different player name, but it did the same thing again. Running Windows 10 on a laptop.

OK, so evidently this is the only clue that there is more than one hidden treat on a level. They're so tiny that it's difficult to tell whether there are one or two.
 
 
 posted in Sweetest Thing 2: Patissérie on Nov 20, 15 11:24 AM
Very small items indeed - petit fours, madeleines and other pastries. So far, anyway.
 
 
 posted in Garden Shop on Oct 14, 15 10:49 AM
sonofstar wrote:I used a free game coupon on this because it seemed better than a lot of the other non CE games coming through.

I gave up trying to use one of the other helpers. It confused me too much to try to remember who was serving whom. I still got 3 stars on most of the levels.

Not completely sold on this one. The game play is really stressful. The story got confusing. Then all of a sudden, the story was done but levels continued. Would have either preferred the story to continue or the game to be all time management.

If I hadn't had a coupon, I definitely wouldn't have spent money for this one.


Have to agree with you on everything. I've also given up on the "helpers" because it seemed to confuse the game when I tried to use one. At one point, neither of my people would deliver the flowers OR take them to the recycling bin so I could try again. It would be nice to be able to use them, especially to serve the unhappy customers, but it seems to be easier to concentrate on one person to do it all. I also used a punch card coupon to get this, so I suppose I can deal with it. Not one of the better games, though.
 
 
 posted in Sweetest Thing on Oct 9, 15 3:20 PM
I don't know if it's a tech issue or just sloppy programming, but on Level 20 I ran into one of the chocolate stations where resources usually reappear but which I can't get to no matter what I try. I cleared the road and see no obvious reason the worker can't go to the station, but all I get when I try to select it is a red circle around it indicating it's not accessible. This is the first real glitch I've run across in the game.

OK, having finished the game, there are 2 of these situations with inaccessible resources. The one on Level 20 as I described above and another on the last level (41), where there's a blue cube and a stack of sugar cubes that won't let me collect them even though I've cleared the road. I suspect this is sloppy programming rather than an actual tech issue. Fortunately, it doesn't make a difference to my ability to finish the level with all 3 stars, it's just annoying.

On the whole, I didn't have any of the tech issues others have reported. I'm on a laptop with Windows 10.
 
 
 posted in Sweetest Thing on Oct 8, 15 10:40 AM
Unfortunately, it appears the Customer Support people also only do copy and paste responses. If they're not going to look at what we send in, including the Dr Felix reports, they shouldn't bother telling us to send them. I don't expect the moderators can address specific issues, but it would be nice if there appeared to be an attempt to get the attention of the people who could fix problems once there are a number of similar reports on the forums.
 
 
 posted in Sweetest Thing on Oct 8, 15 10:36 AM
I guess I'm in the minority, but I like this game. Of course, I like the gathering resources type games anyway. This one is cute. The "story" isn't much, and the translations are terrible, so I've about given up trying to read it. And I don't usually listen to the sounds (generally have the tv on while playing). I haven't run into the glitches reported on other threads (using Windows 10 here), so I can't address them. As for the hidden things, I never saw anything that told me to look for them until I got curious about the question marks on the map. I've found a number of different sweets on different levels - first one has candy corn, as I recall, and then there are sugared hearts, wrapped sweets, and even some chocolates. There may be others, as I'm not done yet. I've been doing what I do with the Hercules games - look over the scene for the treat before clicking to start the level.

 
 
 posted in Family Vacation 2: Road Trip on Sep 7, 15 3:07 PM
This is a terrible game. I get a strange screen claiming there's a problem with my profile screen, but it's evidently a Microsoft error of some sort (can't remember exactly what it said). This happens every time I finish something, like cleaning one of the rooms. If I hit retry in the error box, it continues, but then there it is again next time I finish something. There also doesn't appear to be a way to get to the menu
from anywhere in the game, or to exit the game. I finally (the 3rd time it came up) hit the ignore button in the error message and that closed the game. I couldn't uninstall t fast enough.

What little I managed to play of this game was more annoying than entertaining. As others have said, I'm not amused by being told to clean rooms for kids who're not even trying to help. Then, too, there appeared to be garbled words or machine language in some of the dialogue boxes.

I like a straight HOG once in a while, but this isn't one I want.
 
 
 posted in Pastry Passion on Sep 7, 15 2:55 PM
This is neither a new game nor a time management game. It was a freebie on another site several years ago (not just a one-day freebie, either). If you want a match 3 that lets you earn the ability to "buy" upgrades, you might enjoy this.
 
 
Did you get 3 stars on the 5th bonus level? That's the only thing I can think of that might prevent the super bonus level from being unlocked.
 
 
It appears to me that the 5th level is the CE extra. I'd expect the SE version to end after the 4th section, since that looks like a logical ending place to the "story." The extra hidden objects to find don't seem to have any particular benefit, but the points screen after each installment show a points for birds and HOs, so I guess we just get extra points. You find the levels with the HOs by reading the little signs on the screens - a good idea anyway, since some of them tell you how many of each item can be held (food, wood, gold). If you know you can only keep 20, there's no point in gathering more till you use some.

On the whole, I think this is worth a sale price, although I'm not thrilled at the so-called half price of $8.99. Still, I've been waiting since I played the beta version.
 
 
highlander1942 wrote:Can't run it in Windows 10 without a CODE. Please help and get these Windows 10 problems fixed soon.


I have Windows 10 and have no problem getting this game to run.
 
 
 posted in Sally's Spa on Aug 11, 15 1:20 AM
I have the same problem with the 3rd level of the Banff location (not sure which location is your first, as the game lets you pick which to open next). So far, it's the only level that won't show the perfect heart/star on the map of the locations I've replayed.
 
 
 posted in Juliette's Fashion Empire on Aug 3, 15 10:19 PM
I have really enjoyed this game and replay it frequently, but it doesn't seem to work with Windows 10. Every time I try to open it, I get a blank white screen that blocks everything, even Task Manager. I can get the toolbar at the bottom of the screen to open, but I can't open any of the programs, or close this one.
 
 
 posted in Divine Academy on Jul 22, 15 11:46 AM
As others have said, I played a few minutes of the game and then started getting the error messages about server maintenance and error code 2. Reviewing the comments in this thread has convinced me that the game has too many problems to bother with. I don't like the FTP format in the first place - while it may be possible to play without spending real money for in-game items, it appears to be extremely slow to play that way. I have played Farm Up many times since I purchased the original PC version from RL (they say they no longer support the PC version, which is odd since they still sell it), and I love it. I tried the FTP version here to see how it differed and it looked like the biggest difference was that everything took a LOT longer.

The iPad version of Divine Academy has been out for several months, so I don't understand why there are these problems.

Regardless, I have uninstalled Divine Academy (and the FTP Farm Up) and won't bother to try again. I too wish they'd release a real version of this game that I could buy and play, as it looks interesting. I like All My Gods, and this looks like a similar game. Guess I'll just replay All My Gods, and the 12 Labours of Hercules ones.
 
 
 posted in Shrouded Tales: Revenge of Shadows Collector's Edition on Jul 19, 15 11:24 AM
Oddly, I did the beta test of this game but didn't recognize it because they evidently changed the title - the beta was called Shrouded Tales: The Shapeshifter. I knew I'd seen it when I watched the intro, though. Based on the demo, I'll probably use credits to buy this. The use of inventory items is unusual, but I think I can adapt. And I'm one of those who's not a fan of morphing objects, especially when there are achievements for speed but you have to wait to watch for the morphs. I'm not overly fond of going back and forth between the shadow and regular worlds, but then I also don't much like the games that make you go back and forth to the same locations over and over. At least this one seems to have some progression of locations.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator