Posts created by fluffyalso

 
 
 posted in Haunted Hotel: Eclipse on Nov 8, 13 8:01 AM
It is now 11:00est and I downloaded game with no problem and it plays well. So maybe it is fixed. Good luck. very enjoyable game as expected form this developer..
 
 
 posted in Strange Discoveries: Aurora Peak Collector's Edition on Jul 13, 13 12:47 PM
When I went to fix bear cub, the inventory showed no disinfectant but there was a blank green space and when I clicked on it the disinfectant "magically" appeared and allowed me to heal bear cub. This maybe the glitch you spoke of. Hope this helps.
 
 
I had same problem and did all the same things as you did but none of the normal stuff worked. So I decided to "Fix" the problem like I fix my computer. Trial and error. This takes about 25min but worked for me. First I made game windowed. Then went to b/w puzzle. I waited a bit and noticed skip button moved a miniscule amount. So I clicked on screen which went blank then it came back paused, clicked on screen again and waited to see if skip button moved then clicked again. It took about 20-25min but finally was able to skip puzzle when bar filled in. Don't leave game or you will have to start over again. Then you can get blue button doing the same thing. Once I had button, game went back to normal and is playing okay, Although occasionally goes blank for a moment or slows down. Glad I bought on special.. Good luck

Oh no found another puzzle doing same thing will try "fix"again..
 
 
Not a game for a grown-up, in my opinion. Hard to see graphics. Not very well drawn. There was way to much click this and then click that and then pick the first item up and click it on something else again in order to get second item then...etc etc. After all this,you've only achieved one goal. When you pick up wand you have to place back in holder instead of right clicking if you can't use it. Annoying. No map. Guide is not very good in helping solve puzzles. I didn't find game very intuitive. Wasn't really sure where or what to do next. On the bright side, the options were customizable which was nice, no click penalty on the setting I chose and mandrakes were cute. And puzzles showed solution when skipped. Not a buy for me, not even SE unless real cheap. With some tweaking could have been fun.
 
 
 posted in Phenomenon: Meteorite on May 1, 13 3:19 PM
Game played well in demo, but after I bought game and started to play, I noticed the amulet in far right bottom corner was pixilated. I didn't feel like reinstalling so played game anyway and it worked fine. Just had a square bunch of line to put in locks. Had no other video problems. Really nice game. Thanks.
 
 
 posted in Enigma Agency: The Case of Shadows Collector's Edition on Apr 27, 13 8:36 AM
Possible spoiler alert: Had same problem. I put cursor on dartboard, in opening, moved it around and it finally stuck in one position and that made hint worked. Hope this helps.
 
 
 posted in Dreamscapes: The Sandman on Mar 13, 13 2:26 PM
SPOILER ALERT: If you mean the lock in the other room with the blackboard where the fuse might be. Use the dry sponge on the blackboard. Code will be revealed. And look for what looks like an eyeball sort of for the thingys, click them twice. hope this is what you meant. Sorry for the spoiler in black. I don't know how to make the type disappear.
 
 
 posted in Scarytales: All Hail King Mongo on Mar 2, 13 2:19 PM
Sandrahollie absolutely agree. Will not buy a game where you get punished for clicking on one or two wrong items in HOG. Game also too short . Had 27min left after demo. I hope the developer continues to make games because I think they can come up with a good one. Got pretty close on this one.
 
 
 posted in Deadly Voltage: Rise of the Invincible on Feb 24, 13 6:41 PM
Spoiler Alert : If I remember correctly. There is a toothbrush on the right edge of the chest, back near the hinge. Same color as wood so hard to see.
 
 
 posted in The Missing: Island of Lost Ships on Jan 1, 13 11:56 AM
Loved this game. So easy to get around with map and doable puzzles. Only con was way too short. Wanted more. Reminded me of PC game "Around the World In Eighty Days." Much better than Game of the year=MCF Shadow Lake which I can't finish because of some sort of glitch.
 
 
 posted in Mystery Case Files®: Shadow Lake on Jan 1, 13 10:36 AM
Thank you genfool32. I was finally able to get the bobbie pin off the bulletin board by having knife in hand. I would never have figured that glitch out.
 
 
 posted in Mystery Case Files®: Shadow Lake on Dec 31, 12 7:01 PM
My game freezes up and I loose the cursor when I click on the bulletin board in the warden's office. I uninstalled and reinstalled and same thing happened . Any suggestions? Game played fine up to that point. (albeit a little slow)
 
 
 posted in Mystery Case Files®: Shadow Lake on Dec 31, 12 6:51 PM
There is a soccer ball or basketball on top of the lockers in the front hall. Hope this helps.
 
 
 posted in Mystery Case Files®: Shadow Lake on Dec 30, 12 7:39 PM
As in a lot of other tasks in this game, all the other things in that scene such as HOG have to be completed first. When that happens the top board will pop off and then you can do the rest with the crowbar. Hope this helps.
 
 
 posted in Break the Curse: The Crimson Gems on Dec 24, 12 7:46 PM
I guess I am odd man out on this one. I bought as one of BOGO free. I am enjoying okay game play but find the puzzles puzzling. Some are straight forward and can be done in a reasonable amount of time. Others are either too hard to figure out or take too many steps to complete. Knowing that, I would not have bought this one at any price. Just too frustrating. Also no map so when hint button tells you to go to a certain area, such as workshop, I couldn't always figure out where to go. Happy Holidays!
 
 
 posted in Dream Tale: The Golden Keys on Oct 2, 12 1:12 PM
Played for only 9min. This game comes very close to being a good game.The graphics are simple but colorful. It misses in the game play. One hit of the bad guys, kills you and sends you back to beginning or check point. The flying star lasts a fraction of a second too short so I kept missing the landing. The regular jumping has to exact or you miss. Just too much trouble to play. Not a buy for me. Too bad cause I love this type of game occasionally.
 
 
 posted in Eternal Journey: New Atlantis on Aug 26, 12 10:36 AM
Am another who usually doesn't comment on games, but had to put my 2cents worth in on this one. Absolutely loved this game. Am 3/4 of the way thru and keep stopping because I don't want it to end. The game plays so smoothly and is beautiful to boot. The map makes it so easy to get around and gives great hints without spoiling the game play. The story line is such a nice departure from ghosts and the supernatural. Kudos to the game developers and Big Fish for bringing us this really cool game.
 
 
I always saw the object highlighted in yellow. *** Possible spoiler alert: First piece is found in sails of ship in lower right-hand corner. In some scenes objects were still miniscule such as one of the sausages and an egg, so look carefully.
 
 
 posted in Whispers on May 30, 12 11:08 PM
Possible Spoiler Alert:
The boat motor and gas are in the scene that is at the 12:00 position on the location page.Just move cursor around screen till areas are highlighted and do what they tell you to do. IE: lantern, crate etc. It is a learning curve but once you've got it ,it works. Good luck.
 
 
 posted in Theatre of the Absurd Collector's Edition on Apr 29, 12 7:20 PM
Possible spoiler.


Gargoyle is above left door in bell room. Same door where chest is. hope this helps.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator