Posts created by judithannegg

 
 
 posted in Magic Bookshop: Mahjong on Jun 24, 14 3:19 PM
After weeks working on this game, which I do LOVE, I got to Level 30. Then I had issues. I can only do up to four moves then the game freezes. No problems before this. I play other BF games with much more advanced graphics, so it is not graphic issue. I have tried this level probably 100 times and have now given up. Frustrated because it can't be my computer if I have been playing this for weeks and am able to play the most recent BF games with no problem. I really can do 2 to 4 moves on this level and it freezes up. I love timed Mahjong so was soooo looking forward to finish this game!
 
 
 posted in Magic Bookshop: Mahjong on Jun 2, 14 8:15 AM
I love this game! I love Mahjong timed games, so this is really up my alley! I had to replay the 3rd level about 3 or 4 times before I beat the timer! The timer does seem very fast. I do recommend this game for people wanting a challenge since there are 50 levels and if I am having a challenge at level 3, then I have some serious challenges ahead of me, which is what I want out of a game. No untimed option, so those who do not like timer would not like this. I am definitely turning a credit in for this right now! It is a combination of Mahjong and time management games where you serve customers.
 
 
 posted in Cadenza: Music, Betrayal and Death Collector's Edition on Apr 29, 14 8:36 AM
I had no problems with demo. Bought this and now it won't save any profile! I have demoed and bought other games since I bought this and had no problems with saving any of those profiles! Am I missing something when I leave the game? I have uninstalled and reinstalled it three different times. Have contacted BFG, but no response as of yet.... It's an awesome game and I want to continue!!!
 
 
 posted in Final Cut: Homage Collector's Edition on Mar 29, 14 6:51 AM
I've been playing for about 12 to 14 hours and only on Chapter 3! Playing with no hints and no skip button and having a blast!
 
 
While playing demo, my game crashed TWO TIMES in 20 minutes! Both times I restarted my game and my profile was corrupt and have to start over from beginning. Even though I was at the beginning of the game, this is a no buy for me as I don't want to get really into the game and have it crash on me. 2 times in 20 minutes! Wow!
 
 
 posted in Lost Lands: Dark Overlord Collector's Edition on Mar 1, 14 8:55 AM
Yep Tammy, same thing here. I always play expert and never skip puzzle, but I had to on this one. I was stumped too. I knew what I had to do, but couldn't maneuver the circles around to where I needed. Just skip and move on! Game is awesome!
 
 
 posted in European Mystery: The Face of Envy Collector's Edition on Feb 23, 14 3:46 PM
I lost it too! And no it is not in the jewelry box. Hint button says everywhere that there is nothing to do, even in jewelry box. Put horn on unicorn, clicked on emerald, and never got into my inventory. The very sad part of this is that I bought this game when the sale was buy one and get one free, I think, so I bought this along with Witches Legacy: Hunter and the Hunted both at same time. With that one I lost the crystal key when the game was 97% complete! Lost in my inventory just like this emerald! So, bought both games, but can't finish either one, plus they were CE, so I can't do bonus games! I've been playing BFG for over 6 years and have never had this happen, let along with two games back to back! And yes I have uninstalled game and reinstalled it, but same problem with both games. Lost a critical inventory item and can't continue....
 
 
Yep, tried that and it did leave me back to where I left off, so hint button still pointing to key hole and no key.... Was really looking forward to doing the puzzle and extra play at the end. So close, but so far away.... Thanks!
 
 
 posted in Lost Lands: Dark Overlord Collector's Edition on Feb 22, 14 2:18 AM
Divine Swine! Been playing BFG for many years and first time I have ever done review!!! AWESOME! I have never ever seen graphics like this on BFG, only on my teenager's $60 games he buys at big box store! The opening scene was so beautiful, I really thought the scenes when you started to play would be downgraded, but NO! It is still beautiful! Despite some reviews that say there are 3 modes of play, it is really custom, so you can play with some hints, or no hints at all, if you want skip button or no skip button, etc. I am an advanced player so I like no help at all. So far the mini games are on the easy side, but the HOP had me thinking for a bit and finding items since I had no hints, which is really great! Again, I am not a huge graphics person, but WOW! I can't wait to get back into the game and just watch it all!
 
 
 posted in Danse Macabre: The Last Adagio Collector's Edition on Feb 20, 14 4:14 PM
You need to put the 4 colored coins in order on the right; however, you need to do it in reverse. I think it was green that was in the 4th position and gold in the 1st. So, move circle around until you see green in line, then move that over to right, then find the 3rd color, then the 2nd, then the 1st. I found it easy to pull out of the line in the middle all the colored coins onto the circle, then fill that line with blank coins, so that your circle has the colored coins, then you just line up the line on the right with the colored coins in order. Does that make sense?
 
 
 posted in Dangerous Games: Prisoners of Destiny on Feb 10, 14 7:14 AM
I think I moved the top stairs and got the vase in the window. Then I kept trying to connect the top and middle and after a while I realized there was a set of stairs at the bottom. Maybe this will help?
 
 
I know I had the key before I did the eye puzzle. I had so much problem with the eyes and I know I was so close to the end I skipped the puzzle, then nothing in my inventory! I am 97% complete. Hint button just says to go to the keyhole in the ceiling but I have nothing to use! AAAGGH!!!! Any help?
 
 
Played eye game. Finished that and then nothing in my inventory! Can't use key to finish game! Hint button just points to keyhole... Glitch or did I do something wrong?
 
 
 posted in Midnight Macabre: Mystery of the Elephant on Jan 23, 14 2:51 PM
All I know is I LOVED the game! I too am on a budget, and this was a very long and complicated game, so you will get your money's worth! You can set your hint button setting early, but you can't change it during the game and there is no walkthrough. I am an advanced player so I played with no hints and no skip button, so I had to rely on the forums sometimes to figure out what to do next. There is a map that lets you know where stuff can still be done. Some of the items were soooo teeny, even in inventory, and some items were just at the edge of the screen. I do felt like I got my money's worth, so I highly, highly recommend this game!
 
 
 posted in Midnight Macabre: Mystery of the Elephant on Jan 21, 14 5:40 AM
I did the code to the safe and am stuck inside trying to use the lockpick. It wiggles in the lock, but none of the bars move at all. Is there a code I need first?
 
 
 posted in Midnight Macabre: Mystery of the Elephant on Jan 21, 14 5:00 AM
Got lockpick and trying to use it on lock, but nothing happens. Just move lockpick back and forth, but nothing happens! Also found book on floor with mysterious symbols in red. Code for something? Help, help, help!
 
 
 posted in Midnight Macabre: Mystery of the Elephant on Jan 21, 14 4:46 AM
I don't remember where I got mine and didn't even think I had it, but it was in my inventory and very, very, very hard to see it! You might have it and not even realize it! Good luck!
 
 
 posted in Midnight Macabre: Mystery of the Elephant on Jan 20, 14 2:11 PM
Thanks Nynaeve 70! You saved my a** again! Every time I am sooo stumped, I think there is a glitch and I have lost something and can't continue on, but you have saved me again! Maybe I can repay favor in future! Thanks again (but don't go too far because I am sure I will need your help again....)
 
 
 posted in Midnight Macabre: Mystery of the Elephant on Jan 20, 14 12:42 PM
My cursor changes to the left of the harp by the broom, but nothing happens when I click. I clicked on mirrors on left and right walls, but nothing happens.....
 
 
 posted in Midnight Macabre: Mystery of the Elephant on Jan 20, 14 7:04 AM
I have glass shards and magnet on string and stuck. In hallway, only thing that I can click on is door that needs playing card. My cursor doesn't change on cabinet, so I must have done that earlier. Only other thing on map is go to the secret room, Chamber of something. Clicked on everything and cursor only changes by the broom like I am going somewhere else, but I don't. Soo stuck!!!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator