Posts created by GreenMyEyes

 
 
 posted in Dark Dimensions: City of Fog Collector's Edition on Jun 22, 11 10:51 AM
(This is in the extended play part of the Collector's edition.)

There are four dials each with the numbers 1 through 5. I'm at a loss, and I don't think I can make progress without it. The only other unsolved puzzle at this point needs a screwdriver which I can't find.
 
 
 posted in Dark Dimensions: City of Fog Collector's Edition on Jun 22, 11 10:45 AM
Where are you in the game? In the beginning, there's no way to get into the train station. Close to the end, you're in the station and need to find a way to get out. Is that the puzzle you mean?
 
 
 posted in Dark Dimensions: City of Fog Collector's Edition on Jun 22, 11 10:39 AM
I noticed that, too -- drove me batty. But I have finished the regular game and never needed anything from there, so I just consider it a bug.
 
 
 posted in Tearstone on Jun 21, 11 11:13 AM
AH! Thank you VERY much, Mr_Russ!
 
 
 posted in Tearstone on Jun 21, 11 10:11 AM
I've reached the end of the game. When I received the riddle I wrote it down and exited the game so that I could think about it and try to come up with the answer. When I went back to the program today, the answer to the riddle is displayed, but I can't figure out how to enter it. I've clicked on the word displayed, but nothing. I've tried to pick up the last item in my inventory (the secret item) and drag it somewhere, but it doesn't move. I try both clicking and double clicking on the secret item, but nothing happens. Help, please!

(BTW, I haven't downloaded the update to this game because it doesn't say anything about fixing a problem with this.)
 
 
 posted in Emma and the Inventor on Jun 6, 11 12:32 PM
When I got the machine working and tried to create the fuel, I just threw all (5?) of the ingredients in the big vat, in the same order that they were in my tray. Stupidly, I didn't think to check the recipe first. Now nothing happens. Is there a way to get the ingredients again, or do I have to start over? Or, hopefully, maybe there's just an ingredient I'm missing?

(I'm not liking this game very much anyway, and the thought of starting over ... not likely.)
 
 
I have seen the red X and clicked on it. But still, whenever I try to use an object the fairy comes back with the word "Ability" underneath. For example, I picked up a bucket from inventory and tried to see if I could fill it at the fish fountain, but she appears and gets in the way. Or, if I click on a sparkle that appears, she's in the way.

Or maybe is that how it's supposed to work?

Thanks for your quick answer, by the way.
 
 
Just begun this game and I expect I'll enjoy it as I did the first. But now I've run into a problem with the fairy's ability. She says (in her annoying little voice) that I can click on her to turn on an ability, then click her again to turn it off. But once I turn on her first ability it seems to stay on. I happily broke a few vases and now every thing I try to do brings up her ability face.

I'm just missing something basic, but what? Come, please tell me and make me feel foolish ;-)
 
 
 posted in The Fool on Apr 10, 11 5:20 PM
I'm thoroughly enjoying this game. Some of the minigames have stumped me for a long time -- which just makes the game better!
 
 
 posted in Escape the Museum on Apr 10, 11 5:17 PM
Thanks, Lizzie. I may try the sequel after all, then
 
 
 posted in Escape the Museum on Apr 10, 11 1:54 PM
I wish I hadn't bought this game. I have a wide screen with 1920 x 1080 resolution, but it seems to me that the game wasn't designed for the wider screen. The display, instead of being crisp and sharp, is very blurry, as though the graphics were for a screen with a narrower width to height ratio, and are simply being spread over the wider screen. Since my eyes are not great, I can't clearly see the objects to be found. I'm also annoyed because:
1) I don't care for hidden object games that penalize you for a wrong click.
2) There are often several objects that meet the criteria (a "vase" for example) with no way to tell which one is the "right" one (according to the game developers).
3) Objects are often partly hidden by other objects. I like objects which are cleverly hidden, rather than just obscured.

I enjoy the areas where you have to solve a puzzle to escape, but not the hidden object areas. I will not be buying the sequel.
 
 
phantomlover wrote:Okay here I am again. I rather disappointed in this game. I realized I didnt have the stone wash stone or whatever its called, so I went back to get it & now I cant find the part where Im suppse to install it. I cant find the little girl where u clean her up or anything. Could someone out there shed some light on this for me pleeeeease & thank you.


In Thorn's house, go to the right rear room, through the cabinet, past the cabinets, past the girl you cleaned up,to the area with the cathedral in the distance. to the right is the crypt where you use the stone. But I'm stuck here. I have the five round objects in the circle on the door but nothing happens. I think this is the phases of the moon puzzle, but I can't find anything that looks like moon stones. I also don't know what to do with the reference in the note to an angel.
 
 
 posted in Magic Encyclopedia: Illusions on Mar 19, 11 12:09 PM
I'm stuck in Chapter 2, in the 3rd scene where I'm trying to help the old lady with the loom. I'm having a lot of trouble trying to find the last rung of the ladder. When I clicked on help, the game indicates that there's something in the vicinity of the boat. I looked at the walk-through here, which also indicates the boat -- some illusion on the end of the oar. But when i click on the boat, I get sent immediately back to scene 2. Help! I'm loving this game and don't want to give up without finishing it,
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator