Posts created by Rob_Blake

 
 
 posted in Cadenza: Havana Nights Collector's Edition on Mar 20, 16 6:15 AM
I downloaded and played the whole demo yesterday morning with no problems at all. My PC is 7 years old, using Windows 10, and Display is set at 100%.
 
 
 posted in Punished Talents: Stolen Awards Collector's Edition on Mar 8, 16 7:16 AM
I also hate when the SG button is close to the Hint button, and in this game, the SG button (a ribbon) is a lot smaller than the large flower Hint button. I tried to click on the SG button to look at the painting puzzle, and hit the flower by mistake, so of course it skipped the puzzle, which I didn't need or want to do. I don't understand why they would ever think it's ok to place the 2 so close together. Hint buttons should always be a ways away from any of the other buttons, maps, or journals.
 
 
 posted in Grim Tales: The Heir Collector's Edition on Mar 8, 16 6:46 AM
tookat wrote:head-desk.

I was going to use the strategy guide in hopes of understanding how to align these....
because it seemed even more persnickety than the usual puzzle of this sort.....
and I accidently hit "skip" instead of the SG button.

I ardently wish there were default locations on ALL games, for where the skip, hint and SG buttons were.


I totally agree. I get so upset when the SG button is right by the Hint button. Played another new game the other day. The SG button was a thin ribbon below the large flower Hint button, and sure enough I clicked on the flower instead of the SG button, and skipped a puzzle that I didn't need to skip. At least it was the demo, so after I buy the game I can start over with a new profile and know to be a lot more careful. Just doesn't make sense to me why some developers do that with the SG button. Should always be on the opposite side, as should any maps, journals, Achievement button, etc.
 
 
 posted in Grim Tales: The Heir Collector's Edition on Mar 8, 16 6:40 AM
KathyGriggs wrote:How far do I turn the dials?????


You turn the dials clockwise just one tile space at a time, so if it says 4X3, you move the dial numbered "4" in the SG 3 tile spaces clockwise, but don't click on the tiles themselves. The shaking tiles made me a little nervous, but I managed to keep from turning the dials too far.
 
 
 posted in Steel LIFE on Mar 4, 16 6:23 AM
OMG I finally got it to work. Thanks for everyone's suggestions. The trick was going outside RIGHT after shutting off the heater, before the ice completely froze, and then going back in as the crow was flying back in, so he gets stuck AS it's freezing, not AFTER it's frozen. I had kept melting the ice and then letting it freeze completely before going outside and then back in, so that was why the crow wouldn't stay stuck on the ice. Also, shutting off the heater AFTER the crow flies back in may have worked for some players, but I could not shut the heater off fast enough before he flew away again. Strange that different steps worked for different players. Thanks again for all the help.
 
 
 posted in Steel LIFE on Mar 3, 16 3:23 PM
theosseys wrote:Took me a while to figure how to get the crow - but done it


How were you able to get the crow to stick to the ice? I have tried all the suggestions, but nothing has worked. Going to the wind turbines has not helped. I just keep seeing message that the glass of the illuminator is covered in thick ice. I have frozen the ice while the crow is outside, but he only stays on the ice for a second or two and flies out again. Nothing happens when I click on the crow. I feel like I am missing a step, Thanks.
 
 
 posted in Grim Tales: The Heir Collector's Edition on Feb 29, 16 6:43 AM
The puzzle does work as stated by moving each of the dials clockwise the number of times listed for each dial. The picture in the SG doesn't affect the instructions. Just need to be sure you don't turn the wrong dial each time, or the wrong number of turns each time. The shaking and turning tiles on the dials made me take my time turning each dial, as I felt I was going to turn the dials too far at times.
 
 
 posted in Steel LIFE on Feb 24, 16 6:33 AM
I don't understand how so many people can have such problems with this game, when I and at least one or two other members said they didn't have any. I don't have a fancy, expensive PC. In fact it's over 7 years old, although I did get the hard drive replaced a year ago due to major corruption. I have had other issues with Windows 10, but I had no trouble with this game. So, how can this be the fault of the developer if the game does work for me?
 
 
 posted in Steel LIFE on Feb 23, 16 10:45 AM
I am on Windows 10 and I was able to play the demo the whole 60 minutes with no glitches or technical problems. Very interesting game, but some puzzles are tougher than normal, and I did not figure out how to get the arcade machine game to play after inserting coins. Then the time ran out.
 
 
 posted in Vacation Adventures: Cruise Director on Feb 15, 16 7:43 AM
I have not been able to get the game to Save either, since I bought it early last month (January 2016). I am on Windows 10, but I don't know if that is causing the problem or not. I reinstalled it, but that did not help. Like you, I haven't had this issue with any other game. The only way I can see to complete this game is to play the whole game in one day, and not try to save it. At least I got the game for free with one of my credits.

Update: after I responded to your post, I re-installed the game again, and this time it did save each time I exited, so I don't know if there was some kind of a fix, or it's just my PC and Windows 10 fluke. It did crash a few times while I was playing it, but I have been having that same problem with other games since I got Windows 10, especially if I have other web sites up and tab back and forth. I hope you are able to re-install and get yours to work.
 
 
 posted in Parallels Cross on Jan 28, 16 8:11 PM
You need to put all the red "Volatium" books on the tray, then light the stack of books with the lighter. It will burn down to red ash which you will need in the lab. I think there were a total of 5 books. The lighter won't work on the stack until you have all of them.
 
 
I don't think Collector's Edition games were included in yesterday's sale.
 
 
 posted in The Last Dream on Dec 29, 15 5:20 PM
Thanks to each of you for your replies and suggestions. I do have The Emptiness and Fall of the New Age, which were both good, and I think I found those by accident also. Since I do look at the PC home page every day, I will now try to pay more attention to looking for the Soft Releases. Thanks again.
 
 
 posted in The Last Dream on Dec 29, 15 7:23 AM
I keep running across Soft Releases, like this game, by accident. I have been a BFG member for several years. Does anyone know if there is a way to find other Soft Releases that I might not know about? Several weeks ago some members mentioned some other Soft Release games on another forum, and there was a series of 3 games that all came out a long time ago, that turned out to be really good. I appreciate anyone's help with this. I have a few coupons left that I would like to use, and I thought there might be some SE games that I would like to get but don't know how to find them if they were Soft Releases. You may send me a private message if you don't want to break any possible rules here on the Forum. Thank you.
 
 
 posted in Spirit of Revenge: Gem Fury Collector's Edition on Dec 27, 15 9:04 PM
I was looking for them also. Doesn't make sense to try to find all the Morphing items and then not know if you achieved that or not. Although I know I found all the Collectibles since I was able complete each of the children's boxes. Also sad that the Extras don't include playing any of the HO's or puzzles again.
 
 
the code is HUGE for CE games
 
 
 posted in Secret of the Pendulum on Dec 21, 15 4:20 PM
The Exhibition Hall is through the door to the left of the Greek Exhibit, where there is a sign that says Notice Authorized Personnel Only. If you were able to disable the laser with the gum and compact, then you need to go into the Greek Exhibit and play the HO game there to get the ID.
 
 
 posted in Secret of the Pendulum on Dec 16, 15 6:12 AM
Thank you for the suggestions. "Run as Administrator" did not work. However, I was able to play the demo after running a Compatibility Test under Properties, and telling it to fix whatever problem there was. I don't know how that fixed the problem, but just glad it did.
 
 
 posted in Secret of the Pendulum on Dec 15, 15 6:09 AM
I can't play the demo at all. Menu screen comes up for only a second, then screen goes black, but the music keeps playing. I'm on Windows 10 and everything is up-to-date on my PC. I have installed the demo twice.
 
 
 posted in Christmas Stories: Puss in Boots Collector's Edition on Dec 3, 15 7:20 AM
Just an FYI for future reference to members regarding the BF sales. I have found that every time they have a sale, it's been good for an extra day, even though it says that it will end at 11:59 pm Pacific time on the day or weekend that the sale comes out. I have gotten many CE games for $6.99, the day after the sale, thanks to this, even though the new sale was not for that price.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator