Posts created by barbaralbb

 
 
I was missing one of the red crystals. Went through the SG and found all six. Then went through each section to see which one I'd missed.... it was sitting right there on the bar in the Brewery. Not a game problem.... a player problem! Once I found it, I was able to easily complete the last section and go on to the Bonus.

This is a good game, I think I'll replay on "Hard" mode, tomorrow.
 
 
 posted in Hide and Secret: The Lost World on Jun 19, 11 8:30 AM
Thanks, fishies! I was really scratching my head on this one.... Went through the game again looking for what I'd missed. Went through the Walkthrough, line by line, to see what I'd missed and didn't find a thing .

Then got smart and came to the forum and, of course, the answer was right here!

Fishies rule!
 
 
 posted in Emma and the Inventor on May 20, 11 1:59 PM
Finonacci numbers are very straightforward and even a "mathphobic" person like me can do them. Each number in the sequence is the sum of the two prior numbers. If I knew how to "whiteout" the text, I'd do that... so continue reading at your own risk.

Possible Spoiler:
So, 0+1=1, 1+1=2, 1+2=3, 2+3=5, 3+5=8, 5+8=13, 8+13=21, 13+21=34, 21+34=55, etc....

Finonacci sequence shows up all over nature - the swirls on a sea shell, the veins in a leaf, the branches of a tree, even the bones in our bodies. Pretty cool stuff for a PC game!
 
 
With the help of the responses, above, I finally figured it out.....and it was a "duh" moment!!!

When I completed the weights in the Guard Room Chimney, two inset screens appeared. I thought they were just showing me what I'd done and where the next action was to occur. Didn't realize that I was supposed to move the gate lever on the inset screen, not return to the main screen and do it there. When I did that, "sparkles" appeared and I knew it was right. Back at the main screen, the gate was open and I could proceed.

Think it was one of those times when I'd been playing too long and needed to take a break. Laid up with a bum knee, was bored, played the first Princess game all the way through then went right into the new Princess game....so, was a little brain fried!
B.
 
 
Have made it this far and am stuck at the city gate. Had my dragon fly over the gate and add the weights (20/10/5) and I'm then told to go and pull the lever at the gate.
Then I get there and try the lever, I'm told I need to go to the guard house. Am pretty sure there is still something to do at the Guard House, but darned if I can figure out what it is. Have also been "down" the chiminey and completed the Hdn Obj scene, so that's not it. Don't find anything else to do within the walls...

Am open to some "fishie" help from those who have made it past this point. I'm stumped and have no idea what I've missed

Gotta say I'm not loving the Strategy Guide and I really miss the map from the previous Princess game. Loved knowing which (if any) sections behind me were still in need of completion. Also loved being able to "warp" between section without having to backtrack. It that is available in this game, I haven't found it.....
 
 
 posted in Legacy of the Incas on May 17, 11 7:27 AM
What is up with the weird camo coloration on the characters? The cut scenes have normal drawings but in the game scenes the people are oddly shaded. Looks like a blend of camo/tie-dye/patchwork. I don't get the significance...., or maybe there isn't any.

And what happens to the woman who is supposed to be the main character? She disappears and we have the the self -described "grave robber" leading all the action.

Well, at least I tried the whole demo/hour and this is a no-buy for me. Maybe several years ago, but I've been spoiled by excellent games with great graphics and sensible stories.

Maybe tomorrow.....
 
 
 posted in Mystery Trackers: Raincliff Collector's Edition on May 6, 11 8:08 PM
The Strategy Guide shows that I should have gotten the White Eagle after the puzzle at the outside deposit at the bank. I completed the puzzle and got the Cork and moved on to the bottle puzzle. Now I find that there should have been a White Eagle in the "slot", though I don't remember seeing it.

Have tried to go back to the deposit slot outside the bank and cannot access it. Zip, nada..... Have the Black and Ruby Eagles for the Knight Coffin at the Church, but cannot complete without the White Eagle. PLEASE don't tell me I have to start over...I hate it when that happens!

NEVER MIND-
Edit/Update: Please ignore my message! Clearly, I've been playing too long and I need to take a break. Turns out I did have the White Eagle and had already put in on the Knight's grave..... Mea Cupla

BF - if you want to delete this "thread" feel free to do so....
 
 
 posted in Fallen Shadows on Apr 23, 11 7:18 AM
Powder - I do agree with you. I'm grateful that there is a trial version for most games so that I can determine if the game is one I'm interested in. Think they no longer say that you can play for One Hour, I believe they are labeled as Sample Version. That means to me "until you complete the sample or one hour, whichever comes first".

There are times I finish the sample,and times I don't. So, sometimes I play an hour and sometimes I play 45 minutes. By just making the sample available, I think Big Fish has more than fulfilled it's agreement.

If there is no sample and I can't try it out, I don't buy the game - got burned a couple of times on Large Files games that had good reviews on the forum and then found they just weren't for me.

So, Thanks BF for all sample options and keep it up!

Happy Easter and Happy gaming!
 
 
 posted in Avalon Legends Solitaire on Apr 19, 11 8:24 AM
I agree with barbee44 that I'd like more variety within a Solitare game. Just like there are often several different match formats within Match 3 games. But, that being said, I'm okay with this one. It is what it is.

Other sites do have more games grouped together but those games are much more expensive (usually 19.99) and there are only two or three games within the group that I like - so, for me, it's a toss-up.

This one is nice and I may use one of my credits from last month.

Happy gaming, fishies!
 
 
Took me about 45 min to complete the sample/demo. Must admit that I did skip at least 1 (maybe 2) mini-games. That means that the game (including bonus material) would take me about 5+ hours. I'm okay with that.....

Liked it okay, as long as I didn't get caught up in the "bad" creatures being good soldiers who volunteered and were transformed by experiments. A little bit of the Bourne Identity series there, with a supernatural twist. Not a huge fan of the story line, it's very "graphic novel" 'ish (formerly known as Comic Books).

I'm on the wire about buyinging as it's an interesting game with good play time. Just felt like it was a bit too easy - may hold on and see what else comes out this month.

Did anyone else notice the girl on the poster where you get the 7/7/1914 date? She looked a little more 1930's/1940's than 1914. Don't think the bikini (bandeau) top was fashion that early - at least not in public!

 
 
Love that the Strategy Guide is available during the sample/demo. Thank you developers! A little "kludgy" having to go to the Menu, but doable.

Hate that it did not keep track of where you were in the guide - always had to start at the beginning of the chapter. If there was a way to exit w/o that happening, I never found it...... That was annoying.
 
 
 posted in The Revenge on Mar 25, 11 2:38 PM
Hi, Clueless - have patience, this is a quirky game....

Have you put the clothes (toga that they call a dress) on the skeleton? If not, you will need to complete all the HObj scenes to obtain those. Place the dress/toga items on the skeleton (there should be two brown pcs and one white pc).

When you have done that, you may be told to find the sandles and buttons - another HObj scene. After getting those items, place the sandles on his feet and the buttons along the fold on the right'ish side (your right) if the garment. After placing the buttons, click with the thread and it will "sew" automatically.

The head in to the left, on the bookcase where you prev played a HObj scene. It is on the top shelf. As you move your cursor in that area it will change slightly - click there and you should be able to get the head....

Good luck!
 
 
 posted in The Revenge on Mar 25, 11 2:28 PM
Cargui,
I placed the buttons on the fold that runs top to bottom on the right'ish (your right) side of the toga (which they call a dress.....). When the buttons are in place, you can click with the thread and they "sew" automatically. Didn't ever see the light circles that Sinshack mentioned, wish I had!

Good luck!

 
 
 posted in The Revenge on Mar 24, 11 3:52 PM
The net is from one of the HObj scene. In you inventory, it looks more like a chuck of wood (check inventory, it may already be there)....

While the Raven is eating (see msg from Heidi), place the net over the bird and you can then get it for your inventory.
 
 
 posted in The Revenge on Mar 24, 11 3:48 PM
The feathers are pretty obscure - some are white/gray, some are black'ish and, as noted in the earlier msg, they are spread over three rooms.

Three of the feathers are hidden in wooden boxes in the same room as the as the block puzzle where the rooster was hidden. To open these boxes, you will need the "nail puller" from one of the HObj scenes. This same tool was called a screwdriver in an earlier scene. Check your inventory, it might already be there. Use that tool on the boxes and the feathers are inside.

Gotta say, I used my hints several times as the feathers were really hard to find....

Good luck!
 
 
 posted in The Revenge on Mar 24, 11 2:28 PM
Think I did that on the 3rd soul - moved the rock under the wheel of the cart with barrel. The barrel fell off and spilled water that held turtle for the 3rd soul, is that the one?

If there is another cart, I haven't found it.....and I just went through all the rooms/gates again. The only thing I can't figure out (besides cutting the rope/giving the monkey the banana) is that on the 2nd gate/soul, when I click my hint button, it drains out and doesn't show me anything - very preplexing.


 
 
 posted in The Revenge on Mar 24, 11 2:17 PM
Yep, Heidi - tried the knife all down the length of the rope. Am about ready to stab the monkey (as if that would work)!

Already finished the 2nd "lost soul" with the chains/rocks and do still have some chains left.... is there another place I should use them? I have looked around for something to use the chains and didn't find anything.

Did't think I'd missed a step but this game is so quirky that may have happened.

 
 
 posted in The Revenge on Mar 24, 11 2:11 PM
The rooster is behind the puzzle with the blocks.

You recive the missing block when you complete the HObj scene. In the HObj scene it is called a "dice", but it's really the missing block. If you recently finished a HObj scene, the block might be in inventory already..... Am sorry that I don't remember where that scene was, but there aren't many options since you are stuck in the dungeon.

After you find the rooster, you must look for 10 feathers scattered throughout the various rooms.

Good luck!
 
 
 posted in The Revenge on Mar 24, 11 1:57 PM
Am really afraid I have a "glitch" here. Have tried the knife on all parts of the rope. No luck. Even exited and restarted the game - that worked on another HObj area were I could not move forward. Didn't work here.....

 
 
 posted in The Revenge on Mar 24, 11 1:53 PM
Marco,
Could you please look at my post regarding the monkey/banana/knife @ soul tree. Just posted and then saw your volunteering to assist.

I am well and truely stuck here. Have exited and restarted the game - that worked for another area that was stuck but darned if I can get this one to work.

Any assistance would be appreciated....
B.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator