Posts created by want2win45

 
 
 posted in Nevertales: The Beauty Within on Aug 1, 16 3:48 PM
This game has never worked. The cursor changes before the game even loads.
Then at the Gramaphone scene it slows and jumps all over the screen. Can't control cursor at this point. Also, the game loads and then after the woman speaks, tries to load again. Need a refund.
 
 
 posted in Spirit of Revenge: Florry's Well Collector's Edition on Jul 13, 16 11:34 AM
I clicked on the cart scene and get a blank screen with Quincy saying "Yes, I'm still here" but don't know what to do next.
 
 
 posted in Clutter V: Welcome to Clutterville on Mar 15, 16 10:58 AM
I'm stuck on the puzzle screen - I don't know what the skip button is but I have clicked on everything and can't exit the screen at all. I have uninstalled and re-downloaded the game several times to see if it would go to the opening screen but no luck. How do I get back to the opening screen? I'm using Win 7. Is there ever going to be a fix for this? To get us out of the frozen screen?
 
 
 posted in Botanica: Into the Unknown on Nov 1, 13 8:50 PM
In the hidden object scene at the healers table, the little broom is suppose to whisk across a pile of dust and reveal garlic. I couldn't get the broom to work. Also I don't know where the drain is to empty the vial. I have been to the walkthrough but the instruction is the same. Use the broom to clear the dust and the hint button says the same. Hint just repeats so I can't get the next hint to show me where the drain is. Could I have missed something?
 
 
 posted in Nearwood on Sep 27, 13 7:47 PM
I can't find a fifth bell that is needed before I can go forward through the fog. The walkthrough only states (4) bells collected but my scene is requiring five. Anyone got the answer?
 
 
 posted in Nearwood on Sep 23, 13 6:12 PM
I collected the four bells and placed them, but I have a place for a fifth bell and I can't go any further because of the fog. I have been back and forth from the game to the walkthrough trying to figure out what I might have done wrong. Did I place them on the wrong holders? Help
 
 
 posted in Timeless: The Lost Castle on Jun 6, 13 7:56 PM
Has anyone else lost the pestle? I mixed the first ingredients right but the pestle only partially ground the mistletoe and flew off. I can't go on now.
 
 
 posted in The Treasures of Montezuma 3 on Mar 17, 13 1:59 PM
I've been playing the Treasures of Montezuma since the first version. If the developers were going to make this a timed version they should have made sure that you wouldn't run out of moves. One minute is too short a time to run out of moves on the board. Also, this game use to be about collecting gems to raise your score but I am not seeing many gems lately. I have mastered all the levels once and had a few 400,000 games but the second time around it is slowing me down with too many gems of a certain color that interfere with getting over 50,000. Getting bored.
 
 
 posted in Cursed Memories: The Secret of Agony Creek on Feb 9, 12 1:48 AM
This game hasn't worked properly and I would like a game credit please. I have several items in my inventory, a candle, a jewel, a ring, a tire and a screw driver.
The screw driver is hard to pick up and kind of floats around. I got as far as the museum and tried to use the screw driver on the screws on the left side of the panel
however, the screw driver immediately went back into inventory and wouldn't let me loosen
the screws on the right side of the panel. You need the wire inside of the machine to
repair the wires on the garage door. So, I haven't been able to go on. Please advise
or issue me a credit for this game.
 
 
 posted in Awakening: The Dreamless Castle on Nov 30, 11 9:40 PM
I am playing the demo and can't get past the door with the symbols. I put them in the right order and it prompts that " that's not the right order. Sun, Heart, butterfly just as it shows on the mirror. I click on the gold door knob and nothing.
 
 
 posted in Awakening: The Dreamless Castle on Nov 30, 11 9:38 PM
[/b]I'm playing the demo and can't get past the door with the symbols. I put the symbols in the right order sun, heart, butterfly just as the mirror shows and the prompt comes up
not the right order
I've done it over and over and clicked on the gold door knob and no results to go on.
 
 
 posted in Elixir of Immortality on Oct 10, 11 2:14 PM
I am in the chemists room - my inventory contains the revolver (complete), the elixir, and the pneumatic tubes. I need to finish the experiment but I have been all around the game and can't find anymore things I need to finish it. Please halp!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator