Posts created by greyhare

 
 
 posted in Return to Mysterious Island 2: Mina's Fate on Aug 18, 13 6:44 PM
Some of what you say works well, thank you

''Do not use any vase item until you make all of the vases, including the blue vases. ''
If you don't use a vase to water the plant, you can't get the blue, so maybe you meant something else.Could you explain, if you do?
 
 
 posted in Return to Mysterious Island 2: Mina's Fate on Aug 18, 13 9:05 AM
Not a stone, but the tool--a ''handy''--just beyond the grip (tong, whatever). It will need to be sharpened at the sawmill.
 
 
 posted in Return to Mysterious Island 2: Mina's Fate on Aug 18, 13 9:00 AM
I've tried original & easy, get the same results, i.e., it hits Amber or says I'm off-center. I have tried time & again, for several (10+) minutes. Any more suggestions?

Also, I've gotten stuck at the part where Mina should be able to stop the disaster, but the coconut Jep put in the turbine hold disappears & I have nothing else in inventory that fits. HELP!
 
 
I'll admit I haven't read 100% of the posts, but has anybody else been stuck at this stupid claw game? I've played it enough to have spent over $20 for the dang doll! Always drops it! Any suggestions?
 
 
 posted in Super Granny 6 on May 2, 12 8:48 AM
I scrolled, The longest is all stars, no help. NOW what?
 
 
 posted in Super Granny 6 on May 2, 12 6:55 AM
As I said in earlier posts, I can get everything EXCEPT the last scarab! I have now moved to 3/3 magmam city lights, where there's a kitty I cannot approach to save, so I'm stuck. The rest was fairly easy.
But I like getting all the prizes, so want to know how to get to the last scarab in 2/6, upper left corner of bottom right area--the one w/the easy to get key!
 
 
 posted in Super Granny 6 on May 1, 12 6:41 PM
granny, I can get all the kitties & the scarabs except the 1 scarab on the top LEFT of the bottom box--box 4? The area w/the key. I can't figure out how to get to it. Can't by rope swing. So HOW!?
 
 
 posted in Super Granny 6 on Apr 30, 12 7:33 AM
HOW!? I did everything else, finally just went on to the next ones. But want to get all the scarabs!
 
 
 posted in Red Crow Mysteries: Legion on Jan 23, 12 5:50 AM
Babs, go back to where you see the fountain ahead, tree to right. Click directly on the stone arch! It took me a few times to get this right, but you don't need a fix.


I still can't get the safe thing to work. Anybody?
 
 
 posted in Red Crow Mysteries: Legion on Jan 22, 12 8:14 AM
I like it pretty well, except for a few snags. I have started over 3 times, am stuck at opening the safe. because I put the paper up, I put the mirror up, I place the stupid ball in the middle, then .... nothing. The 2nd time, the colours flashed for less than a second on the big maze thing, then blank. nothing moves. What am I doing wrong?
 
 
 posted in Super Granny 6 on Apr 6, 11 2:04 PM
Love all granny games, have all.
just bought this 1, & on 1 world, level 10, 'Book'em, Danno', can get all items, gather all kitties, even temporarily trap the beasties. the best i can do from key to switch is 8 secs. the switch takes 7, but by the time i am allowed to move, i have only 3 secs left. not enough to reach gate. Am i missing something? Granny is running as fast as these old fingers can go.
Any hints are welcome.
 
 
 posted in Escape the Museum 2 on Nov 1, 10 7:14 AM
i uninstalled, reinstalled, & it worked. now stuck in bus. hotspot in jacket won't 'hot' up
 
 
 posted in Escape the Museum 2 on Oct 31, 10 7:35 AM
I have read the walkthru, tried changing the pulleys' positions, time after time. it continues to say it won't work like that. what else can i try?
any help to move me forward is appreciated
 
 
 posted in The History Channel Lost Worlds on May 18, 10 2:16 PM
Are there any forums or cheet sheets for the History Channel MonsterQuest? theres a part of this game that has my grandmother and me stumped on. it where we have to reconstruct a case subject's dna but somehow or another the items we are given are not working despite how we try to angle it.
 
 
 posted in Escape the Museum on May 5, 09 12:23 PM
I tried this, spraying the fire , the key, many times. Key remained too hot. What's the trick?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator