Posts created by paco12348

 
 
 posted in Our Wonderful World on Jun 14, 17 5:34 AM
I couldn't get the pieces to move and there's no easy way out of the game. I hate games when you have to search for the out button. [Removed by Moderator]
 
 
 posted in DragonScales 2: Beneath a Bloodstained Moon on Mar 22, 17 6:18 AM
Level 10-10 is impossible. I absolutely DESPISE purchasing a game only to find a level that can't be completed and there's no HELP online.
 
 
 posted in Midnight Castle on Jun 23, 16 12:29 PM
First time to play like this and won't do it again. First, I might have enjoyed the game if there were instructions on how to do things. Easy to find object didn't take as much time as trying to get another screen open for searching.
Another gripe to this game and others I have purchased. An easy way to exit is not easy to find. When I try out a game before purchase, I won't buy it if I must search for an exit.
I didn't know this was a buying game. I don't understand those and hope to heck I'm not charged for something I clicked on.
 
 
 posted in Solitaire Game: Christmas on Jan 5, 16 10:14 AM
I managed to get through the playroom and am now in the professional. The first room played ok but now it's all messed up. I complete a level and all other levels are LOCKED. Now it tells me i have to work them over. This is a total rip off and I will NEVER purchase another game on a special. I believe that's where they put their DUDS OUT. Shame on you BIG FISH.
 
 
 posted in Deep Blue Sea on Feb 2, 15 8:47 AM
I don't like Match 3 building games and would like more like Deep Blue Sea. I do not like DBS2 with it's spinning and freezing boards. Deep Blue Sea has it all: a good story, and boards one never tire of. To me, most M3 games are childish games. DBS is the only one I've found that is superb in every aspect. Are there more like it?
 
 
 posted in Excursions of Evil on Jan 16, 14 12:23 PM
I keep swearing I'll stop buying and trying to play some of these stupid games but here I am again. Right in the first HO scene I need the tape and can't find it. The hint needs the battery in my inventory but the inventory won't open. Crappy, d*** game will go into the dust bin with lots of other crappy games. I have a list started for game makes I won't purchase from again. This one goes on the list.
 
 
 posted in Legacy: Witch Island on Jan 6, 14 5:56 PM
I'm in the forge and have nothing to light the fire with. The hint just keeps pointing to the wood which is in the forge. Throughtout the game the hint is no help at all. The games may be "thought provoking" to some but there are many that I can move nothing at all and have to skip. This could be a good game but I am sorely disappointed in the way it works.
 
 
 posted in Secrets of the Dark: Mystery of the Ancestral Estate on Jul 15, 13 3:21 PM
I used the hint to find what to do in a scene. The hint said I was suppose to get a card at the last hidden object scene but instead I got a picture of a scientist. I need to card to open a locked door and then can proceed with a potion or something I find in enclosure. Since I didn't get the card I can go no further. Any help is appreciated.
 
 
 posted in Patchworkz™ on Dec 4, 12 6:08 AM
I see most people couldn't figure out how to exit, BUT I couldn't find out how to get started. I saw all the patches to select from and all the options. When it said to click BELOW I guess they meant click above to select the patch. At least that was the only thing that worked. I could use the side buttons to go back and forth between options but could not find a way to BEGIN the game.
Anything that has such poor instructions isn't for me. Don't know if I would have liked the game or not. Thumbs DOWN!
 
 
 posted in Bluebeard's Castle on Dec 3, 12 3:53 PM
I can't get the game to use the hot spice in the potion. I have everything I need but it just won't take the hot spice and that's the next thing on the list it shows.
 
 
 posted in Bluebeard's Castle on Nov 18, 12 4:44 PM
I have everything I need for the vanishing dust but it won't take the hot spice. I've tried everything. any ideas?
 
 
If it's said in talk all of us can understand I guess that means this is a free game but to continue playing we must pay dollars to purchase things if we want to keep playing. Right?
If so, it's not worth it.
 
 
 posted in Paradise Quest on Aug 15, 12 12:06 PM
I'm sick of games that aren't fair. This game gives you the vine and the wind tunnel plus other things to move through and complete the levels. You have work at it and play a level several times but it's possible to complete the level. THEN, they give you a level with nothing to help you move through. I think there might be 2 wind tunnels and this is a big level to travel. I don't recall the "experts" speaking to this when I read their reviews. This is the second game I've purchased where the game makers seem to think it's "cute" to throw in an impossible level. I don't think it's funny and I'm noting the gamemaker so I'll never purchase one again. I'll also not read the "experts" reviews. I've played this level at least 50 times and now I'm through and it will go to the uninstall and reject bin.
 
 
 posted in Hide and Secret: The Lost World on Jul 15, 12 11:43 AM
I'm having the same problem and the hint is as worthless as the walkthrough.
 
 
 posted in Hodgepodge Hollow on May 13, 12 6:41 AM
i hate it when i buy a cute game and then find it stinks. One follows the recipe a dozen times and still get a puff of black smoke. The hint just sends you back to the ingredients.
 
 
 posted in Alice's Adventures in Wonderland on May 1, 12 1:16 PM
I hate games that take you half way through and then get stupid. In one scene I needed to find hedge clippers and had to use the hint. It showed a circle on the hedge. I used 3 hints, clicked dozens of times in that circle and nothing happened. I always swear I'll stop buying games but instead I buy and get caught again.
Can anyone tell me where the blasted hedge clippers are within that circle on the hedge?
 
 
 posted in Dark Strokes: Sins of the Fathers on Apr 29, 12 8:56 AM
I've tried painting the right and the left eye and nothing happens. What else should I try. I picked up the brush, dipped it in paint and tried to paint but nothing happens.
 
 
 posted in Dark Strokes: Sins of the Fathers on Apr 29, 12 8:49 AM
In the hidden object scene where one must find the eye I took the paintbrush to dip in the pink paint and used it on the blank eye. It didn't work so I went to the walkthrough. It showed to do exactly what I did. I went back and tried again. The words that come up are "Better not do that" among other things like, "Anymore ideas?"
I'm out of ideas. Does anyone else have one?
 
 
 posted in 4 Elements II on Apr 5, 12 2:30 PM
I'm new to this type of game. Bought this one after reading reviews but can't seem to learn how to use the powerups to go down the thin lanes. I guess it's another game for the garbage heap.
If anyone can suggest a game like Deep Blue Sea (certainly not the 2nd one) then I would appreciate it. I have played that one until I'm needing a change.
 
 
 posted in Ghost Towns: The Cats of Ulthar on Apr 5, 12 1:16 PM
I was loving the game until I came to the playing the piano sequence. I HATE games with the piano. All the other games had a skip button which I didn't have to use but the piano game didn't have one. BAH! Not fair!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator