Posts created by cohiba

 
 
where is the dove aming the cats
 
 
 posted in Spirit of Revenge: Florry's Well Collector's Edition on Jun 30, 16 4:19 AM
cannot get the fish to the cat just doesnt work
 
 
 posted in Christmas Wonderland 5 on Dec 16, 14 2:57 PM
when trying to pick up the knife to cut the apple it does'nt work.
 
 
 posted in Sharpe Investigations: Death on the Seine on Jul 28, 14 7:16 AM
just beginning to enjoy it then it was OVER ,... much too short.
 
 
 posted in Whispered Legends: Tales of Middleport on Jun 14, 14 11:48 AM
Tales of Middleport is an excellent game. Wish there were more from these people.
 
 
 posted in The Fog on Jan 22, 14 5:58 AM
same here - I have the numbers but don't know which row they belong on
 
 
 posted in Entwined: Strings of Deception on Feb 20, 13 10:16 AM
This game has to be one of the best I have ever tried ..
There are so many excellent details it would take a while to list them all.
I only with there were more games from these people.- ? Or at least similar games.
 
 
 posted in Dark Dimensions: City of Fog Collector's Edition on Jun 23, 11 6:30 AM
i cant even reach the saw ... help ? the hook doesnt work and the only other thing i have is a bucket ..
 
 
 posted in Insider Tales: The Stolen Venus 2 on May 31, 11 5:46 AM
playing stolen venus I was doing fine until it came time to spread the sauce on the pizza .. either my mouse is in fail mode or something else is wrong with this part of the game .. have been trying to follow the stars for ages now but nothing happens.. its stuck at this point .. anyone who can help .. id appreciate it. Thanks
 
 
im really stuck .. how do you get the bull's horn .. each time I press the hint ..im told to go to the mortar and pestle but am still missing the bulls horn .. can anyone give me a hint please. ?
 
 
 posted in The Fall Trilogy Chapter 2: Reconstruction on May 11, 11 9:42 AM
I agree this is a big disappointment .. nothing seems to work and Ive tried downloading it several times.
ALSO another game I downloaded didnt work either .. keep getting error messages. Think Ill and join the marines... lol
 
 
 posted in The Fall Trilogy Chapter 2: Reconstruction on May 11, 11 9:37 AM
After severral tries downloding the game doesnt work .. on this version theere is no map. the hint button doesnt work .. generally its a disappointment .. had trouble with another game today .. that makes two that dont work ... grrrrr
 
 
 posted in Mystic Gateways: The Celestial Quest on Oct 7, 10 6:17 AM
I cannot remember having enjoyed a game quite so much as I did The Celestial Quest .. the graphics were amazing - so very clear and perfect. the story line was fascinating and it gave so much pleasure .
The game loaded very quickly and nothing at all went wrong.. I wish there was another like this .. it was said "to be continued" and I cant wait.
thanks ..
cohiba
 
 
 posted in Victorian Mysteries: Woman in White on Oct 4, 10 11:04 AM
I wish I knew how to finish this game too .. how did you manage to get back to the labyrinth ,, all I keep getting is like starting all over again .. the help button does not work and each scene says "nothing more to do here"
before I start tearing out my hair I could use your help . pleeeeese
and thanks
 
 
 posted in Victorian Mysteries: Woman in White on Oct 4, 10 10:45 AM
I was in the final episode of the woman in white .. but after quitting and trying to go back to the last scene .. i had to start all over again at the front door.
how do you get to return to the scene you were last in. ?
 
 
 posted in Victorian Mysteries: Woman in White on Sep 21, 10 5:59 AM
how do I ensure the new edition will be ok .. ? and how can I download just the NEW VERSION
THANKS.
 
 
 posted in Victorian Mysteries: Woman in White on Sep 20, 10 4:09 PM
Big fish should have some explanation to the masses who have written about the poor game quality .. you can go on and on .. and nothing is able to restore the game to where you left off.
this is a big NO..
not worth a cent. am very disappointed in this game.
 
 
 posted in Victorian Mysteries: Woman in White on Sep 20, 10 4:06 PM
you are all correct .. you cant get back to your game.. so where is the saved game button .. not such a great game at all .. right now it seems like a rip off..
I do not intend to finish this and will be very careful in future before i buy.
 
 
 posted in Hidden Mysteries: The Fateful Voyage - Titanic on Apr 6, 10 12:12 PM
AM STUCK TRYING TO UNLOCK THE CRANE .. I CANT SEEM TO FIX IT...
CAN ANYONE HELP ???? I INCIDENTALLY ITS A GREAT GAME IVE HAD NO PROBLEMS EXCEPT IM PROBABLY NOT TOO BRIGHT .. LOL
 
 
 posted in The Tudors on Nov 5, 09 11:35 AM
I could use some help playing the tudors .. Ive reached a point where there is a revolving bookcase . a writing room and a small room with a picture frame.
trouble is the hint I have is just a piece of paper and I cant makeout the hint.
can anyone help please .. and thanks
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator