Posts created by pkbeehler

 
 
 posted in Dr. Cares Pet Rescue 911 Collector's Edition on Jul 11, 17 4:22 PM
I just bought this game and it won't download. when I try to hit "purchase" it said the game was not available yet. however, on the BFG site it was fine so I bought it. But it still has the purchase sign on my game site. What do I do now?
 
 
 posted in Penguin Rescue on Apr 27, 17 3:23 PM
Thanks skpjazz. I will keep trying.
 
 
 posted in Penguin Rescue on Apr 26, 17 8:31 PM
Does anybody know how to win level 113? I only have 12 points to buy any boosters
 
 
Clematis es: I am having the same problem as you with the Shaman. And the hint button doesn't work, it keeps reloading. BFG, please help with a fix.
 
 
 posted in Penguin Rescue on Apr 20, 17 7:21 PM
Thanks skpjazz. That helps a lot. Really enjoying this game.
 
 
 posted in Penguin Rescue on Apr 19, 17 12:00 PM
what am I supposed to be eliminating on level 54? I can't figure it out. I would appreciate any help. thank you
 
 
 posted in Subliminal Realms: Call of Atis Collector's Edition on Feb 18, 17 7:54 PM
Having the same problem with the S in fixing the compass. Like the game and hope there is a fix soon.
 
 
thanks.
 
 
am at the end of this round and no meteorite. Where is it? please help.
 
 
 posted in PuppetShow: Bloody Rosie Collector's Edition on Nov 24, 16 8:15 PM
There is a small hammer located behind the photographer doll but I cannot reach it and I have tried many times. I even tried to increase the size of the program but, of course, was not successful. I have all of the other games in this series and I am sad to say, this will be my last purchase of the Puppet Show series. Unless somebody gets the message and fixes the problem.
 
 
 posted in PuppetShow: Bloody Rosie Collector's Edition on Nov 21, 16 5:37 PM
I finally solved the problem: my computer doesn't support full screen so I didn't realize there are shutters for the window hiding behind the photographer doll. I kept clicking on the doll and the pictures and after multiple tries I finally hooked the shutters. After that I solved the puzzle and got the phone number. Good luck and I hope it helps you.
 
 
 posted in Enigmatis 3: The Shadow of Karkhala Collector's Edition on Jul 24, 16 10:08 PM
Where do the tweezers go when they disappear and how can I get them back?
 
 
 posted in Nevertales: Legends Collector's Edition on Sep 28, 15 6:20 PM
I am having the same problem with the vials when I try to start the solution. I reloaded the game and still nothing. I am current on everything. What do I do now?
I haven't had any problem with this game until the very end.
 
 
 posted in Dark Canvas: A Murder Exposed Collector's Edition on Sep 26, 15 5:38 AM
I was booted out as I reached for the key in the car. And I have Windows 10. Will try to reload game.
 
 
 posted in Lost Island: Eternal Storm on Sep 20, 15 3:27 PM
what do I have to do to get the collection items? I am on level 25 and have collected a few of the first ones but I can't collect the majority of them. Also am stumped at what to do about the 2 ravens I have on the left side of the screen where the challenges were at one time. Nothing happens when I try to activate them. Am I at the end of the line with this game?
 
 
 posted in Runaway Geisha on Dec 17, 14 7:21 PM
as with several other gamers, I too get music and a blank screen. I will reload and see if that helps. hope there is a fix as this looks like a fun HOG.
 
 
 posted in Fear for Sale: The 13 Keys Collector's Edition on Oct 27, 14 5:02 PM
I am having a problem with the glass box too. I will try the suggestion of going into the next room. hope it solves the problem. if it does, many thanks.
 
 
 posted in Alice: Behind the Mirror on Aug 22, 14 8:09 AM
Does anybody know how to solve the maze? I can't seem to get it and I can't find a skip button. the other puzzles have all been solvable. Help! Please.
 
 
 posted in Mayan Prophecies: Blood Moon Collector's Edition on Aug 9, 14 2:00 PM
wish I could help but I'm having the same problem. hope somebody knows how to fix this.
 
 
 posted in Whispered Legends: Tales of Middleport on Jun 12, 14 9:27 AM
thanks stuffnh, that worked for me.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator