Posts created by lisafavre

 
 
 posted in Facility 47 on Jun 18, 16 12:41 PM
I had to cut and paste your answer onto a Word document so I could walk through it. You were spot on with the directions--THANK YOU SO VERY MUCH! Now I can continue on with the game (until the next snag--haha!) Thank you for helping me out. It's really frustrating when you're stuck. Have a great afternoon/evening~
 
 
 posted in Facility 47 on Jun 17, 16 8:48 PM
I am supposed to assemble a map jigsaw puzzle that's on a table in the map room through Building 2. I feel like a do-do because I have no idea how to get there...
 
 
 posted in Criminal Investigation Agents: Petrodollars on Oct 14, 14 4:19 PM
It says I need to pull the correct book numbers with the letters of something or other...can't figure out how to get them. I've got the numbers 18, 10 and then I wrote them all down in numerical order, used up all my hints and now I'm a sitting duck! When you pull the wrong number you have to start all over again. I'm about 1 hour 41 minutes into the game and STUCK. Any help is appreciated~
 
 
 posted in Psych on Mar 30, 14 5:35 PM
I have a room key, tried everything in my inventory and nothing works! I also backed out and went through every available space to see if there would be a hidden object puzzle for me to earn something to unlock it. Totally stuck at that point--any thoughts? Thanks~
 
 
 posted in Who Am I on Jan 25, 14 2:21 PM
THANK YOU! THANK YOU! You really helped me get over that mountain that I was stuck on for quite awhile. I send you a huge bear hug from South Carolina~
 
 
 posted in Who Am I on Jan 21, 14 12:45 PM
I believe the astronomer is in house 23, but I have a purple arrow pointing upstairs and a green arrow pointing outside. I only have 3 pieces of the gun in my inventory but I've been to all the other places on the map and the arrows are flashing to head back to house 23. PLEASE HELP!!!!! I've been stuck for 3 days now~
 
 
 posted in Who Am I on Jan 20, 14 2:13 PM
I've tried going to all the places. My metal detector is dead and every time I use the hint it says to go to astronomer's house 23 for a battery. The arrow going upstairs is purple and won't let me go up. In my inventory I have a gun, thing to hold bullets and a silver handle type thing. I can't get any hint other than the message to go to the astronomer's house for the battery but the arrow won't let me go upstairs. What do I need to do?? Please help!!
 
 
 posted in A Girl in the City on Mar 18, 11 4:49 PM
Hi~~

I was wondering if you had any luck. I am in the same situation, I believe, as you are. I can collect the 9 grocery bags, but what do we do with the items that appear in boxes at the top of the screen when you click on the checkout desk? There is a little light that kinda "glows", so you know where to click. Then these 4 items pop up in boxes at top of the screen...THEN WHAT? Nobody seems to be answering our forum questions because I posted mine on March 2nd and it's 16 days later...NOTHING.

ANY insight you could give me would be GREATLY appreciated! Thanks!

LisaFavre
 
 
 posted in A Girl in the City on Mar 2, 11 11:27 AM
HELP! I have collected the nine bags of groceries, clicked on "checkout number 1" and then 4 items in boxes appear at the top of the screen. WHAT DO I DO WITH THOSE ITEMS? Do I look for them? I tried clicking on them to put them somewhere but nothing works. PLEASE HELP Thanks!
 
 
 posted in Behind the Reflection on Feb 24, 11 4:19 PM
HELP! I've already completed the "hidden object" puzzle by the storage cabinet where I found the horn needed, but it didn't go into my inventory for me to pull up later and add to the storage cabinet. I found all the other items. When I click on HINT it goes up to the stone where there's a face. I've clicked all over the area the hint points to and nothing happens. NOW WHAT?? I'm stuck and I'd like to move on with this game. Please help! Thank you!
 
 
 posted in Agatha Christie: Peril at End House on Jun 28, 10 6:36 PM
I'm loving Agatha Christie: Peril at End House, but I'm stuck and only have 5 minutes left on my clock. I was given an additional room "the parlour" where Maggie is laying dead from a gunshot wound. I'm supposed to find 3 horses and found 2, but I'm out of hints! Please help me asap. THANK YOU!
 
 
 posted in Dr. Lynch: Grave Secrets on Jun 21, 10 1:05 PM
To Sandyengel: THANK YOU!! I've had to redo this chapter over and over because I couldn't find the "L" for the tea room. I looked for a strategy guide, but you completely helped me get past my rough spot. Have a great day! Thanks again.

LisaFavre
 
 
 posted in Dracula Origin on Dec 25, 08 12:15 AM
Hello! I purchased Dracula Origin & got to the point where they are in a room in the manor...the woman leaves and the man finds a map on the wall. Then nothing else happens. He won't go a certain way and he thinks the roses are beautiful. I'm so frustrated! I was hoping there was a Strategy Guide that I could download for this game. I'm also having problems with The Color of Murder. Any other game and I beat them easily but these large file games are a pain in the butt. Any help would be VERY much appreciated!
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator