Posts created by adragon

 posted in Phantasmat: Town of Lost Hope Collector's Edition on Apr 24, 18 2:29 AM
catching up on my older games - cannot find the flat tire at all! Won't let me zoom in on the grating anymore. Stuck
 posted in Mystika 2: The Sanctuary on Oct 16, 14 2:22 PM
I've played two 'names' several times and one is over 2million points because I don't have to buy anything raising the $$ I have as well. The 'end game' puzzles may be ones you skipped PLUS an additional one and then play-on. I have beaten them with help each time for the 2 puzzlers so the assists on this site have worked so well for me. I LOVE THIS GAME!!
 posted in Les Misérables: Jean Valjean on Aug 18, 14 7:02 PM
Forgot how to include the prior post from Valdy - meanwhile, it is a great synopsis. I tried very hard to like this game. It is cumbersome to drag inventory items to the object/spot they are required - lots of extra mousing. Too much reading to do as well (sound too annoying - particularly the snoring in the beginning - and no option but off for me).
 posted in Les Misérables: Jean Valjean on Aug 18, 14 6:59 PM
Valdy wrote:Yaelle, it is a HOG, and for your sake, I hope you will find it good. But it isn't. Far from it. It's misérable. LOL

The choices are: Music: on/off, Sounds: on/off, Full Screen mode: on/off. At least it comes in widescreen automatically - for me, anyway. And there are no difficulty modes to choose from.

There is only the custom cursor, which drags around the scenes. No voices, no map, no diary, nada.

The HOS are basic lists with no interaction. These were the best part of the game, which to me is more of an old-time adventure game with HOS thrown in.

The Hint button takes about 40-45 seconds to refill.

No idea about puzzles and skip button. Just couldn't bear to play any more than I did, and so far I haven't stumbled over one puzzle yet.

--- --- ---

This is definitely an oldie and an adventure game, with huge tabs (rings) showing you where to go, and where to do something. And when you leave a scene, most of the time, you don't get straight to the next scene, but the game has to load that scene first.

The Inventory can't be locked to stay on top. When you want to use an item in the inventory, don't just click on it. You have to drag it to where you want to use it.

The graphics aren't actually bad, but the gameplay is just so out of date, it's quite terrible.

I did like the clear and clean graphics in the HOS, and no clutter, and objects large enough to see. They were quite nicely done.

Well, I am sure you guessed it: I won't be getting this game. But I am sure some die-hard oldies players will love this one.
 posted in Spirit of Revenge: Cursed Castle Collector's Edition on Aug 18, 14 12:01 AM
Stuck also - no help on hint or skip. . .I know what the picture is supposed to look like but I am not adept at 'making it so' - need the object(s) I will receive but am stymied. No walkthrough as yet.
 posted in Mystika 2: The Sanctuary on Aug 17, 14 11:10 PM
There is a bug? Puzzle cannot be solved? What is the answer, then?
 posted in Fright Collector's Edition on Jul 1, 14 12:33 AM
I loaded the 'new build' and now I am frozen; so I am doing a reload. It is soooo slow! I remember doing this game in beta and thought it might be interesting but it plays slowly as well. I was hoping the new build would make it easier - help!
I have the magnet & line but no clock hands are where they are supposed to be. . .backtracked as much as I could - no "joy". Now what?

I had a great thought - it worked out - got what I needed~
I blame the muscle relaxers for my messed up knee in messing with my cognition!
 posted in Haunted Manor: Painted Beauties Collector's Edition on Jun 1, 14 9:06 PM
I now have one game at 70 minutes sample play and 2 at 90 minutes, one a CE the other SE. Neither seem to be beta or survey version. . .saw this in another game and, like I read from another, didn't need that long to determine I wanted to purchase it. Seems the longer times are more prevalent but I am unsure why - I do know at the rate I play sometimes the demo is not over at the 60 minute mark, so maybe it is for folks who are slow like me - works well for me, too! Either way, loving more games to play these days while I have extra computer time to spend.
anabel1566 wrote:Does anyone have the security key for this game? I purchased it yesterday and cannot play without the security key. I cannot get any help from BF either. Please help. Thank you.

Hardware fingerprint: 83FD-1D9E is what I also get and I also don't have any security key; thought this was fixed for me but don't remember how. . .doing another delete/install didn't seem to work.
 posted in 'dillos on Mar 15, 14 1:11 AM
Probably somewhere before this was asked but my searching capabilities are limited, apparently.

It seems that the release of the standard edition is much longer after the collectors edition these days. I really like to play the SE 'first' actually, then decide if I want the CE version.

Or, is it just my imagination?
 posted in Cruel Collections: The Any Wish Hotel on Mar 7, 14 5:43 PM
Still frozen, none of the tips have worked - many uninstall/reinstall, curser change, following all trails. . .just don't know what next to try - any new thought out there for a total freeze near the end such that it won't even boot up - shuts itself down? I am at the entering 6-digit password lock (I know the password, but it flashes on the screen and then shuts down).
 posted in Night In The Opera on Jun 27, 12 10:38 PM
I wanted to try the double game concept (like a couple others with HO & M3 or HO & Majong) but it keeps crashing when I try to go to M3 or the store. . .I've done a delete and reinstall but still black screen with only music. I think I may wait for a patch?
 posted in Dark Strokes: Sins of the Fathers on Apr 18, 12 10:09 PM
Took several attempts to get the paint brush to paint but just kept sticking at it.

Now am stuck at the "claw" between Chapter 12 & 13. . .read the entire walk through and didn't see where it came from; hint just keeps sending me to the 'plate' where I am supposed to write with chalk (which I have) but cannot because I don't have the claw. Walk through doesn't seem to address the claw and the photos show chalk lines without it the later screenshot seems to have it but no instructions on where it is or how to get it; hopefully it is not somewhere way passed??
Saw someone else note they had this problem. . .I am going to double check the CE walk through and see if it might be there.

Update: Used the "find" feature and back tracked and forward looked to find claw (then a few other things). Looks like the chalk drawing is similar to the paint brush on the eye - you need to keep trying it and it finally worked because you don't get the claw until a lot later in the game
 posted in Dark Strokes: Sins of the Fathers on Apr 6, 12 3:31 PM
I missed this grouping and put comments in the CE side (search didn't find this one). I like having a map (it doesn't have to show me much but where I am and where a few things are - I don't need to teleport there) and I don't remember the big blue eye on CE. I was checking CE fans to see if the bonus play is worth the extra $ and it seems it could be; I mostly own SE versions. I always try the hint near the beginning to see what it is going to do - flying feathers is 'new' on this game and I agree with previous post that the lag time and flashiness of obtaining an object in the HOS is a bit too cute. I really like the non-anacronistic HOS - if it is a period piece, I don't want cell phones in my HOS. Sometimes I like all the moving about and sometimes I forget where I am and/or where I saw something. If I want just HO, I can play my Houdini game with unlimited HO (I found enough clovers or ravens or something) or back to an older game - this one is Hidden Object Puzzle Adventure (and darn close to large file), so there is a lot going on. I am letting my taxes "rest" for 2 days while I work on the shredding event tomorrow - all those old records have got to go!
I wanted to play the non-CE before probably buying the CE and awaiting the bonus chat on if it adds or is just added. I love games that cross genres like Hidden Object Puzzle Adventure with something for all my quirks. This game (yes, I loved Sacra Terra and 9: The Dark Side) has the blessing of staying in period mode in the HOS - items are clear, good hot spots, and not just 'thrown together" like some HOG scenes. I intended to put more into my review but missed the chance. I hadn't noticed the big blue eye in the CE. . .but it is in the regular version. There are often subtle differences like collecting certain objects in a CE that you don't in the standard version (either 'real' like a clover, owl, raven, etc. or "enchanted" or similar like the HOS in Escape from Ravenhurst.
 posted in House of 1000 Doors: Family Secrets on Mar 10, 12 3:10 PM
Did figure it out after all. . .did try to get another star pattern first, though then just drew it out and made a few adjustments until it fit the pattern and got past it! I miss the days of lots of HOS and fewer puzzles, etc. so I love it when I get past a puzzle you cannot skip and can get on with the game!
 posted in House of 1000 Doors: Family Secrets on Feb 22, 12 9:35 PM
Well, the bird doesn't appear to be a swan like the star pattern. . .not a long neck and long wings. . .I think I will try out the walkthrough and see if there is some other pattern.
 posted in Mystery Case Files®: Escape from Ravenhearst™ on Feb 20, 12 1:18 PM
I did get it to work by pressing all buttons 'up' and then just the four "down" and the lock did open.
 posted in Mystery Murders: Jack the Ripper on Dec 21, 11 6:14 PM
I have read posts, blogs, walkthrough but, on my second play of the game, the prybar has gone missing and there is no way to go backward to find it as I don't know where it was last seen. I am in Chapter 5 at the Barbershop and need to open the box. . .I am guessing I need to start over? Could be I am using the same profile and should have set up a new one? Could be the 'known issue' with XP? I will try to reload. . .and hope it resolves. . .but, if anyone knows a way around this, please let me know. Thanks!
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator