Posts created by bjcs319

I tried the update, no luck. I uninstalled and reinstalled. Just took me back to where I had been, so no luck. So, it finally hit me. I simply started the game over as a new player. Believe me, it doesn't take that long. IT WORKED. I finally got it. Hope this helps someone.
I finally got it. I downloaded the update, no luck. Tried uninstalling and reinstalling. Just took me to the same place I was, so no luck. Today, it hit me. I simply started the game over as a new player. Believe me, it takes very little time to get there again. IT WORDED. I finally got it. Hope this helps someone.
I finally got the hummingbird solution. I downloaded the update. I tried to go to the room and get it, but did not work. I uninstalled and reinstalled, took me to the same place I left off, so did not work. SO ... I finally just started a new player. I started over. Did not take long at all to get to that spot. It WORDED. I finally got it. Tr starting the game over with a new player. Hope this helps someone.
 posted in Haunted Legends: Faulty Creatures Collector's Edition on Dec 17, 16 6:21 PM
I cannot get the hummingbird solution. I moved the books on the shelf and got the journal. But, I do ot have the solution. If I go back to that room, I cannot click on the bookshelf. If I click hint, it tells me to try somewhere else, there is nothing to do here. Seems I am at a standstill. Please help. I did download the update, but no help.

I just tried to uninstall the game and reinstall - it just took me to the same place. I thought it would start the game over.
 posted in Haunted Legends: Faulty Creatures Collector's Edition on Dec 17, 16 6:17 PM
I have the same problem. If I click on hint, it tells me there is nothing to do here. Seems I am at a standstill.
 posted in Fear for Sale: The Dusk Wanderer Collector's Edition on Oct 29, 16 11:31 AM
I am in the last chapter before the bonus chapter. I seem to be stuck. I am in the room where the "savage" doll is on the floor. The hint keeps telling me to go to the vanity beside the window. I have already placed the dragon piece. I think I am supposed to pick up a glass shard there, but I do not get the magnifying glass that shows there is something to do there. My curser stays the same. Am I missing something: I have a zipper pull, triangle piece, toy plane, and the pattern piece. Please help. Thank you.

Update. I just found out that I need to get the glass shard upstairs. Went there, hint tells me to leave the room. Cannot click on the desk where the lamp is to get the glass shard. Curser does not change into the magnifying glass. Still stuck. Thank you.
 posted in Gizmos: Spirit Of The Christmas on Jan 4, 15 10:09 AM
I don't have a problem. I love these type of games, and the Gizmo series is one of the best. I love the harder levels, the 25 and 30 grid puzzles. Hopefully there are more of these coming soon. Please and thank you.
 posted in World Mosaics Chroma on Apr 29, 14 4:00 PM
I downloaded the newest update. I get the board, but the levels are not numbered. so, I cannot play the new levels. Please help. I tried posting this under the Technical section, but got no response. Please help. L love this game, and want to play the new levels. PS. I uninstalled the game, and reinstalled., Same outcome.
 posted in World Mosaics Chroma on Apr 26, 14 7:47 AM
I just installed the most recent update - thank you. But, when I try to play, the "level number" does not show up. I have al the dots that show where the levels are, but no number, so I cannot access the level to play it. Help. I want to play the new levels. Thank you.
 posted in World Mosaics Chroma on Mar 23, 14 11:17 AM
Finished the last update. Levels 151-175. Can we have more please?
 posted in World Mosaics Chroma on Mar 15, 14 6:54 AM
Not sure if this is technical or not. I was happy to see an update for this game. Reinstalled the game. No new levels. Any infor would be appreciated. I love this game. Thank you.
 posted in World Mosaics Chroma on Mar 14, 14 2:03 PM
Same problem. Installed the update, but no new levels.
 posted in Mystery Case Files®: Shadow Lake Collector's Edition on Jan 3, 13 11:26 AM
Okay. I have 49 of the morphing items. I think I am missing the breeze break in the secret room. Is the secret room the one with the skeleton and the hanging light? If so, where is the dog gone breeze break? What the heck is a breeze break? Thank you.
 posted in Dark Mysteries: The Soul Keeper Collector's Edition on Dec 9, 12 7:02 AM
This is a new one for me. The only part of the game I get is in the upper left corner of the screen. It should be the part that is in the lower right corner. In other words, al I see is the hint button, the strategy guide button, and then his arm. I hear him, just can't see him. Please help. thank you.

PS. I have Windows 8.
Got it. Making progress. Thank you.
I have the gear and the bulb for the door, but evidently, no handle . Where do I get this door handle? Thank you.
Looks like I may have found an answer. Well, maybe not an answer, but...Looks like the strawberry book is just a story. Not the bonus game play. Looks like the bonus game is unlocked after you complete the game. So, no need to find the other strawberries.
Is there a way to go back to get the strawberries? I saw the last two, but it was too late. I could not go back from the gate. I "finished" the game. Wanted to go back and get the strawberries to play the bonus chapter, but it started te game totally over. Any ideas? Thank you.
I had the same problem. dis not have the face. Deleted and reinstalled. Same problem. So, I started over. Worked okay that time.
I am having the same problem. When he died, the face did not go back to the inventory, but did disappear from the hint button. Really sucks that I have gotten this far, and sounds like I have to uninstall and reinstall, and then start over.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator