Posts created by hidnseekr

 
 
 posted in Modern Tales: Age of Invention Collector's Edition on Apr 22, 18 8:39 PM
To macquigan
Thank you, I think I will be going there! Its good to hear there is a place to go
 
 
 posted in Modern Tales: Age of Invention Collector's Edition on Apr 22, 18 8:23 PM
I didn't even know anything is going on. I game to the forums to say this game and others are now giving us a very short demo time. What's up with that?
So anyway, BFG is shutting down the forums? Y? And r they selling their game site? Are our games going to still work?
I also have noticed a high number of "removed by moderator" on the forums of late. What is going on?
 
 
 posted in Eventide 3: Legacy of Legends on Apr 10, 18 4:48 PM
leacraw, I had the same problem.
want to buy game but I'm concerned with its security.
I am using IE on windows 10
 
 
 posted in Darkheart: Flight of the Harpies Collector's Edition on Mar 31, 18 9:16 PM
old_man_river

I do care about all the censors. If people are trying to sell things or using foul language, I can understand but several regulars on the forums have been censored lately. That DOES kind of bother me. I have never seen so much of it!
 
 
 posted in Darkheart: Flight of the Harpies Collector's Edition on Mar 31, 18 8:58 PM
It was a ripoff CE bonus chapter
 
 
I would have liked to see that I collected everything in the achievements. I know in extras there were separate sections for them but it would have been good if it said you have collected "this many" cards etc.

Also I didn't understand the horseshoe puzzle in bonus chapter. After it clicks the first time I saw where to click but after that I didn't see anything else pop up that would tell me the next spot. Had to go to SG. Just wondered if anyone else noticed this or if I am missing something.
 
 
The strategy guide has all the moves written down but has no pic of the solution. I thought I had done this puzzle correctly using the instructions but it didn't work so I went to strategy guide and to look at final pic. but none there. When I skipped it looked like it followed the same directions as me, so whats the deal?
 
 
 posted in PuppetShow: The Curse of Ophelia Collector's Edition on Feb 8, 18 4:22 PM
I didn't care for the fact I could not go back for my missed flowers and snowflakes. The map doesn't always have all the locations still open to go back. When you finish and go to achievements, the least they could do is tell you how many you collected.
Also some of the puzzles made no sense such as a rope hanging from nowhere. I think they could have done a better job considering this is a preferred series. There were many mistakes and "no sense" kind of puzzles.
 
 
 posted in Shadowplay: The Forsaken Island Collector's Edition on Feb 4, 18 7:49 PM
well I had to figure it out. tried to put 43 in but it accepts one number then u have to keep putting in plus number and minus numbers til you get to the right one(43) then press the red arrow on bottom right.
hope this helps
 
 
 posted in Grim Tales: The Time Traveler Collector's Edition on Jan 31, 18 7:30 PM
There was a puzzle, not sure where exactly but in demo. It had 4 circles you line up, outer and inner circles and in the 4 intersections little shapes light up when correct. I got it all right and all lights on but it did nothing. I finally skipped it and it moves a tiny fraction and that was it! I thought it was pretty touchy since I had all the lights on.
 
 
 posted in Grim Tales: The Time Traveler Collector's Edition on Jan 31, 18 7:22 PM
Really???
 
 
 posted in Noir Chronicles: City of Crime Collector's Edition on Jan 14, 18 9:16 PM
In the second punching scene, I could not figure out what to do. The first time you just click on the fists in the pattern it gives. The second one in the upstairs hallway, it showed nothing so I had no way of knowing what to do. I finally went to the guide and went back and tried to do it in the pattern given. Even that didn't work. Maybe its a glitch?
 
 
pennmom36
I prefer more games than hos. I search for hog's cause that's what they're all called. Years ago I loved the hidden objects but as time went on I got tired of searching for things but wanted to actually find my way out of things like with tools etc. But that has even gotten boring. Like for codes they give you a piece of paper to put on safe etc . Some actually just punch the numbers in for you. The old games, I kept a notebook in front of me to figure out my own clues and codes. Don't know why they dumbed it down. I play mostly on casual so I am not looking for difficult things but sometimes it seem a little ridiculously easy and then the next puzzle is impossible lol.
 
 
The paint worked for me but I did not like this puzzle even with the strategy guide so I did skip it. I think you can go out of puzzle and change your level of play ie, casual etc. I play in casual and was able to skip it.
I don't like to skip but don't like this type of puzzle.
 
 
 posted in Crossroad Mysteries: The Broken Deal on Dec 19, 17 1:30 PM
I think this is a tech issue. Towards the end there is a match 3 type puzzle and I accomplished what was supposed to be done but nothing happens. Then I watched someone on Youtube play it and they didn't even finish the object of the puzzle and it ended for him. So now I have to skip it even though I finished it.
 
 
 posted in Crossroad Mysteries: The Broken Deal on Dec 17, 17 2:03 PM
I still cannot figure this out and I am not sure where to "highlight below" is. Can anyone tell me? All the youtubers have skipped it.
 
 
 posted in Dark City: London Collector's Edition on Nov 30, 17 9:23 PM
maryek, I get the same thing. I don't want to continue to download it if it's bad.
 
 
 posted in Living Legends: Uninvited Guests Collector's Edition on Nov 5, 17 8:08 PM
This might be a spoiler but in the demo there is a puzzle where you have to find 12 or 13 living things. It seems like some of them were not living things. (used hints) Not sure what to make of it.
Does anyone have an answer for this?
 
 
 posted in Dark Romance: The Monster Within Collector's Edition on Nov 4, 17 2:26 PM
My game keeps stopping and shrinking to the task bar. I have to click on the little icon and press resume and it does it very often. Just thought you would like to know.
I also have a problem with a puzzle. IN the treasury in chapter six, "dragon treasures", you place the dragon heart and then the puzzle comes up. You need to match up the symbols with the symbol in the center of each one. I have done it correctly, looked at the SG but it won't do anything so I will have to skip it.
 
 
 posted in Midnight Calling: Wise Dragon Collector's Edition on Oct 25, 17 8:10 PM
I don't know why that after you finish you get access to the secret room all you get is be able to replay games and hos. That is usually a given now. I expected something better.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator