Posts created by polbetty

 
 
 posted in Kingdom of Aurelia: Mystery of the Poisoned Dagger on Oct 1, 16 8:08 PM
You have to keep the arrow in the hole for the number, the number will blink when you get there, Hope this helps.
 
 
 posted in Mysteries of Neverville: The Runestone of Light on Jun 21, 14 7:46 PM
I loved the game but some of the HO where hard to see so used the hint button (that is what it is for,correct?). Very disappoointed in the end, I still had items in my inventory so didn't feel I was able to complete the full game. I bought the game and am not sorry, Seemed it was a new developer and wanted to give them a look see and not disappointed (hopefully will only get better).
 
 
 posted in Viking Saga: New World on Mar 6, 14 5:32 PM
Finally got out of the snow and in a desert setting needing to use the air balloon to get from one place to another I can get to one or two but not to all of them. Have retried different ways and I can usually work this out but need help please.
 
 
 posted in The Gift on Nov 27, 12 9:13 AM
Thank you. Now i can go forward, coin and socket just aren't the same thing.
 
 
 posted in The Gift on Nov 25, 12 2:57 PM
Will someone please tell me where the socket is to use on the blue safe at Riker's home?
 
 
 posted in The Gift on Nov 25, 12 2:43 PM
Shirt is on wall in bedroom.
 
 
 posted in Gothic Fiction: Dark Saga Collector's Edition on Sep 9, 12 10:30 AM
I enjoyed the game and bought it. Due to memory problems I did use the strategy guide and had no problem going back and forth, makes for a longer game. Only real problem I had was the pages for the book. Went to the forum and found out my problem. Counted backwards in the strategy guide to were the page was missing. Would have helped if you listed the pages as you did the mystic light (didn't need that part at all as I found those). But enjoyed the game very much. A 1 out of 10 would be a 8 for casual players. Thanks for a good game.
 
 
 posted in Mystery Trackers: Black Isle Collector's Edition on Mar 1, 12 5:09 PM
Look around the statutes.
 
 
 posted in Mystery Trackers: Black Isle Collector's Edition on Mar 1, 12 2:09 PM
Never mind I finally found it. I need the strategy guide. Or is not ready?
 
 
 posted in Mystery Trackers: Black Isle Collector's Edition on Mar 1, 12 2:07 PM
I couldn't find anything to fix stool so used the hint button and was told "It;s near the window. Is it outside , it won't let me look there, or inside, nothing there either. Please help.
 
 
WT?
 posted in Youda Mystery: The Stanwick Legacy on Nov 15, 11 10:25 AM
Yes, a walkthrough would be very helpful. I have some mental problems and stressing out real bad at not finding anything to help you move forward is one of them. This game hint system sucks. I know I need a key for the locks to open, I just don't have any. It took me the whole demo to get all the cubes and was just trying to figure them out to use the elevator but i ran out of time. Won't buy as I don't have the patience to go through all the pages that will slowly no quickly add up. I like working through as far as I can go before hitting the hint or going to the walk through. I would like to get the game once a walk through is available as it looks interesting and challenging (trying to make the brain work better). So Please get a WT. I buy alot of BFG and this is one of the worst ones to start out due to the hint.
 
 
 posted in Nightmare Realm Collector's Edition on Jul 31, 11 3:30 PM
Figured it out.
 
 
 posted in Nightmare Realm Collector's Edition on Jul 31, 11 3:21 PM
I found the beetles but can't figure out how to catch the bugs I need for the potion. Please help
 
 
 posted in A Vampire Romance: Paris Stories on Jul 19, 11 1:37 PM
Tried to get on Subway, can't find a white dot with an M on it and I clicked just about on everything. I found a star but that didn't even do anything. Sorry I don't like this game and I have now deleted it. Won't even get it on a DD.
 
 
 posted in Tales From The Dragon Mountain: The Strix on Jul 3, 11 5:07 PM
They change positions when you put them in. I quit as I never received the coins and now they don't open the gate.
 
 
 posted in The Revenge on Mar 31, 11 8:51 AM
Sinshack, Thank you from the bottom of my heart. I thought I was going compeletly crazy, with all the problems noted throughout this forum and all the glitches. Yes, I reinstalled and they were still glitches. But I finally finished with your help. Again thank you. I was a great game but I will probably wait awhile before I play this wonderful maddening game. I do hope there is a follow-up as it is not dark and gloomy and has a good plot along with less glitches. Thanks.
 
 
 posted in PuppetShow: Lost Town Collector's Edition on Mar 21, 11 1:00 PM
Mine does the same so you are not alone with this.
 
 
 posted in Soul Journey on Mar 1, 11 8:27 PM
I got to the mouse maze and game quit but it ran out of time before I determine if it was me or the game. Cute but no go.
 
 
 posted in G.H.O.S.T Chronicles: Phantom of the Renaissance Faire on Feb 21, 11 5:52 PM

I am having same problem with the game with error message "TorqueGameBuilder has stopped working". I have Vista service pack 2 installed on my Dell computer. I played this game after install up to the trees with the gems and now can't get back in. I changed resolution (just in case this was problem even though it worked without this prior to problem). Have gone through everything and will let the tech side know. Big Fish has worked with me on another problem and they were great. Yes it took awhile and we finally worked it out and the game was able to played. So hang in there.
 
 
 posted in The Secret Legacy: A Kate Brooks Adventure on Jan 23, 11 7:54 PM
went back in 3rd time and finally got it by clicking underneath about midlength of key
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator