Posts created by KAJjak

 
 
Oh my goodness, I was reading this as serve 10 customers in less than a minute EACH. And I was thinking, "Great, easy peasy." :/

Thanks, all, for helping me to figure it out!
 
 
 posted in New Yankee in King Arthur's Court on May 20, 12 8:16 PM
Has anyone figured out how to upgrade the house all the way? I've achieved the gold requirement and none of my workers have become "trapped," but I need 40 wood in order to upgrade the house one more time to get enough workers to finish the level. All the trees have been chopped down and are gone.
 
 
 posted in Roads of Rome III on Oct 27, 11 5:53 PM
I'm trying to get gold on this level (sequentially, it's level 33) and am not really coming close. I ended up waiting on gold to be produced every time I play it, but I really can't figure out a faster way to get the gold mine up and running.

My other option is usually to get the storehouse up and then upgrade it as much as I can so that the gold counts for more, but in this level, the storehouse isn't any easier to get to than the gold mine.

Any advice and tips would be most welcome!
 
 
 posted in Rescue Team on May 10, 11 3:32 PM
I have played level 20 probably 30 times now in an effort to get gold - anyone have any tips? I would really appreciate them!

Thanks!
 
 
 posted in My Kingdom for the Princess II on Dec 15, 10 3:29 PM
Oh my goodness! Your tip of only using the renew resources button after you've killed all the wolves (leaving the one on the far left) was the only thing that got me to finish this level before nightfall! I have played it every which way, over and over, so I am grateful for your post. Big ups.

Brackenlady wrote:This must be the hardest level. Tried numerous times using all the tips here and finally, finally got gold (and beat developer's record). I suspect there is no one right way but in case it helps anyone else, this is how I did it - slightly different to some of the other tips.

Collect resources near start and chop first bit of wood; build hunter's tent.
Continue working down, kill first wolf, build farm when you can
use +1 resources when available to pick up food and the first lot of wood which has regenerated by that time.
Continue working down to the two wolves, upgrade lodge when possible.
Kill wolf use +1 resources and collect what you can, you should be able to kill the second wolf and collect food while the +1 is still operating.
After that the only bonus I used was the one to regenerate resources faster. Chop wood down to pink flowers and down the long path to lower right, build across swamp to gold (but as has been said ignore the pothole and wolf on the left).
Upgrade farm, then cross bridge in middle when you can and work towards second farm and also the gold on the right just past the pothole.
Upgrade lodge to get three workers, then build bridge on lower left and start picking flowers there to get the gold while still working on the wood paths.
Build final bridges when possible.

The key then is to push the renewable resources button as soon as available, collect the resources as soon as they renew, watch so that you don’t go past 20 and, as noted, stop collecting wood when you have built the final bridges. I agree that it is best to collect the flowers further away first leaving the ones near for the last bit. The final thing is not to waste time collecting gold you don’t need right at the end.

Hope this helps anyone still stuck!




 
 
 posted in My Kingdom for the Princess II on Dec 14, 10 3:32 PM
Very helpful tips from both of you, thanks so much! I was FINALLY able to finish this level before nightfall.
 
 
 posted in Farm Tribe on Oct 21, 10 2:35 PM
StripeyCatiana wrote:Woohoo! I've just found my last item - the star on the top row.

It's a pink one, just above where all the totems light up at the top of the map, it's on a little ledge above right and it's over some flowers.

Hope that helps, I was about to crazy when I finally found it ;-)


You saved me! That was my last item, as well. Good eyes, you.
 
 
 posted in Farm Frenzy 3: American Pie on Jun 21, 10 2:11 PM
gpuccioni wrote:No answers? Really?
At least let us know if the version available at BFG is still the old one with the bug.

G


Big Fish Games: I concur! We'd like to know if we can get the updated game from you and if it is indeed the version with the fox for the endless game play.
 
 
 posted in Nancy Drew: Warnings at Waverly Academy on May 24, 10 2:31 PM
puddelz wrote:I was having the exact same problem. I tried numerous things to get her to ask me for the notebook. Here's what I did that worked.

I played the match game on the computer and beat Izzy's score (again as I had already played the game and beat her once, then she topped my score)

I deleted all the pictures I had uploaded.

I uploaded all the pictures again.

I went to talk to Rachel.

She again told me that there was a problem and she posted comments online.

I left the room.

I got a text message telling me that I earned 1 credit for my high score.

I returned to Rachel's room and she asked me for the notebook.

Hope this works for you too!


I have no idea why, but this worked for me, too! Thanks for the assist.
 
 
 posted in Ancient Rome on Mar 5, 10 1:37 PM
I am stuck in this same spot and getting pretty annoyed. Just to be sure I wasn't missing anything, I have built and fully upgraded every single building available to me. No such luck.

bigblah2u wrote:I am also stuck on how to build and estate. Can't go on with the game if there is no estate. Anyone know how to do this or is it a bug that needs to be fixed.
 
 
 posted in Westward III: Gold Rush on Jan 1, 09 1:56 PM
Is there anyway to turn your town drunks back into employed citizens? I have one guy that I forgot to assign to a job and now he's bumming out the whole town. I could really use him in a job.

Thanks for the advice!
 
 
 posted in Westward III: Gold Rush on Jan 1, 09 1:48 PM
Thank you so much! You were right - I was just determined to find the supplies before I continued on to the next mini-quest. Going forward to the next mini-quest allowed me to gain my dynamite license.
 
 
 posted in Westward III: Gold Rush on Dec 31, 08 1:57 PM
tayky wrote:You have to rescue the lumberjacks first and then you get the license!!


What lumberjacks are supposed to be rescued? I keep delaying going to the next quest because I want to get the hidden supplies. I know where they are and I know that I apparently need dynamite to get to that land mass, but when I try to buy dynamite in my general store it says I must first obtain a dynamite license.

If you don't come into this quest with dynamite is there a way to access the hidden supplies?
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator