Posts created by bertiepuppy

 posted in Rush for Gold: California on Mar 18, 14 11:13 PM
When do you drop down?

When it gets down to 2 stars - did that and it didn't help.

When you have finished the first objectives but still have three stars - did that and it didn't help.

So annoyed that this glitch it there.
 posted in Monument Builders: Great Wall of China on Mar 11, 14 12:07 AM
If you like having to click ALL the time and having a game with no tutorial this might be of interest but when you start a game it should actually tell you how to play it not just some garbled stuff - like these guys like to train but they just stand there with hearts and do nothing - never move and no instructions on how to have them move. Developers have to realise that not everyone will have tried a game in a series before. I lasted 5 minutes before I gave up due to having to click to get a worker to do something, then to collect what they had cleared, then to collect something produced with the added lack of instructions. This is simply awful.
 posted in Fable of Dwarfs on Mar 3, 14 12:59 AM
Thank you - I was buying too many workers it seems.
 posted in Royal Envoy 2 Collector's Edition on Mar 1, 14 7:00 PM
Any idea of when it will be here or will I buy it there?
 posted in Fable of Dwarfs on Mar 1, 14 4:28 PM
I am stuck on this level. Any help would be appreciated.

 posted in Fable of Dwarfs on Feb 28, 14 7:26 PM
Do NOT demolish the bank.

First off repair one of the obelisk to the left as you look at the screen - opens up two slots.

Build a manor on one and the sawmill on the other. When you get enough money get 500 wood and change that with the man for the crystal to protect the manor.

Keep getting wood until you can fix another obelisk and then build the food.

Now keep getting 1000 food and wood as you unveil the other obleisks build the manors and protect them - need less food than wood.

When you have three manors and 1500 food (need that much for the remaining manors) demolish the food and build the manor there.

When you have enough wood, a crystal and the food demolish either the bank or sawmill and build the sixth house there.

If you have been collecting money along the way you should have well over 100,000 by then (I had 120,000)
 posted in Fable of Dwarfs on Feb 28, 14 4:55 PM
First off - build the bridges, demolish the food place, the laboratory and the bank and collect the wood - that will give you enough resources to build and upgrade two houses and build the third, pay off the mermaid and build the totem, build a sawmill and buy 1000 wood, upgrade the third house, build a laboratory on the other site and buy the talismans.

Once I realised that you had to demolish everything it was easy but before that it was frustrating.
 posted in Royal Envoy 2 Collector's Edition on Jun 29, 13 4:00 AM
I too am torn between buying it already from the developer or waiting for somewhere between a day and a year for it to come here.
 posted in Rolling Idols: Lost City on May 28, 13 4:34 AM
Game screen flashes ALL the time - thus making the game unplayable.
 posted in Royal Settlement 1450 on Apr 19, 13 5:39 PM
bfgBaikal wrote:Hi Fishies,

bertiepuppy - to build, click the green arrow to the base of the screen as this will open up your building options. Then all you need to do is place the building of your choice; the outline will show up as green once you have placed it in a valid spot.

My problem is that there is no valid space - everywhere showed up red and no greens.

I also have a simply rule - when the tutorial is as bad as this one I save my money and don't buy - so far I have bought ONE game this year and that crashed my computer to the point where I was minus a computer for a week while the IT guys as work rebuilt the computer.
 posted in Royal Settlement 1450 on Apr 19, 13 1:53 AM
Save you time and money and leave this lemon of a game.

Good premise but poorly put together

Developers - go back and fix the tutorial so that it can be completed without the timer running out so the game ends. Make sure that the instructions are clear and that the game actually works. This one doesn't.
 posted in Royal Settlement 1450 on Apr 19, 13 1:51 AM
You aren't missing anything.

I couldn't complete the first tuturial level before the timer ran out as there is nowhere to build the quarry as the screen doesn't scroll at all and everything is so poorly explained that you have to figure things out for yourself.

Note to developers - a tutorial is supposed to explain how the game works in a clear way - not leave the player having to guess. It is also supposed to be able to be completed before the timer runs out and the game has to start again.
 posted in Trivia Machine Reloaded on Apr 3, 13 2:40 AM
I found the History questions were more English based with lots on Kings but maybe it is the luck of the draw and yest the sports were all American - which is enough to turn my off.

If you want to sell a game to an interntional market you have to cater for that market.
 posted in Green City on Feb 10, 13 11:07 PM
I tried upgrading and selling everything etc and was never able to do it as you do need to own the houses - when I own one I get 1/2 and when I sell it I get 0/2 and you have to have 2/2. So buying and selling only works so far - as you do have to own everything.
 posted in Ancient Rome 2 on Jan 25, 13 2:50 PM
I have played the gave through now about 3 times and find the 'no save' and the 'fires' very annoying.

Solved the 'fires' problem by making sure that every third building is a prefecture. Then I don't ever worry about fires.

The 'no save' means that I have to leave the computer on while I do other things as I can't save - most annoying.
 posted in Ancient Rome 2 on Jan 9, 13 6:09 AM
Even worse when you have played a level for nearly 3 hours and have been trying to get one house to level 11 for over an hour of that time but have trouble with fires everywhere with things burning down - simply can't keep the fires down and I build in sets of four - two production buildings, one fire and one warehouse but still get fires all the time.

Had to go out and lost the lot.

Not even sure I will try again.
 posted in Christmas Wonderland 3 on Dec 18, 12 1:44 AM
All that happens is it flashes to a black screen and then back to the normal screen - game doesn't open,.

When I get a game with a technical problem before I can even test it - simple - I save my money.
 posted in Building the Great Wall of China on Nov 30, 12 9:29 PM
Do we still have to click forever to get rid of the dragons or is that skippable?
 posted in Building the Great Wall of China on Nov 30, 12 12:39 PM
ebec wrote:To MarkAlan and Moesart --- I am 66 yrs old and have arthritis in my hands. Pls know this! Not so many yrs ago when I was younger and without health issues I very likely would have "clicked" circles around you. My inability to do so at this time is not a matter of choice, rather one of necessity. I love the time mgmt/strategy games! However, am not able to keep up with the timers. So - I find my "challange" in the strategy. I suggest you open the mind and heart just a bit, and see some things from anothers point of view.

I am with you - arthritis in the hands and fingers makes this sort of game with no relaxed option or even no skip option on the dragons impossible for us to play - and so the developers don't get a sale - they aren't good business people to cut themselves out of a group of people who would otherwise buy their product.
 posted in Building the Great Wall of China on Nov 27, 12 1:18 AM
I didn't find the timer too hard and made it to level 7 - didn't realise that you can't continue if you don't get it done in time but made 3 stars each time.

But...if you don't like 'clicky-clicky' things as fast as possible then you might give this a miss - although you can skip the part of the level - but that is enough for this to be a no buy for me - as soon as the game has one of these things I save my money.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator