Posts created by mogadon

 
 
Windows 10: In William's hideout, in the globe, I found the ship to make up the three, placed the first two correctly, and the third vanished. If I press on Portugal, where the third ship should be, the ship suddenly appears at the "start line" but disappears again quickly, even quicker if I try to touch it to move into place.
what???
 
 
 posted in Dream Walker on Dec 18, 17 2:39 PM
Can't progress through Chapter Four. All 3 stars in all 8 sections but gate does not unlock. Help! Tried to follow directions but in Windows 10 on brand new Surface Pro, under view, hidden items, properties, there is no compatibility tab and can get no further. Too bad, as I enjoy the game a lot.
 
 
 posted in Incredible Dracula II: The Last Call on May 4, 17 7:53 PM
In level 43 required to have a contractors plan or some such to get to the black building to blow it up ... where is it? Can't find it.
 
 
 posted in Incredible Dracula II: The Last Call on Mar 30, 17 10:34 PM
Absolutely true and very frustrating!!!
 
 
 posted in Edna & Harvey: The Puzzle on Dec 28, 15 10:18 PM
Downloaded this game to laptop computer, played fine and I loved it. But computer broke (grrrr - USB ports stopped working therefore no mouse). Downloaded onto new computer, installed Adobe stuff fine, but neither mouse nor touchpad will pick up the pieces in Chapter One. Uninstalled and tried downloading again, same problem. Ideas???
 
 
My tech issue is different, or maybe not. I was really looking forward to this, but when I get to the minigame in the priedieux in the Queen's chamber, the one where you are supposed to put misplaced items in the picture back where thry belong, nothing will move, no matter what I do!
 
 
 posted in The Travels of Marco Polo on Mar 21, 15 7:20 PM
I closed out the game last night. On opening it today I was in the emperor's throne room. Task, give the letter to the emperor. Clue Ashmat's chest contains a letter that will be of interest to the emperor. Problem, there is no letter in my inventory, and no chest either. There is what appears to be a chest on a little table between me and the emperor, but it is dead to me, no hand, no gears appear on the cursor. Not does there appear to be any way out of the room. Gaaaa!! I am bereft because I love this game. Finally a game with no one trying to control/destroy the world with evil.
 
 
 posted in Mystery Trackers: Blackrow's Secret Collector's Edition on Jan 22, 15 12:20 AM
Thank you all for posting. You lose the saw in sawing the trees. In my version at least the girl in front of the house is holding a knife, not shown with sparkles but it's there, and in the inventory on the picture in the strategy guide there it is, and it works, thank goodness.
 
 
 posted in Castle Secrets: Between Day and Night on Jan 2, 15 6:47 PM
Read the reviews but decided to try this game anyway. Love, love, love it. Didn't find it hard to follow for me ... must be my weird mind synchs with theirs.
and if you just press on the "?" button, after huge back stories for all the characters there's an explanation of all the parts of the game ... told me what some stuff was for I hadn't figured out yet. Had a baaad New Year's but 8 hours of play today (and nowhere near done) has quite brightened my spirit. Not at all like the witch who is trying to fill the world with evil games that others may prefer, bit so glad not to have another puppy-eyed child in danger game myself.
 
 
 posted in True Fear: Forsaken Souls Collector's Edition on Mar 18, 14 12:43 AM
How soon, oh BFG, how soon ??? Love, love, love the game. Tired of spirits trying to sieze world power. A true mystery and genuinely hooks you in to the scariness.
 
 
 posted in Timeless: The Forgotten Town Collector's Edition on Aug 7, 11 5:45 PM
"In Timeless: Forgotten Town, can't get out of train engine room - follow directions exactly but stage 6, the big lever, goes up instead of down! Every time!"
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator