Posts created by lost61

 
 
 posted in Cursed on Jan 13, 17 7:15 PM
I thoroughly enjoyed playing this game. Finally something different. No helpers in animal form, no witches, no princess, no hotels egad..a different story!

one problem, took me a while to discover I had to hit menu if I got nowhere in a game so I could skip it.

Otherwise, had a ball and it was not a C.E. Surprise.

Thanks BF, More from this developer please and thankyou.
lost 61
 
 
I can't figure out the order of lights to grab on the ravens beak to enter the lighthouse.
I also agree with another player that that maze game is dumb. I have used the skip button so much in this game and I have been playing for over 5 years.
Usually these dark tales are spooky and this one is just silly.
Sorry BF but tell the developer to harken back to his/her previous creations for a better game.
 
 
 posted in Green Moon 2 on May 11, 16 7:56 PM
There is no cauldron only the pile of garbage where I found the basketball. I can't make the coffee, or the ingredients for the magic boots. Good thing I didn't buy this game yet. The first green moon had all the stuff I'm missing. What's up BF? Help!
 
 
 posted in Mountain Trap 2: Under the Cloak of Fear on Apr 3, 16 8:20 PM
I changed my name and the game plays now. ?
 
 
 posted in Mountain Trap 2: Under the Cloak of Fear on Apr 3, 16 7:30 PM
Whenever I hit play with the courser it stops the game, the courser duplicates itself if I move it across the screen. I have to log out to get the game to shut down.
I deleted and reinstalled the game. Same problem. Help!
 
 
It's a good length and has a bonus game as well.
 
 
I never thought I'd say this but this game is not great. I can't get past level 9 and I've been playing with BF for over 5 years now. Posted a question and not one player deemed to help me. So, adios amigos.
 
 
This game keeps telling me to move on. Can't find a way to open gate with crescent moon.
Anyone have an answer? Thank you.
 
 
 posted in Haunted Hotel: The X Collector's Edition on Nov 12, 15 9:47 AM
I found all six screws and now they've vanished from my inventory? Help! Anyone?
Thank you.
 
 
 posted in Medford Asylum: Paranormal Case on Oct 21, 15 10:32 AM
I watched how they did it on a walkthrough but it still doesn't help me. Does anyone know the steps to get the combination to work? Thanks.
 
 
There is no fix, and Windows Defender on my computer is turned off. I have Windows 7 and the main game worked just fine. Five minutes into the second game it became an error and froze. When I tried to restart game I got a black screen and had to hit ctrl alt and del to get out.

Hurry up and get a fix for us. As the developer you seem to care but saying you care and not doing anything is useless.

Disappointed customer
 
 
 posted in Dracula's Legacy on Aug 11, 15 9:44 AM
Use the board on the gas tank near the purse on the road. When you fill the gas can your hint button will work again.
 
 
 posted in Drawn™: Trail of Shadows Collector's Edition on Jul 30, 15 10:58 AM
I already coloured the scarecrow and was playing the croquet game and had to exit. Came back and the scarecrow is unpainted, no crayons in the scene and the hint keeps telling me to continue with the croquet game! I uninstalled and reinstalled this game.

Can anyone help me?
Thanks.
 
 
 posted in Shrouded Tales: Revenge of Shadows Collector's Edition on Jul 21, 15 10:12 PM
Why do we have 90 minutes to play the demo and then with 27 minutes left it finishes, so then we have to buy the game to continue. Why say 90 when it's less?
Just wondering.
 
 
 posted in Contract with the Devil on Jun 29, 15 9:20 PM
What a game! Fantastic, fun, had to work hard to get through each level. Loved it! First time I played a game in a long time that gave me hours of fun.
Even if the hint didn't tell you everything it pointed at it and that's better than having everything given to a player so easily.
I skipped some games because my hand cramped from playing so long, but wow, it was sure worth it!
Thanks BF for a game that was tons of fun. Hope you get more from this developer.
 
 
Thank you. I forgot the 1st step. Light the fire ..duh!
 
 
How do I wake up this idiot?
 
 
I exited, read some solutions, went back and the white dress went into the red ink.
Hope this helps.
 
 
 posted in Mythic Wonders: Child of Prophecy Collector's Edition on May 30, 15 11:59 AM
I found using the right click released the mouse and was able to go on to finish the game.

I have been playing all the HO games for over 5 years and this one is not that hard in my opinion.

The artwork was fantastic and if I couldn't finish a game I got out.

Good Luck to all the Fishes out there..hang in and persevere.
 
 
 posted in Mystery of Neuschwanstein on Apr 25, 15 8:23 AM
How do I trace the route the airplane needs? Any help would be appreciated.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator