Posts created by holofernes

 
 
mmmpepper wrote:I am having the same problem! I played through the game once already, but I did not find all of the hidden objects or puzzle pieces so I wanted to play through again to open up the bonus level. Suddenly stuck where the girl is chained to the chair and nothing works: not the map, not the inventory, not the exit arrow....nothing! Please fix this!


I am in the same part of the game and it has frozen. This is happening far too often - these games are not inexpensive and I think we should expect better. And, by the way, why do we never get any replies to these posts?
 
 
 posted in Nevertales: Shattered Image Collector's Edition on Aug 2, 14 2:20 AM
Like the game as far as it goes. Am stuck with the organ keys. Have checked the guide information and played in that order - nothing. Have tried all combinations - nothing. The light just goes from C through to B, no stopping no indication of which is correct. I do object to paying for a game that doesn't work beyond a certain level.
 
 
why can't I find the bonus game. Have finished the main game but none of the menu listings indicates that there is a bonus game - although the strategy guide gives it.
 
 
 posted in Awakening: The Sunhook Spire Collector's Edition on Sep 3, 13 4:50 AM
I have talked to the fairy, and should be able to close the book (done) and then collect another crystal - but I cannot do this. Have checked strategy but it doesn't tell me how to release the crystal from the sticky substance (how to stiffen the substance in order to release it). I have gone back and retried several times - but no luck. How do I sort this?
 
 
 posted in Nightmare Realm: In the End... Collector's Edition on Jan 19, 13 11:02 AM
have just played the trial period. Liked it. Bought it. However the trial period ended
with the stick needing to be wrapped up to warm the leaf.
I cannot put the stick anywhere near the fire - it will not release. The strategy guide says put it on the right - and yet indicates the left. I have tried for over half an hour, doing both - going all the way around the fire and cannot release the stick. Do I need to uninstall - I cannot play any further at present.
 
 
mine is flickering and I couldn't find the cursor. I had to wander around the screen
blind until something highlighted. I deleted the game - fortunately I was only trying the one-hour freebie.
 
 
Need help. Have painted scissors grey, but cannot get transformation potion to work on them. Have checked walkthrough and strategy guide and none of them give any info. as to what to do other than paint grey and use potion. Anybody else had this happen - or any suggestions?
 
 
thoroughly enjoying this game - such a welcome pleasure after the disappointment of Dream Chronicles - water! Agree that strategy guide could be better, but it does make you need to think. I always play without sound, so no problem with voices - find I feel sorry for the little dragon having to keep aloft for so long!! If there is a No.3 - I shall be in line to buy.
 
 
Feel that I have been conned. Having begun to play twice, because of freezing - it's too short, too easy, doesn't end properly. It seems that having gotten onto a good thing the game people have decided not to give us full value - because they think we are hooked. I loved the Dream Chronicles 1 2 and 3- was disappointed with Air and thoroughly disgusted with Water. I won't bother with fire- such a pity as the story line is so good.
 
 
same thing has happened to me. Am outside Wish second time and cannot pick up wood, cannot access book, cannot access airship. Have exited and restarted this twice. I didn't finish the Book of Air for this very reason - and now it is happening with this new game.
 
 
 posted in Chronicles of Mystery: Tree of Life on Jan 19, 11 8:47 AM
I so much dislike the games where you have to make the player walk from one place to another. Fortunately I only downloaded this one to play for an hour - just to see whether or not I would enjoy it. It would be useful if we were told this in advance of downloading the game.
 
 
 posted in Crossworlds: The Flying City on Jan 8, 11 9:25 AM
like the fact that I don't have to search unpleasant bathrooms etc., am getting tired of creepy filth. But am stuck in teleporter room with absolutely no idea as to what I should be looking for. Am told that gears need to be replaced - but no clicking makes anything work. Is there something wrong with download - one comment said she couldn't find button - so are there glitches?
 
 
 posted in Crossworlds: The Flying City on Jan 8, 11 9:12 AM
I find I am irritated when mistakes are made in grammar and/or spelling.
And am now stuck with how I operate the machine - hints don't help. Need a walkthrough or clearer hints.
 
 
 posted in Crossworlds: The Flying City on Jan 8, 11 9:07 AM
yes please - am doing quite well but hints not always as good as they might be.
 
 
 posted in A Gypsy's Tale: The Tower of Secrets on Jul 29, 10 6:16 AM
Jolly good game - the best for a long time. Let's hope the sequel will be as good.
 
 
 posted in Dream Chronicles: The Book of Air on Jul 14, 10 8:20 AM
Agree with all the comments - except I am totally stuck on the well. Have all the wooden tablets and the weights but cannot combine any of them. Is it my copy - or am I missing something incredibly simple! (possible).
Far too many dream pieces and far too obvious at that. Agree so much about the grandfather's notes. Game is really not anywhere near as good as the previous ones - which I just loved.
 
 
 posted in Skymist - The Lost Spirit Stones on Jul 11, 10 11:39 AM
In the bar, collected all objects. Exited game. returned to find no wrench. Have tape and half-full mug but cannot change pump handle to other keg. Can still pull up objects, but no wrench there and no possibility of picking anything else up. Has anyone else had this problem? Most irritating - must I exit the game on a permanent basis?
 
 
 posted in Love Chronicles: The Spell Collector's Edition on May 10, 10 3:50 AM
Am just stuck - cannot find the hammer. Have been stuck here for a while and can usually sort this out - but not this time.
Why do we need a bonus? Why can't it be in the main game?
And I think CE are not worth the money - seems to me that we get nothing
special.
 
 
 posted in Haunted Manor: Lord of Mirrors Collector's Edition on Apr 5, 10 10:17 AM
Cannot find pump - cannot recover flat tyres - so cannot reach jack to pick up
last car. Has anyone else had this problem?
 
 
 posted in The Fall Trilogy: Chapter 1 on Jan 18, 10 6:27 AM
I've lost the gold statue! I had it, and when I was placing the small statues in the niche by the side of the statue protected by blades, I accidentally clicked it into the niche and it vanished. How do I get it back? have tried all the ways I know. Do I have to restart the game?
Like the game a lot.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator