Posts created by VeryBigFish

 posted in Tiger Eye: The Sacrifice on May 6, 12 10:43 AM
Although the topic for the walkthrough has not yet been created on the game forum, it is available. You can reach it from the main download page. Just click on "Check out our Blog Walkthrough."
 posted in Tiger Eye: The Sacrifice on May 6, 12 2:41 AM
I was hoping for more of "something" from this game. For me, the story was hard to follow...or even care about. Graphics were a bit rough. Visually seemed very...just...scattered. Did enjoy the puzzles, though they were a bit on the easy side.

I was planning on putting this on my DD list....until I was kicked from the demo before the hour was up. While skimming the walkthrough, I realized that I had completed 4 of 11 chapters in about 40 minutes of play. That means I would probably have just over an hour of play left. I never buy a game that short (even if it scores high in all other categories)

No Buy for me
 posted in Sacra Terra: Angelic Night Collector's Edition on Aug 28, 11 8:28 PM
Just an FYI--This games runs okay on my system. (I have an I7, 9 gb ram, and a pretty nice 2 gb gaming video card.)

But within a few minutes of starting it up, with max video settings -- it sounds like I'm running a high load stress test on my video card. The fan kicks on and is running so high that is sounds like an airplane preparing for takeoff.

Which is strange....I also play one of the newest MMORPGs, at 1920x1080 and ultra settings -- and never even hear the fan, unless I'm involved in a massive battle. And then, the sound of the fan is barely noticeable.

I had to turn my settings down to minimum to keep the fan nice and quiet.
 posted in Gourmania 2: Great Expectations on Feb 21, 11 9:20 PM
I really enjoyed the first one, and this game would have been an automatic buy for me, if not for the bugs - and the overall unpolished feel to it. Among other things:

That sign cleaning problem.....almost made me even give up on the demo.
Paying hundreds of dollars for a sponge?
The ingredients: there is "ice cream" (no flavor) which is white in color, then there is "vanilla ice cream" which is a bit yellow , "mocha" which is brown, etc....I wanna know...what flavor is the plain old "ice cream" flavor?
I don't even mind an occasional typo, but one ingredient is "waffle cone" yet the spelling is wrong on another, "wafle basket." (probably wouldn't have even noticed this if I was satisfied with the game overall.)

I don't know if I'm missing a setting or something, but I didn't like that you could not help more than one customer at a time. (at least in relaxed mode) including picking up the money of the previous customer. It felt too restrictive (Yet I could be picking ingredients for the next customer if I was cutting/cooking something for the first time.

Plus, overall buggy....I had to reinstall just to finish cleaning a sign (which is my least favorite part of the game.)

No Buy.

 posted in Elementals: The Magic Key on Feb 7, 11 10:17 PM
I think I've tried every hog/adv demo on this site for the last few year, so I was a bit confused....because I didn't recognize this one when it popped up as the DD. After downloading, noticed that I'd tried it at some point -- but gave up because it kept kicking me out every couple of minutes....appears that problem was fixed?!

The graphics are nice, and adjusted well to fit my widescreen. But overall, had a really clunky, sluggish feel to it, even on my i7/9 GB ram/1GB video card. Plus, I tend to stay away from the more "cartoonish" looking games. And seemed to be alot of handholding going on. The conversation bubbles kept appearing with a little "pop" noise... that got on my nerves very quickly.

I also was having problem with sound cutting out. Reminded me of what it used to sound lik when you tried play an old, scratched up vinyl record...skipping and popping noises every minute or so....(ohhh boy....did I just "date" myself or what? )

So it's a "no buy" for me.
 posted in The Mystery of the Dragon Prince on Dec 1, 10 7:42 PM
suddensam wrote:...I always turn off sounds, yet in this game the sounds kept coming back, each room was diff, maybe some sound, maybe lots of sound, maybe no sound...

Glad to know it wasn't just my machine! In the past, I've had a few other games that seem to "ignore" the fact that I've turned all sound down.. But I've never had a game that seemed to vary so much from room to room, when I have not changed the settings from my inital set up. I was starting to worry that my sound card was giving out on me. (The trials I've run on other games since "Dragon Prince" have had no sound issues at all.)
 posted in The Mystery of the Dragon Prince on Dec 1, 10 5:52 AM
I found the story idea intriguing, but immediatley realized it was a "no buy" for me. Some of the reasons are already mentioned in this thread (especially no skip!)

But another reason:
I had all sound settings set as low as possible, yet I there was still sound from my actions, and background sound at certain locations. I find this extremely annoying, as there are times when I wish to play without sound. I'd find it less annoying if sound control was not even in the settings. BUT IF YOU MAKE IT AN OPTION IN THE SETTINGS, at least get the settings to WORK PROPERLY!

Plus....the game just had an "outdated" feel to word I can think of to describe it...... very clunky. (mechanics, screen layout, graphics,etc...)

 posted in Jane Lucky on Dec 1, 10 3:05 AM
In my opinion:

Shallow game: irrelevant "find 10" scenes, inane dialogue, bad grammar.

I hope this isn't a ******POSSIBLE SPOILER******

as everything to follow happens within the first ten minutes of the demo, but....

I'm not in the mood to play a blond bimbo that picks pretty flower and keeps the wild animals safe (while her professor has been taken and the assistant is badly injured and there are gunmen all over the place.)

"I think if people admired the flowers more often, there would be less trouble in the world." and "Now the animals are safe...."

That's as far as I progressed in the demo before it hit the trashcan.
 posted in Lost in the City: Post Scriptum on Nov 3, 10 11:36 PM

After just finishing the game, I had one thought I wanted to share, and this thread seems to be as good as any. It gave me a good laugh here and there but was still eerie...a first in my experience.

....Not depressing for me the way others describe, but more on that in a sec, lol.... I thought the graphics were great. The interaction with puzzles, for the most part, was pretty intuitive for me. (There was one that I had to read the instructions several times....and still didn't get to camera, if I remember right.)

I noticed a few grammatical issues, but they weren't the kind that annoyed me enough to detract from the enjoyment of the game.


One thing that stood out, though, is the misuse of the neurological disorder - Narcolepsy. But it's almost always misused or misrepresented in movies, books, etc. It's not about sleeping all the time, but about not getting quality, deep "sleep." So.... It's really about sleep deprivation. So you get drowsy, sleep easily...but you wake up easy too-sometimes just a bit slowly. And it's not always so severe as "blacking out." There aren't any drugs available that really "cure" it. (I wish!!!)

TRUST ME! The last thing a "narcoleptic" wants to do is down a case of energy drinks and gobble a bunch of energy bars. It's a really, really bad way to self medicate. (Caffeine makes it even harder to reach Delta sleep-so your body may not be tired - but your mind is even sleepier!) (SERIOUSLY...I've done vast "scientific experiments" of the caffeine effect. on a narcoleptic.)

This misuse of the word didn't bother, offend, or annoy me or anything, still enjoyed the game. But wanted to explain why I found it so funny. But the misuse sort of added a humorous aspect to the game for me (that might seem weird given the story line.) But yet it still had the eerie feel for me, so...quite a unique gaming experience to feel both with the same game.

p.s. afk, gotta go refill my Coca

 posted in Columbus: Ghost of the Mystery Stone on Sep 29, 10 11:17 AM

I have W7/64 bit. And haven't had any problems any recent games, but this game gave me a bit of trouble.

First try, from game manager wouldn't start - just a black screen with cursor.

Second try, directly from "hidden" exe file let me into the game, but then, something came up IRL so I exited after ten minutes to save demo time.

Third try, directly from "hidden" exe file didn't work. :::boggle::: (exact same settings?)

Fourth try, from exe with "compatibility" settings checked didn't work.

Fifth try, after delete, reboot, install....didn't work.

Sixth try, after unchecking "compatibility" setting (but not reinstalling or rebooting again) directly from .exe file works!!

I can now reenter the game fine, even from the game manager....but I'm not sure if that's because of the last fix, or because the game is now activated. (didn't check game manager between fix and purchase.)

 posted in Chocolatier: Decadence by Design on Sep 29, 10 10:35 AM
BarbaraFish wrote:Not to worry. If you did already buy the game and you tried to buy it again, the game manager would tell you. It's already happened to me several times. I can only plead old age and bad memory

Thanks for both posts!

I just popped in to confirm that it was the third version! (I have bought 1 and 2.)

And ....Barabara....thanks!!!
Lately, I've wondered about that! I've been resorting to checking my purchase history , 'cause I didn't know if I'd get a warning about a double purchase. I think I'll blame it on the large # of games that I've purchased here in the last few years......

(I normally go with the bad memory excuse, but I've got the big "40" coming up, so I'm a wee bit senstive about it right now.)
 posted in A Gypsy's Tale: The Tower of Secrets on Jun 26, 10 12:28 AM
Try a new user account in Windows 7!

About "Access Violation" on startup

I was constantly having this problem with my new system. I couldn't even get into many games. I had tried all the fixes suggested in the various forums here. Reinstall, run as admin, grating full access granting access in firewall/av, run from copy, etc....NONE OF IT fixed the problem. I was pretty sure it was not a problem with my system, but with the game manager.

But after reading some diagnostic windows logs, realized I was having permission problems. Even when I ran a game from admin, it wasn't really giving me the full admin rights.

So I created an entirely new "User Account" in Windows 7. And as soon as I logged into the new user account, all of the previously inaccessible games worked just fine. (I set the account up with identical video/firewall/audio...etc. settings that I had on the original user account.) I didn't even have to reinstall the game manager. The error messages have totally disappeared now. (I've tried all of the games that I had written down that had given me the error.)

Unless you really know your way around windows, though, DO NOT delete or change the old, original user account. There are some programs that do care which user account is logged on. (Microsoft outlook, for example....I couldn't access my emails until I back up and restored my personal file to the new user account.

I believe my user account was corrupted because I had transferred my entire user folder from an older xp machine. And there are hidden files that affect permissionsand access control. (In theory anyway, ...all I know is that everything works now!)
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator