Posts created by Sablesshadow

 posted in Haunted Legends: The Stone Guest Collector's Edition on Jun 29, 16 10:57 AM
I have three out of four, only by luck. Try clicking on the teacher's portrait and move to empty spaces. That's how I got the other two. Still missing one.

Yes, the Strategy Guide is a piece of garbage.
malcolmbart wrote:
leacraw wrote:I'll leave the game play review to others. Sadly, I didn't care for how the custom feature worked for the hint and skip times. Because it is a sliding bar that increases the hint time it decreases the skip time.The reverse is true when decreasing hint time the skip time goes up. For me that isn't an acceptable option in custom mode.

I totally agree. I've always felt that developers who force you to wait an interminable amount of time to skip or get a hint are either control freaks or are trying to make the game seem longer than it actually is.

Yes, agree completely. And if the game isn't able to be compatbilized by the player, don't name it so.
 posted in Mountain Trap 2: Under the Cloak of Fear on Mar 17, 16 8:03 AM
Relatively short, but for me, captivating. I usually rely on W/T's, but found I really didn't need one for this game, although I was caught out on one portion.

I really enjoyed this game, despite the brevity, good story I thought and interesting puzzles.
 posted in Entwined: The Perfect Murder on Apr 24, 15 7:34 AM
FreakyHobbit, I agree as far as switching the controls from left to right. I'm a lefty also, and, had I known about this condition to play the game, I never would have bought the game.

Very frustrating.
 posted in Entwined: The Perfect Murder on Apr 24, 15 7:27 AM
I'm a lefty and found the same problem,. Wish I had found it before I bought the game, very irritating.

I'm surprised I didn't see any other complaints about the switching, but oddly enough, many complaints in the forum have been locked.

There is a walkthrough, furnished by Big Fish, in You Tube. That's where I got most of my answers. Good luck.
 posted in Fantasy Mosaics 4: Art of Color on Nov 26, 14 2:11 PM
I bought the game, but when I try to open it, only get a blip from my laptop. Can't play the game. Off to Customer Service (ha!) to see what's up.
 posted in Surface: Game of Gods Collector's Edition on Nov 20, 14 5:57 AM
dobbiemijnboekje wrote:
troischats wrote:Not the nicest way to ask for help! Manners cost nothing.

But then again, the response of "Open your eyes......" wasn't the most helpful either.
 posted in Melissa K. and the Heart of Gold on Sep 17, 14 10:38 AM
Lazeedragon, look at the post just two above yours "repair of boat." I've put the steps I've used to fix the boat. Wasn't easy by any means.
 posted in Melissa K. and the Heart of Gold on Sep 17, 14 10:35 AM
patinmass, this wasn't easy by any means. I've put the direction I've used below using the spoiler. Just use your cursor to read between the words spoiler.

Spoiler: First I had to use the flashlight on the big hole in the wall behind the skeleton to get the linen bag that's needed. Then I had to move the boat support where the hint shows the circle. Keep moving your cursor till you find the support and it stays still (it's like a U-shape. Then I believe I had to put the two oars in the boat. Then, I think, I had to find the directions, which were in the water near the entrance to the room, kinda directly across the room from the skeleton. Once you have the directions, you'll have to go to another part of the game where the big pile of sand is to get some sand into the linen bag. Then back to the boat, where you can finally use the catalyzer you should have (at this point I think the hint will tell you where to find the catalyzer). You have to use the catalyzer, the wood file and the can of hardener (I'm sorry I don't remember the exact order, but the directions will tell you explicitly. By this time, the only thing you should have in your inventory is the baby experiment. That should do it. Spoiler
 posted in Panopticon: Path of Reflections on Jul 17, 14 5:31 AM
huckleberryblue wrote:I know that i need to use the notes on the wall but I have no clue how i am supposed to use them to arrange the rotating rings in the right places

Huckleberryblue, I googled the game, and on the second YouTube walktrhrough, got the answer. Hope this works for you. I'd put the info here, but BF doesn't allow it. Sorry, hope you find the answer.

 posted in Tales of Terror: House on the Hill on Jun 15, 14 4:39 AM
[Removed by Moderator]
 posted in Black Rainbow on May 14, 14 7:06 AM
Angelfish, thank you for the information about CCleaner. I had tried to load it before, but Norton wouldn't let me. This time it went through with no problems.

RockinRobin, I had the same error message that you encountered. I took a chance (only because I have hundreds of BF games) and I hit continue. So far so good, but I do wish someone would check and DO SOMETHING when this type situation occurs, whether it be developers or BF.

ETA: And by "do something," it could range anywhere from an update to the game, or a reason for the happenstance, or at least an acknowledgement of the problem, and the fact someone can/cannot fix it. Nothing like being left out to dry, lol.
 posted in Deponia: The Puzzle on Apr 29, 14 5:01 AM
When I try to open the game, I get a message: This installation of this game is damaged. Try re-installing or contacting the publisher for assistance.

Guess it's not for me, lol.
 posted in Dark Dimensions: Somber Song Collector's Edition on Apr 26, 14 11:04 AM
Thought this one would drive me (sorry) right around the bend. Thanks for your hint, would never have gotten it otherwise, ReallyHelpless.
 posted in Off the Record: The Italian Affair Collector's Edition on Apr 18, 14 5:36 AM
As joray says, the important thing is to pick up the camera from the bottom right. I was thrown because when the pointer changed to a camera, I mistakenly thought that was the actual camera. Duh! on me.

Once you've clicked on the camera and it stabilizes on the swan, then you can get the filter from your inventory and then play the little mini-game to get the picture in focus.
 posted in Off the Record: The Italian Affair Collector's Edition on Apr 18, 14 5:34 AM
If you mean the hint on how to solve a puzzle, it actually shows up on the bottom of the screen. Instead of the inventory, it shows the word HINT. If you click on it, the hint on how to solve the puzzle shows up. Kinda confusing.
 posted in Off the Record: The Italian Affair Collector's Edition on Apr 17, 14 9:31 AM
I didn't realize until half-way through the game that when a puzzle comes up, the inventory down at the bottom of the screen changes to the word "Info" and that's where we get info/hints on the puzzle. Sheesh, takes me a long time sometimes.
 posted in Off the Record: The Italian Affair Collector's Edition on Apr 17, 14 9:28 AM
Belamba, I had the same problem - seems like it took hours to find the answer. I just kept clicking on the swan with the camera only, when it finally took, I could put the scanner filter on it finally, then proceeded to make the picture clear.

Once I finally found where to click the camera on the swan, seemed to go OK. Don't try to use the scanner filter until the camera stabilizes on the swan.

Good luck,
 posted in Emberwing: Lost Legacy Collector's Edition on Mar 17, 14 7:13 AM
Yes, use the lens before using the cat, cat chases mouse, then you can use little hook. Wasn't really clear to use the lens in the Strategy Guide.
Go to:   
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator