Posts created by Waycross48

 
 
 posted in Supercow on Mar 10, 09 2:15 AM
I'm at the end of level 6 - battling the "Big Boss" - what in the world do I do to defeat this thing?? I've been "Killed" several times before I even know what's happened!! Are there any suggestions for how to defeat the Big Boss before he gets me again?? I'm getting sick of repeating this level again and again. I've done extremely well up to this point. But, He's huge so jumping on his head isn't much help, especially with him throwing large "rocks" at Super Cow. Any hints before I die yet again??? Thanks!!
 
 
 posted in Super Granny 4 on Mar 4, 09 3:29 PM
YOU ARE A GEM!!!! Thank you so very much!! These games are fun and so very entertaining but they can drive you crazy sometimes (and, frankly, for me that's not too far !!!). Seriously, I do appreciate the fact that you take so much of your time to help people with these games. Don't know what I would do without the Forums. God Bless, J
 
 
 posted in Super Granny 4 on Mar 4, 09 12:41 AM
I went back and looked and I don't see anything that tells me "which quilt" - all I can do is describe it - it has light pastel patches with white chalk marks on it (diagrams) there's an american flag patch, a red and blue marble and a patch that has a face in the cent with blue ruffle around it. Sort of like a button with a ruffle around it. That's all I know unless you can tell me how to find out which particular quilt it is. Thank so much for your conintued attempts to help me out.
 
 
 posted in Super Granny 4 on Mar 3, 09 11:59 PM
I'm sorry! I should have gone back and checked to begin with. It's level 14 - Cat-a-pult. The minute the game starts the little guys in black (not sure exactly what they are called) come down so quickly that I don't have time to do anything. Even when I manage to dig a hole for one of them, the other is right on top of Granny before I can do anything. I've been doing this a while and usually am pretty quick in getting Granny out of the way or using a tool to fight any opponent. But, these guys are too quick for me. Thanks for the prompt response!!
 
 
 posted in Super Granny 4 on Mar 3, 09 11:10 PM
I'm at the level (forget the number) where the two little "undead" looking guys in black first appear. Before I can even move, they've attacked Granny and I have no idea WHAT she is supposed to use to protect herself before I can get to the shoes. I do see the racing shoes but I can't even get to them before getting clobbered!!! I have managed to dig a pit for one of them, but the other comes so quickly that I can't do anything else. Any hints for how to deal with these little varmits??? It gets very frustrating having Granny get bonked before I can even move!!! There has to be something I can do to deal with these annoying little guys.
Thanks!
 
 
 posted in Dracula Origin on Jan 28, 09 10:02 PM
Which safe are you referring to - there are several throughout the game?
 
 
 posted in Dracula Origin on Jan 28, 09 9:57 PM
Well, I finished the game tonight and the ending was truly amazing. I was personally, disappointed in the overall outcome at the end. I guess I won't say more - I would never want to give anything away as this game is just too much work to have someone spoil it for you. it's just one of those surprises that you're not prepared for. I have to say that this was the most challenging game, to date, that I have completed. I applaud those 'great" minds who are capable of coming up with these detailed stories and all of the intricacies involved in each step along the way. If you miss a single item, you cannot complete that portion until you go back and get it right - no opting out of a puzzle on this one - you HAVE to do it and do it right!! It was quite a "ride" and I'm somwhat disappointed that it's over!! I'll just wait for the next one. Anyone got any suggestions??
 
 
 posted in Dracula Origin on Jan 28, 09 6:46 PM
In the inventory - put the measuring tape onto the spool of thread, then take the wood spoon and put that with the other two. That should do it for you unless there's just a glitch somewhere. But, this is how I did it, plus I went back and checked the Walkthrough for this part of the game. I'm in Transylvania right now!! This game gets more and more interesting the longer you play it. But, it can get frustrating at times when I can't get something to work for me.
 
 
 posted in Dracula Origin on Jan 28, 09 5:07 PM
I'm just wondering if you are able use your Escape key to follow the "Save Game" instructions I left. I saw a couple of people who seemed to be having problems using their Escape key.


 
 
 posted in Dracula Origin on Jan 28, 09 4:00 PM
you can also just hit the ESCAPE key. I don't know why, but I sort of got in the habit of doing that with this game.
 
 
 posted in Dracula Origin on Jan 28, 09 3:58 PM
The person who did the walkthrough I'm using is: MaGtRo from GameBoomers - the one I refer in the post above. js.
 
 
 posted in Dracula Origin on Jan 28, 09 3:50 PM
Go to GAMEBOOMERS and you'll find a GREAT Walkthrough for DO. I've got it printed out and it's 39 pages. The rules prohibit posting URL"S on the Forum, but you can go there and do a search for a particular game.
The one for DO is extremely good. I like to do as much of the game as I can without assistance, but when you get stuck on a puzzle or some action within the game and you can't go any further until you solve it - having a walkthrough has saved me from taking a hammer to my computer!!LOL
Seriously, I don't know who did the one for this game, but it's the best. It has pictures of each puzzle along with detailed instructions for solving them if you can't do it yourself.
Best of luck. js.
 
 
 posted in Dracula Origin on Jan 28, 09 3:31 PM
When you are ready to leave and SAVE your game:
1. Hit the ESCAPE KEY
2. From the Main Menu - click on SAVE GAME
3. This brings up the "brown boxes" - click on any EMPTY BROWN BOX - it will HIGHLIGHT BUT you will NOT see anything in the brown box yet.
4. Go to the top of this page and select - YES
5. NOW you will see your last scene from the game appear in the brown box (with a date & time)
6. Go to BOTTOM of this page and click "BACK"
7. From the main menu - click EXIT GAME - it will ask if you really want to exit the game
8. Now, select "YES"
YOUR GAME IS NOW SAVED.
To get BACK to the game later:
I use my Big Fish Game Manager to get back into the game. Select the game you want to play and it begins to load. The MAIN MENU comes up and you simply select RESUME - that's it. You should now be exactly where you left off earlier.
Hope this helps!! God Bless, js.
 
 
 posted in Dracula Origin on Jan 28, 09 3:08 PM
To get BACK INTO THE GAME
I use my Big Fish Game Manger - I keep the icon on my desktop.
I select the game I want to play and it begins to load.
After loading, the main menu pops up
I select RESUME
THAT'S IT - IT GOES RIGHT BACK TO WHERE I LEFT OFF.
Then, when I'm done - I go through the SAVE GAME process again.
Hope this and the SAVE GAME instructions in my previous post help those who are having problems with it. I'm new to some of these games and we all sometimes have trouble with what, to others, are the simplest things. They're not so simple when it's "you" having the problem. I'm just grateful for all the wonderful people on the forum who are willing to help - no matter how insignificant the problem seems. God Bless, js
 
 
 posted in Dracula Origin on Jan 28, 09 2:41 PM
This is "step by step" how I save my game and I've NEVER HAD IT FAIL.

When you are ready to LEAVE THE GAME-
1.hit the ESCAPE key (make sure no inventory items are on the screen)
2.From main menu - click on SAVE game
3. From the next page - click on any EMPTY BROWN SQUARE -it will HIGHLIGHT but you WON'T see anything in the box yet.
4.go to the TOP of this page and click on YES
5.NOW you will see the last scene you played appear in the BROWN SQUARE BOX along with the date and time.
6.Go to the BOTTOM of this page - click on "BACK"
7. THIS WILL TAKE YOU BACK TO THE MAIN MENU
8. click on EXIT GAME - A NEW option will pop up and ask if you really want to exit the game
9. click on YES
THAT'S IT - GAME IS SAVED!!
this works every time for me. I wasn't quite sure how to do it either at first. js.
 
 
 posted in Dracula Origin on Jan 28, 09 2:29 PM
Hi, II haven't experienced that specific problem but I do notice that my cursor will sometimes be VERY difficult to control and hard to move. It's like I have to push it around. But, I can get out of the game and come back to it and the cursor is fine. In one scene I was taking him to another part of the room - the library in Cairo - he just walked in place, over and over again - going nowhere. So, I took him upstairs and then brought him back down to where I wanted and he was fine.
I guess I am going to have to learn to "think" like a "game". Logic doesn't always do it with some of these games!!
By the way - GameBoomers has a great Walkthrough for this game - the link is somewhere in the forum - although I read we are not supposed to put url's on the forum - they did not remove it -so it's still here. I like to try and do each action and puzzle on my own. But this game has some very difficult puzzles and other actions and you cannot proceed until you accomplish them. So, I keep the Walkthrough handy. I printed it out - it's 39 pages!!!! But, it's a very well done walkthrough and I have a great respect and appreciation for the gamers who take the time to do these. Especially this one - it's very long and complicated. There are pictures of the puzzles and he mentions the "little" things that you wouldn't think of - like having to click on the intersecting lines on the map. I ran into the same problem until I just accidently clicked on it - this was before I downloaded the walkthrough.
Best of luck - I'm in Transylvania now, headed to Dracula's Castle. Even with the occasional help of the walkthrough, this is a LONG game but I am enjoying it very much. I'm afraid it's going to make all others seem tame by comparison. js.
 
 
 posted in Dracula Origin on Jan 27, 09 8:25 PM
Yes, I have the black Sphinx. I'm going to have to stop playing this game late at night. I must have forgotten using the other items last night
But, a strange thing happened - this morning I went through every item in my inventory for identification. No metal rod was there, yet I was positive I collected it and it was missing from the statue - so, I HAD collected it. Being frustrated with the game, I saved my location and just closed it out. and posted my query on the forum.
Later, when I went back to the game - there was the metal rod!!!! I don't know if it was a glitch of some kind but it's there now.
Once again, I am indebted to you for your efforts to help me along with this game. I normally play games like RT Ravenhearst - with combos of HO and puzzles. This is the first time I've played a game totallly like this one and it can get frustrating at times. If not for the help I've been getting on the forum - I would probably have abandoned D.Origin. So, thanks again for the help.
I've also noticed a couple of other strange things with this game. At times - although not everytime, my cursor will be slow and very difficult to control. Other times when I go back to the game - it's just fine. I guess it's one of those things like the metal rod disappearing. I've noticed a couple of other people complaining about the same cursor problem. I've not experienced it until today!! God Bless, js
 
 
 posted in Dracula Origin on Jan 27, 09 12:59 PM
I'm in the tomb after arriving in Cairo - I need the rod which I removed from the statue in the tomb at Blood Rocks.. I've performed all necessary movements - turning the water into sand, weighing the gold,etc., and collected everything available. I opened the secret doorway that led to the crocodile platform. When I went back to the funerary boat = I followed the directions regarding the boat - to use the axe on the right support under the boat - then to put the broken column piece there to support it and THEN to get the rod I had collected from the statue and use it to push the boat down the ramp into the water through the secret doorway. I cannot find the rod I collected anywhere!!
I scrolled through the entire inventory list = no rod. any ideas??
Also, I have another question - is it possible to restart the game from a previously saved spot rather than the last saved position in the game. If I could go back to just before arriving in Cairo - perhaps I could revisit the museum and pick up the items I missed there, and I could go back through the tomb at Blood Rocks. But, I have tried going back to one of the previously saved spots but can't seem to be able to do it. (it's sounding like I may as well just start the entire game over but I sure hate to do that!!!!
God Bless and thanks!! js
 
 
 posted in Dracula Origin on Jan 27, 09 7:13 AM
I'm inside the tomb at the Blood Rocks. I've done the gold - turned the basin water to sand, placed the three pyramids, etc. Then I took the metal bar from the statue, took the piece of column from the floor.
Then, opened the secret door, I went down the steps to the crocodile platform and have come back upstairs to get the funerary boat. He used the axe to cut the right support on the boat, then used the broken piece of column on the right support.
BUT, now I need the metal bar I took from the statue - but every time I go to the right side of the boat where the column support was placed - he says it's "too heavy" because he needs the metal rod to help push and I cannot find it now. I took it before I took the broken piece of column. But, it's NOT in my inventory with the other items. I've looked 2 or 3 times now - I've scrolled through everything.
So, what do I do??
Just like the items I KNOW I clicked on during the first visit to the museum - I cann't find them now in my inventory. From that first visit - I am missing - the scribe's stylus, pharaoh with broken head, small granite scarab, head with solar disk.
I've scrolled through and clicked on everything in my inventory and these are not there.

What in the world could have "happened" to the metal rod from the statue? The "Walkthrough" I have says ""use the metal bar on the piece of column. Use the metal bar again to push the unsupported boat down the stairs to the pool inside the secret room.
But, the bar has seemingly disappeared. All Van Helsing does now when I click on the right end of the boat where the piece of column is - is to say "it's too heavy". He needs the bar that I no longer have. Don't know what to do here.
Any ideas, anyone?? Thanks!
 
 
 posted in Dracula Origin on Jan 27, 09 2:49 AM
You are welcome and thanks for the reply!! Dracula is the first of this type of game I've played. I like HO games and then did Return to Ravenhearst and completed all but two of those puzzles by myself. But Dracula's Origin has been amazingly difficult. Things like knowing to hang the lantern on the end of the shovel to get through the iron gate in the cemetery. I guess I have to learn to "think" like a gamer. God Bles YOU and happy gaming!!! js.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator