Posts created by nivlem007

 
 
 posted in The Mirror Mysteries: Forgotten Kingdoms on Jan 21, 13 10:55 AM
dobbiemijnboekje wrote:Again a very slooooooooooooooooooow DL.

I noticed it took longer than usual and my speed dropped from 54 mbps to 36 while this was downloading. But it did not take 3 hours as one fish said it did?
 
 
 posted in Aquapolis on Jan 15, 13 1:37 AM
BFGHondo, I am waiting for reply to this problem. It really is a big nuisance and very annoying. They should have checked this out before release.
 
 
 posted in Aquapolis on Jan 15, 13 1:30 AM
I really enjoy this game but, I don't shut down computer, I don't run CC cleaner and I have to put in new profile every time I open game to play. I am fed up with doing levels 4 thru 9. the only way I can finish the game is to leave game open, but that stops me playing any other game. So a great big waste of money, I have un-installed and re-installed made no difference to me. I could try again but will it work properly???? Who knows? Can only try and try again.
 
 
 posted in The Tribloos 2 on Jan 14, 13 8:14 AM
Great little game but why does the timer go so very quickly? I always like to try for gold on these games but most are not possible. This is certainly a very different game to the other types of builders and it is a great game to play. I am enjoying very much especially as I have not seen the 1st edition. All I can say is that if the gamers can only comment on your spelling then you have a winner. Well done.
 
 
 posted in The Promised Land on Dec 31, 12 3:55 AM
I love this game and glad I bought it. It is better then the othe type of games like this one. The only thing I find annoying is the little blighters seem to be always hungry and I cannot produce enough food for them, but as all the games we learn as we go. Great game worth the money.
 
 
 posted in Island Tribe 3 on Sep 13, 12 2:18 PM
I can finish the level in normal mode but cannot find the artifact. Anyone able to tell me where this elusive little devil is, please.
 
 
 posted in Trial of the Gods: Ariadne's Journey on Jul 11, 12 2:36 PM
QEIII wrote:
booklover290 wrote:
QEIII wrote:Can anyone who has passed this level please help? I've tried and tried several dozen times to get this level. You only have 2.30 mins to get straw to 4 goats which is just over 30 secs per goat which is a ridiculously short time.

In other posts fishies say to use the power ups but I find they don't help at all. I use the gems which are a help but still I've not cracked it. I've been playing M3 for years and years and never had a level as hard as this.

I've played the adventure mode but found it far too easy and no challenge at all.

Can anyone help me PLEASE? You can PM if you want. I should think I would need detailed step by step instructions though, as I seem to have a complete mind blockage. I am willing to send

HELLO QEIII, DID YOU GET A REPLY TO THIS MESSAGE? i CAN NOT GET PAST THIS LEVEL. HELP


No I didn't so can't help you. Sorry. I deleted the game in the end. Far too frustrating.
 
 
 posted in Be a King: Golden Empire on Jun 5, 12 2:37 PM
Every time I get Exception warning and the game close I am told by the bfg wizards to update every thing. I am up to date so the next thing I am told is my video card is a bit old and a new one will get rid of this. But what happens in a few months or a year? they keep making games with more in them and the cards cannot keep up with it.
This started in the late 70's. My computer had 4mg and the new games wanted 8mg so what do we do but upgrade and this has been going on all the time and I do not believe it will ever be right unless we update parts every six months to a year. So you either buy the game or skip it and hopefully if it is not selling the developers might do some thing so we can play on "older" computers.
excuse any mistakes as I am only able to use one hand at the moment, broke the funny bone which is NOT very funny....
That is my advice about this exception nonsense as I have been using these contraptions both here and in the States since the late 70's and an fed up with upgrading all the time.
bye for now and hope you find a way around it...... "next day"...just to let you all know that today I have had a new 2gb Radeon HD6670 fitted at a cost of £100 or about $160 and I was plying a different game and guess what? Exception came up. so now tell me it is OUR machines... I am very pissed off spending this kind of money when it was nothing to do with the video card as the bfg helpers always seem to say. I do believe I should get the money put back on my card, some hopes... This is why I cancelled my subscription and will never buy another game, only problem is I have a free game token and cannot find a decent game to use it on. Anyway I hope this helps you all and you do not go and upgrade toan expensive video card just because of exceptions. It has to be the problem with bfg and they need to sort it out - if they can?????? bye for now fishes.
 
 
 posted in Royal Envoy 2 Collector's Edition on Jan 29, 12 11:17 AM
Thanks for the info bfgArnoStyx, I have finished the level several times with all the happiness and fish and within the gold time, but I cannot get the check in the box for the happiness. I will give your method a try and see if I can finally get on to 56.
Thanks again,
Nivlem007
 
 
 posted in Royal Envoy 2 Collector's Edition on Jan 27, 12 1:32 PM
Does anyone actually know how to get past this round? I have done it twice and both times I have followed the instructions, I get all the fish and all the happiness and all the little men come out and cheer, but it just hangs. Any help will be good, please.
 
 
 posted in Fairway™ on Jan 7, 12 12:21 PM
Any one know what this is? I cannot work it out. Maybe I am not thinking properly but have all the other Trophy's and this is the only one missing.
Thanks in advance.
 
 
key
 posted in The Clockwork Man: The Hidden World on Aug 17, 11 1:39 AM
At the graves of parents you have to place flowers, then find a heart shape to place in the angel, then a secret panel at the base of the father's grave opens and there is the key. Hope it helps. Now I am stuck on the safe in the professor's office. Oh what fun these games are.
 
 
 posted in Crop Busters on Jul 6, 11 8:03 AM
I started the game and within 3 mins. I received a violation box, but it came and went too fast for me to note. I tried the game a bit later and after playing nicely away for about 30 mins when I got a dog, it just kicked me out with no notice or anything just back to the game manager asking if I'd like to play again. So this will not be a buy until they fix this bug,
 
 
 posted in Mystery Novel on Apr 12, 11 1:05 PM
In my game the stirrups turned out to be Hand Cuffs??? Then I was looking for a Jimmy Bar??? Crowbar or Jemmy maybe? And I would love to know what "ARAENS" is??? Only play 23 Mins and have had enough!!!
 
 
 posted in The Treasures of Mystery Island: The Ghost Ship on Apr 4, 11 2:47 PM
After reading the first page I am wondering if I am using a super computer lol! I have had no trouble with the luggage, all pieces there and the fish symbol just came into my use section. So now I am wondering if I should buy this game or will it run perfectly on my computer? Hope so!
 
 
 posted in The Curse of the Thirty Denarii on Mar 30, 11 12:21 PM
I got the game to work fine on Win XP but what I cannot stand is the description of the items I am looking for. Sticks turned out to be branches and 2 Blades were actually 2 tears on the old man's face. The game the other day by the same people gave the item as a partition and it turned out to be a sheet of music. Pathetic when we are in the 21st C not 16thC. If they are going to make these games then they should get the description right so at least we know what we are doing.
 
 
 posted in Eden's Quest: The Hunt for Akua on Mar 4, 11 2:08 PM
I have used AVG for many years and never had a problem. What I find is the game manager plays up and I just re-boot and all is usually well.
 
 
 posted in Eden's Quest: The Hunt for Akua on Mar 4, 11 2:04 PM
phatkhat wrote:Sigh. Every carpy game I hate installs and plays fine. Get one I really want to play, nada.

On this one, I disabled AVG before I started, knowing there are conflicts. Then when the download started, At about 4,ooo kb, the word "validating" pops up and then the download continues. But it won't install. It will get to 99% and nothing happens. I've deleted and redownloading, but still see that "validating", and I'm sure it isn't going to play.

I guess I'll get rid of AVG and see what happens. I have NOT had this trouble on downloads from other sites, and I'm thinking it's the game manager...
 
 
 posted in Soul Journey on Mar 2, 11 7:53 AM
I'm running win XP home, with AMD dual core and GE Force 6200 Turbo 2 gig with booster at 32 and I have found that all games work. I have read a lot of complaints about games not playing and freezing etc. but I think the problem is with Win 7. I kept XP as I knew it was a good operating system and I can do without The Cloud etc. I have just as good programmes that all work very well.
 
 
 posted in The Curse of the Ring on Jan 5, 11 11:42 AM
You can't please all the people all time, only some of the time and if I don't like the look of a game I do not even try it or buy it whichever is the case, BUT it does not stop me from staying loyal to BFG. Most of the games will have their problems but is it really the games or our video cards? Mine will not take the Direct X 11 but that is MY fault not the game developers, all I have to do is save up for a decent video card and all will be well until the next time Ha! Ha! Just have fun and relax, stress only gives you a headache....
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator