Posts created by georgiarealist

 
 
 posted in Next Stop on Jul 18, 15 11:29 PM
I find myself replaying this one frequently. It's cute and not difficult - and not so clicky that it makes my hand hurt. As others have said, I'm hoping for a second installment with a few tweeks to make it more interesting.
 
 
 posted in Smoothie Standoff: Callie's Creations on Jul 18, 15 11:22 PM
As others have said, this game is repetitious and not particularly challenging - which is not entirely bad. (I'm one of those who can't stand the Emily series and ones like it.) As Janette5 has said, it's annoying that the levels end in the midst of serving customers. I prefer the games that have natural endings to the levels. This is one I only bought because I had a number of game coupons I needed to use.
 
 
 posted in Brownies on Jul 18, 15 5:45 PM
I'm having the same problem. The bubble shows the 2 workers when I use the bonus for the extra worker, but I can't get them to upgrade the barracks. Without upgrading the barracks, I can't clear the fence that takes 2 warriors, so I'm stuck. Don't see anything in the way - since I've built the basic barracks, there wouldn't be any obstacles left.

I ended up closing the game and restarting it, and then it worked. I'm not sure what was wrong before.
 
 
 posted in Brownies on Jul 17, 15 6:01 PM
Oddly enough, tigerdog1219, the scarecrow is on levels with the spider - it will give the spider something to wrap its web around instead of your workers. Like the cheese, it has to be renewed every time the critter attacks it.

Spookys_Mom, the cheese will show up on a wooden platform once you fix the platform. You'll know it when you see it.
 
 
 posted in Brownies on Jul 17, 15 5:57 PM
Janette5 wrote:Brownies is a resource collecting game like the 100s other like it. It does have an interesting story with dialogue before each level (which you can skip).

Basically you run around and collect stuff and clear stuff and fight off trolls, up to the end of my trial there was nothing really new or unique. You collect runes that give you power-ups. To activate the power-ups you need to collect beads that appear at random around the scene every now and again.

It does have a relaxed mode.


[b]Strategy:

I found this game to be more clicky than strategic. There is some strategy in deciding which building you're going to build or upgrade first but at that most it will require you to play a level twice. There was a lot of clicking - and you can click to make the workers work / move faster. A lot of the resources you have to collect. I did find the game had a nice pace, they were moving fast and there was a lot to do. I could get gold on all the trial levels by being fast rather than by thinking out a strategy.

....

Overall
I would recommend you try before buying and play past the levels with the critters and fly swatters. It appears a well-made and interesting game. I'm on the fence with this one, the absence of a lot of strategy and clicking critters is probably going to be a deal breaker for me.


I'm not finished, but I've found a few levels that do require strategy - if you go the wrong way, you'll find yourself unable to get enough of a resource to finish the level. Not many, but a few. The bigger problem for me is the levels that don't have the flyswatter option (or any other, like cheese for the crow or a scarecrow for the spider - odd choices, but useful). Those get pretty irritating.
 
 
 posted in Subliminal Realms: The Masterpiece Collector's Edition on Jul 11, 15 1:50 PM
Locked up my computer (Windows 8.1) when I tried to take the Manticore from the camera. Had to force a reboot, as Task Manager wouldn't work. Then when I went back in, it was ok until I was in Iris's room and needed the spray bottle nozzle. The Strategy Guide says to put the bells on the jack-in-the-box, but there's no jack-in-the-box where the picture shows it. Can't progress without it. I'm wondering if the crash affected this. I may try to reinstall and see if it works, but I won't buy it unless these issues are fixed. I'm tired of waiting for fixes that never come (Gardens Inc III CE comes to mind).

Follow-up: reinstalling didn't change it, so I poked around a bit and found the jack-in-the-box was actually in one of the paintings (where the hint had directed me). So the Strategy Guide, which is one of the main benefits of the CE, is wrong - not an encouraging sign. I like the game, but I'm wondering if the CE is worth buying even at a discount. I may just wait for the SE.
 
 
It's a very pretty game, but it locks up every time I go to a new location, and sometimes when I open the Strategy Guide. I'd have bought it with the sale, but when I can't even get through the Demo (already 3 times of CAD and restarting my laptop - Win 8.1, of course - in less than an hour), I'm not going to waste money on it. I have one game now that I can't finish because of an unfixed glitch, and am not interested in buying another that has so many pages of similar tech issues going back 9 months. BFG needs to pressure developers to actually fix the games they release or else stop selling the games from these developers.
 
 
Dax is correct - the Collectables in the Extras shows you a rack with all the bamboo sticks you've collected, and empty slots where one is missing. Clicking on the empty slot takes you to the scene so you can find the bamboo sticks - and once all are collected, they make a scroll of the stories. You will have to click each empty slot - you're taken back to the Extras once you collect a missing stick.

Now, if someone could tell me how to find the morphing object in the 4th HOP, I'd be grateful. I've stared at the screen for so long my eyes hurt, but I simply don't see anything morphing! The Guide doesn't list the morphing objects, either, so I guess I'll rest my eyes and try again.
 
 
 posted in Avalon Legends Solitaire 2 on May 4, 15 6:28 PM
The good part is the ability to replay individual hands instead of groups of hands (the reason I didn't buy the first Avalon Legends was the group replay factor), and that there are a LOT of levels. This should keep anyone who likes basic solitaire games happy for a long time.

The bad part is making it so hard to exit the game. I can't see any good reason the ll button to bring up the settings and thus the ability to exit to the main menu - even that isn't spelled out, you have to click the little house at the bottom of the screen - is only available in the actual game play screens instead of the village between hands, or even the map.

As far as gathering resources between hands, I don't object to it (but I like TM games, especially the gather and build ones), but so far don't see any real reason for it. Athough you can sometimes choose which building to build, and the buildings affect what options you have in buying the bonus features like jokers and such (btw, the jokers cost more than the wild cards, not the same amount), that's the only customization feature available. The buildings go where the game puts them, period.

As solitaire games go, this is a good relaxing one. After the frustrations of Solitaire Perfect Match, I'm more than ready for relaxing!
 
 
 posted in Gardens Inc. 3: A Bridal Pursuit Collector's Edition on Apr 26, 15 2:56 AM
Coffesaurus wrote:
Janette5 wrote:Error message for the developers - pops up at the end of Level 17

NullReferenceException: Object reference not set to an instance of an object stack trace:
Creature.setAnimation(System.string animNan Creature +<WaitNextFrame>c_iteratorA.MoveNext()


You're missing a bracket - it's not me accidentally leaving it off!

I could continue - the error message just popped up over the level dialogue.


I just got this error message at the end of level 17. I downloaded the game yesterday, April 11, 2015, and I see that the above message was from last December. Has there been no fix for this in the last four months?



No, and it's useless to contact Customer Service. I sent in the Dr Felix report, and they replied with the usual form email asking for a Dr Felix report. Then they wanted me to run an anti-malware program I'd already run - claimed malware might cause this. I never heard of malware that would only affect one game, much less one that would result in what are obviously error messages designed for the developers. It insults our intelligence to make a claim like that, to say nothing of wasting time repeating steps already taken (and which won't help anyway). The beta version worked, so there's no excuse for them not fixing this.
 
 
 posted in Animism: The Book of Emissaries on Apr 25, 15 9:15 PM
Robcol wrote:Well folks I liked this game. It is imaginative and the graphics are fun.


I liked it too, although it was sometimes pretty frustrating, but I seem to be at the end all of a sudden - and the story isn't over. I suppose there's another episode coming, from the sound of it. Sure hope they improve the "hint" button on the next one.
 
 
 posted in Animism: The Book of Emissaries on Apr 25, 15 8:58 PM
shelob9993 wrote:Where is the pesty pestle???


It's in the hidden compartment that opens when you put the bucket full of water on the pressure plate (to the right in the cave).
 
 
 posted in Animism: The Book of Emissaries on Apr 25, 15 8:25 PM
I can't get back there to find the right spot, but it's on the right wall of the right hand cave, as I recall. The obvious spot was more or less straight ahead for the other gem, but this one I couldn't see at all - just run your cursor over the wall and it should pop up with the instructions to move the gem to its socket. That's how I found it. (I'm currently stuck looking for herbs in a cave, myself.)
 
 
 posted in Animism: The Book of Emissaries on Apr 23, 15 11:42 AM
The spot to put the red gem is hard to spot - I only found it when I accidentally ran my cursor over the place. It's on the right, but it doesn't really look like the other gem places did.
 
 
 posted in Animism: The Book of Emissaries on Apr 23, 15 11:39 AM
PuffishLady wrote:My major complaint is there is no interactive map. You keep going from one place to another. Ex. collecting nuggets: you go to the stream, cabin, stream, cabin.
This is very boring.

I agree with the other reviewers.

This game is in need of some tweaking.


That's my biggest complaint, too - that, and the fact that the inventory "fills up" and you have to go back to the cabin to post photos or melt gold nuggets before you can finish collecting all you need. What, photos can't be stacked? A bit too much realism in the way you have to keep wandering around the forest to find things. Also, for those of us with less than perfect eyesight, it's a bit hard to find some of the items - one of the "doors" where a gem has to be placed is essentially invisible and was only found when I accidentally ran my cursor over the place. The hint only told me I needed to place the gem, but had no advice on where to find the place.

I haven't finished yet, but I'm intrigued enough to continue. I don't think it's a HOG or even has HOS, at least in the traditional sense. I'm not sure what to call it. There are some other mini-games - connecting the electricity, and moving gems to their sockets (one of those where every move causes surrounding spaces to open or close) - but nothing really difficult so far. I bought this because of the sale yesterday, but wouldn't have if it had been full price.
 
 
 posted in Easter Riddles on Apr 7, 15 7:20 AM
Based on the trial period, this is another just like other griddlers except with Easter images. I guess I'm spoiled by the Gizmo and Fantasy Mosaics ones, because I just don't find these appealing any more. The constant screens with basic info (defining columns and rows, and telling me numbers read left to right - really?) are irritating, the small images that are never clarified when you finish one, and the fact that these don't auto-complete when you fill in the row or column just makes it tedious to me. I generally enjoy the genre, but I'm not currently desperate enough for one of these to even use a credit on this. Like I said, I'm spoiled - I'd rather replay the others.
 
 
 posted in Solitaire Perfect Match on Apr 5, 15 4:48 PM
Update - I discovered that level 85 requires the points in 60 seconds, but not that all cards be cleared, so I concentrated on matching colors (red in this case) and managed to get 3 stars in the 60 seconds. Of course, I still need more stars to get out of the 8th section, but that's another issue. It's quite a frustrating game, though.
 
 
 posted in Solitaire Perfect Match on Apr 4, 15 1:50 AM
I don't know if I'll ever get to the end of this game. It's something I dip into for a little while most days, replaying levels to get the elusive extra stars I need to advance, but there are a few levels that seem to be nearly impossible (the torn cards ones in particular) - it's all very well to know you get more points/coins for sequences of same color matches and identical matches, but when there are no identical cards in the stack you can't really do that. This means there's little strategy involved in a lot of the levels, just a matter of playing until random chance gives you enough matching cards to get the necessary points. When it takes multiple tries to get enough to even get 1 star so you can get to the next hand, I simply don't have the patience to try repeatedly to see if some miracle will let me get an additional star.

At this point, I'm up to level 85, which combines the worst aspects of this game by being one of the infamous 60-second levels and also requiring enough coins that you can't get 1 star by simply matching any cards to get through in time. I don't know how to get past this level with my sanity (and hands) intact.

I don't really mind the timed levels, although I agree the description of the game is deceptive. But the others I've encountered were simple timed levels, which were not all that hard. Level 85, though, is a whole different kettle of fish.

As others have said, this game is harder than it needs to be and less interesting. Having to repeat levels multiple times in order to advance is bad enough, but it would be tolerable if there were more strategy involved - rather like some of the time management games where I don't mind going back to replay levels to get gold because I can try different strategies.
 
 
 posted in Toy Factory on Jan 21, 15 2:22 PM
I like TM games (except the Emily ones and those similar to them - the rushing around ones), and this is cute, but I'm getting frustrated at how hard it is to get the goals even on the Easy setting. I think Easy ought to be, you know, easy. Or at least possible. The tutorial, as others have mentioned, is hard to understand and not very helpful. There is very little explanation - and no guidance - on choosing the upgrades as they become available. I only discovered I could carry 2 food items by accident, since that little feature isn't mentioned. And I'm another who is frustrated that there's no way to carry 2 toys at once, or better yet have the instant delivery via right click method. I also find it frustrating that the drink machine only makes one of each kind at a time, especially on the levels where you have several tables of elves that all order the same one - purple for the old elves, or green for the ladies (and why is the green one so much slower to refill?).

On the whole, this is a game I will periodically work on until I finish it, and then will probably never play again.
 
 
 posted in 12 Labours of Hercules III: Girl Power on Jan 6, 15 5:05 PM
So far I've only played the Casual Mode, which I found easier than the first 2 in this series. Not altogether a bad thing, as I think it should be reasonablly easy to get gold in casual mode for those of us who aren't looking for a major challenge. I'll probably try the harder mode and see how far I get next, and since I gather the accomplishments for beating the developer score are only available in the hardest mode, I may eventually try that too - I like to get the accomplishments.

As stusue said, there is strategy in some levels even in casual mode. I aso found myself having to start over at least twice because I'd used up all of a resource that I needed to continue and had no source to get more. It's not obvious at first.

I do think the little puzzle pieces are easier to find in this one than the previous games - none of them were underwater or hidden behind something to only show up after you'd moved something. There was only one level where I had to go back and replay to find it.

I enjoy these games and don't really see why it should be considered a "girl" game. I like the building-type tm games, but dislike the Emily series intensely (and most of the similar rushing around ones). I will admit that I prefer gardening, farming and such to the darker themes like zombies (athough I find the zombie solitaire one amusing).
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator