Posts created by KeysPirate

 
 
 posted in Evil Pumpkin: The Lost Halloween on Oct 27, 16 7:46 AM
This was a big disappointment for me, too. Evil Pumpkin is a truly great game, which I've just finished playing for the second time. I would gladly buy it again if I could get the whole game.

Please, Big Fish, give us an answer on this. Can't you negotiate with the developers to get the full game? Please?
 
 
 posted in Evil Pumpkin: The Lost Halloween on Oct 25, 16 12:30 PM
Had me going crazy, too. But really, as with most of the extraordinarily clever puzzles in this game, you need to pay attention to ALL of the clues. Did you consider that there is a symbol with the words? Do the math...
 
 
 posted in Evil Pumpkin: The Lost Halloween on Oct 23, 16 12:16 PM
Have you ever worked the handle of a real pump? Sometimes it takes a little elbow grease.

Friendly advice... make your subject more specific, e.g. Trouble with pump in order to help people see what you need help with.
 
 
 posted in Evil Pumpkin: The Lost Halloween on Oct 23, 16 12:12 PM
No worries. Be patient.
 
 
 posted in The Last Dream on Feb 7, 16 12:45 PM
I was having trouble, too, but finally realized that the problem was in the placement of the pearls. I kept trying to move one against two others and it would not allow the move. You have to line it up fairly precisely with the other pearls -- not too close, not too far. Once I learned how to make them click into place, the puzzle was easy. Looks like there are many ways to do it. I had 2 moves left.

What was really hard was finding a post that had to do with the pearl puzzle. Wish the post here had included "pearl" in the subject line.

As for the SKIP, I had to choose a difficulty level when I started the game. Didn't pick the hardest level because I was concerned that I might have to skip a puzzle. So far, I haven't needed to, though I was about to do it on the pearl puzzle!
 
 
 posted in The Last Dream on Feb 5, 16 5:43 PM
Thanks... I definitely missed a match on the central gear. The puzzles are all great - not too easy but not frustratingly hard. Hope you will come out with a new game of this style and quality.
 
 
 posted in The Last Dream on Feb 1, 16 7:09 AM
I have all the gears lined up but nothing happens. Have tried several times. Can anyone give me a hint? I really don't want to skip any puzzles. LOVE this game!
 
 
 posted in Timeless: The Lost Castle on Aug 21, 15 8:43 AM
It certainly is! I loved the artwork so much that I played rather slowly, taking time to watch beautiful snowflakes falling and admire the icicles and textures. This is a challenging game. I played on Expert Level, but a few times when I got stumped I switched to Casual to see if I was missing an item combination or to use the Hint to get moving in the right direction. Of the hundreds of Big Fish games I've played over several years, Timeless ranks in my top 25. But I suspect that some gamers who appear to want to "beat" games as quickly as possible might find it frustrating because of its clever complexity and difficult puzzles.
 
 
 posted in Christmas Eve: Midnight's Call Collector's Edition on Jul 26, 15 2:52 PM
I can't figure this one out. The contraption doesn't look like what is shown in the SG -- there's no butterfly net that I can see. There is a sort of depression that has the shape of a net but it is not "touchable." The only thing I can do is click the magnifying glass to enlarge the instructions. Looks like wrapping paper is around the cylinder and a wing is laying on top, but I can't place those items.

Without the net, I can't find anything else to do. Anyone have a clue?

Marsha
 
 
 posted in Atlantic Quest: Solitaire on May 10, 15 3:33 PM
I clicked but nothing happened. It sure didn't seem like I had 5 seconds ... more like 1 second and the claw disappeared and I didn't destroy any cards. Has anyone out there successfully used this, and can tell me what I am doing wrong?

Marsha
 
 
 posted in Gizmos: Spirit Of The Christmas on Dec 17, 14 4:14 PM
Tried 1024x768, same error. Must be my video card... That's okay, I was just going to try the demo. There are plenty of other games I can play.
 
 
 posted in Gizmos: Spirit Of The Christmas on Dec 14, 14 4:03 AM
Downloaded demo, clicked PLAY, got error message:

Your monitor does not support the required screen resolution.

Does anyone know what that resolution is? I have a fairly new computer and monitor, which is currently set to 1920x1080 but I can change to pretty much anything.
 
 
 posted in Fall of the New Age on Oct 3, 14 12:12 PM
Looks like everyone played this game in January... I'm late to the party! Hope someone is still listening.

I have the blue powder and the recipe, and have taken the beaker off the stove, but the game in the cupboard with the glass tubes says I need steam to get it going. I have no idea what to do. I still need the green powder.

Someone mentioned playing a dice game? Where? I am lost.

Of all the games I've ever played, this is one where a strategy guide or walkthrough is really needed.

 
 
 posted in Alice: Behind the Mirror on Aug 22, 14 9:55 AM
The download and install worked, but I was forced to install DirectX. No BigFish game that I've played has ever required this. It took a while, and installed updates from as far back as 2005. I thought that was rather strange. Can anyone tell me (in basic terms) what DirectX is needed for, and why this particular game requires it? Should I be concerned about having it on my computer?

Thanks.
 
 
I'm stuck trying to get the heart going. Can't figure out where to use the screwdriver. I would appreciate just a tiny tiny hint, as I really like to figure out all of the puzzles without resorting to the SG or walkthrough.

I love these puzzles! Especially when I finally figure them out on my own. But dang, I am seriously stuck here and cannot come up with any logical clue on the screwdriver.
 
 
I'm a little late playing this game, but in case someone else is still having problems with this one, I can help with just a couple of vague hints. It is a great puzzle, and I wish I could have completed it without getting a hint or two.

It is logical in a strange way. You really do have to just mess with things and watch carefully to see what happens. If you do something, like moving the gull and you don't notice anything, keep trying and looking around. Then you will say AHA!

Even the tricky 3-digit code is logical, if you think about it. The numbers that you find are not in any sort of obvious order, right? So... might different sequences produce different results?

Most everything else involves a bit of trial and error. But still logical! Keep trying until you get the result that makes sense.

The one silly thing that really had me stuck was moving the anchors. I kept clicking and nothing happened. I should have figured that one out, and hope you will, too.

I am really loving this game. Everything, including the remarks, are fun, funny and very clever. You definitely need to use your brain!
 
 
 posted in PuppetShow: Destiny Undone Collector's Edition on Jan 27, 14 7:20 AM
Update to my earlier review...

After finishing the game I replayed the circle game from the Extras and it worked perfectly. All the levers worked, it was logical, and it wasn't all that hard.

I hope there is a #5. I don't care if there are new or old characters, I just want a good, CLEVER, intriguing game. (But you do need a native English speaker to review your translations...)

Thanks for a great game. I'm now looking for other ERS games that I missed.
 
 
 posted in PuppetShow: Destiny Undone Collector's Edition on Jan 20, 14 9:36 AM
Obviously, I am a little late in playing this game, but am hoping ERS is still out there listening.

I love this game. I could go on and on about all the great stuff, not the least of which are the artwork and really fun puzzles, but the quality that makes your games stand out above all others is the CLEVERNESS . I am continually surprised and delighted by the bizarre things you put in the HO scenes as well as the game locations. I love the mechanical gizmos and the cardboard cutouts.

There are some little misnomers and glitches here and there (wish I could have been a Beta tester for you) but none are serious. EXCEPT...

...The circle puzzle on the submarine or blimp or whatever it is. I am hopelessly stuck and frustrated, because I really do not want to skip it.

Having searched through the Forums, I see that others have gotten stuck, but mostly on the 4th circle. I'm stuck on the 3rd. The outer blue circle will not move as it is apparently supposed to. I followed the SG instructions to no avail.

I am wondering if this has anything to do with the fact that I started the puzzle before getting the dynamite. The game did allow me to start, but then everything froze, so I resorted to the SG, which alerted me to the HO scene at the shack.

Then when I went back to the circle puzzle, I was able to get through the first and second ones (have no idea how, as the in-out buttons didn't seem to do anything), but all I can do in the 3rd one is move the inner two blue circles back and forth between the blockers.

I don't think there is anything you could tell me that would help, so I will reluctantly skip it and continue on, but would be very happy if you could confirm that there is a real glitch here. Maybe in future games (and I do hope there will be more Puppet Shows!) you could incorporate a RESET in your puzzles so we at least have a chance to see if starting afresh would help.
 
 
 posted in Nevertales: The Beauty Within Collector's Edition on Dec 31, 13 9:49 AM
I'm not sure whether I am really finished. I completed (I think) all 3 books, and now back in the reception area, the only thing I can do is go into the Ali Baba book. But there is nothing to do there, according to the hint.

What makes me wonder if there's something left to do is that there appears to be an outline of a rose on the wood below the 3 books. All through the game I assumed I would eventually find something to put there. Yes or no?

Also, when I go to Collectables there is still a portal on the top shelf.

According to the Strategy Guide, once you finish the gingerbread house, you've completed the whole game. Did I?

I hope someone can help me with this. The game is really astounding in its complexity and sheer length, and I would hate to miss any part of it -- which I almost did before I figured out that I could find the missing roses after finishing the game!
 
 
 posted in Weird Park: Scary Tales on Sep 12, 13 2:00 PM
Hi lsr103,

I'm playing on a PC and am also stuck on the heart-spade-diamond-club chest. I've tried restarting and doing it over and over, but like you said, there doesn't seem to be any other combination. I really don't want to hit the Skip button. Somewhere else I read that the "correct sequence" is scratched on a piece of wood, but that doesn't seem to apply to this puzzle.

Did you ever figure this out?

I have not had any of the technical issues others have reported, except that it didn't fill my screen until I unchecked widescreen. Some graphics are a little fuzzy but that's okay since I really love this game.

Marsha
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator