Posts created by hagglebag

 
 
 posted in Grim Facade: Broken Sacrament Collector's Edition on Apr 13, 18 9:18 AM
Was playing ok until I called the boatmen over. Took me across to the landing stage then completely froze couldn't ctrl Alt Del so had to turn the computer off. I am running windows 10.

 
 
The first time I tried to download I had an error code. In the subsequent 2 tries, downloaded fine, but each time said my free trial was over. Using windows 10.
 
 
 posted in Haunted Hotel: Personal Nightmare Collector's Edition on May 25, 17 4:49 AM
Thanks CiChDa. I've started under a new profile and it's working fine now.
 
 
 posted in Haunted Hotel: Personal Nightmare Collector's Edition on May 25, 17 4:43 AM
I've signed the contract at the hotel and now it won't close down for me to continue. I have to Alt Ctrl Del for me to come out of the game. When I go back in it is again waiting for me to sign contract. It will only let me choose 1 option for what you fear most. Is that right?
 
 
 posted in Artifact Quest 2 on Feb 13, 17 5:02 AM
I can download the game ok, but my security system has isolated the file and wont let me open it to play. I don't want to go against the security system, so it's one game I wont be trying. Using Windows 10 64 bit
 
 
 posted in Dark Romance: Kingdom of Death Collector's Edition on Apr 21, 16 6:43 AM
Hint and Skip button not working???

Try going to settings and onto the mode that you set yourself. I reduced the hint and skip time but I also had to click on the hint and skip button to highlight them to make them work. Hope this helps. Also using windows 10.
 
 
 posted in DragonScales 2: Beneath a Bloodstained Moon on Feb 24, 16 2:55 AM
unable to download this app. Keeps telling it's timed out Error Code 2. Running Windows 10.
 
 
Re-started game, screen had cleared itself, then time was up!!!
 
 
For the scene when you first enter Ravenhearst Manor and meet the mechanical man it takes you to first hidden object scene which is blank with just the word "mans head" with gobbledegook written for hint, blank lines for menu etc. press the hint button which works so could complete the HO. Once completed and come out, the hint, menu etc "mans head" are still there on screen. Using Windows 10. I had 2 mins left on trial.
 
 
 posted in Dracula's Legacy on Aug 10, 15 6:06 AM
Has downloaded but screen is "double" as if it's 3d out of sinc. Using windows 10
 
 
Was having freezing and slow cursor problems. Turned off the "special effects" button in options, now running smoothly. Running windows 10
 
 
 posted in I Know a Tale on May 20, 15 2:35 AM
Thanks for the heads up. I also use windows 8.1. Didn't want to take the risk so deleted without opening.
 
 
 posted in Dark Romance: Heart of the Beast Collector's Edition on Apr 23, 15 3:51 AM
Windows 8.1 PC Collected flag from statue screen went black. CT Alt DL to get out. Restarted game and within 2-3 mins game froze. Needs to be sorted because I certainly won't consider buying it, as it is.
 
 
 posted in Lost Lands: The Four Horsemen on Feb 13, 15 7:00 AM
I've just played the demo of the SE and I didn't notice any morphing or other objects to collect except for the scrolls. Perhaps I just missed them?
 
 
 posted in Mystery Tales: The Twilight World Collector's Edition on Jan 24, 15 4:53 AM
Game froze for me also. Only just started. Had to shut down computer completely as Ctrl, Alt. delete didn't work. Have uninstalled and will not re-install until fault(s) have been rectified. Running windows 8.1.
 
 
 posted in Grim Tales: Color of Fright on Dec 5, 14 7:14 AM
Running Windows 8.1. Can't get bear to stand on box. I guess that's another problem not solved during the duration of the CE. No buy for me.
 
 
 posted in Ghosts of the Past: Bones of Meadows Town on Sep 7, 14 7:08 AM
I'm running windows 8.1. Game runs fine until I want to exit. The game then freezes. Tried using cntrl, alt, delete and the screen goes completely black. Have to turn the computer off on the mains button. This has happened twice now. When you go back into the game manager it shows that I still have 90 mins left, but allows me to continue from where I tried to exit.
 
 
 posted in Lost Souls: Timeless Fables on Jun 6, 14 8:12 AM
I am also having the same problem with the beach scene in Robinson Cruscoe . White screen with black blotches. Picked some items up but can do nothing because can't see!!!
 
 
 posted in Haunted Hotel: Ancient Bane Collector's Edition on May 29, 14 6:43 AM
I got it to work by uninstalling game, then reinstalling and using a different name. Worked fine then.
 
 
 posted in Haunted Hotel: Ancient Bane Collector's Edition on May 29, 14 5:18 AM
I am operating on windows 8.1. Hope that helps.
 
 
 
 
 
 
 
 
Go to:   
 
 
 
KEY:    Unread    Read    Sticky    Locked    Announcement    Moved    Moderator